We have moved to a new Sailfish OS Forum. Please start new discussions there.
0

Connecting to Jolla via SSH over USB from Fedora 19?

asked 2014-03-20 15:16:46 +0300

sugnea gravatar image

updated 2014-03-20 16:20:06 +0300

Fedora 19 is using NetworkManager so the setup in https://wiki.merproject.org/wiki/Nemo/USBNetworking for /etc/network/interfaces I couldnt use, other than as a pointer for what to do.

Anyway I have setup an Ethernet connection on my computer for the jolla and the network tool has created the following files

/etc/sysconfig/networking/devices/ifcfg-jolla
TYPE=Ethernet
BOOTPROTO=none
DEFROUTE=no
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
NAME=jolla
UUID=c0ef376f-6a23-43a8-9af6-a7dd4d5866fd
ONBOOT=yes
USERCTL=no
HWADDR=FA:D4:92:3E:EA:51
IPADDR0=192.168.2.15
PREFIX0=24
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes

/etc/sysconfig/network-scripts/ifcfg-Jolla
HWADDR=FA:D4:92:3E:EA:51
TYPE=Ethernet
BOOTPROTO=none
IPADDR0=192.168.2.15
PREFIX0=24
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME=Jolla
UUID=51d7082e-7d93-4908-8992-6b9271ce7fa8
ONBOOT=yes

When I plug jolla in

ifconfig -a reports 
usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.2.15  netmask 255.255.255.0  broadcast 192.168.2.255
        inet6 fe80::f8d4:92ff:fe3e:ea51  prefixlen 64  scopeid 0x20<link>
        ether fa:d4:92:3e:ea:51  txqueuelen 1000  (Ethernet)
        RX packets 3  bytes 196 (196.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 25  bytes 4779 (4.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Ping is fine

[root@parkroyal ~]# ping 192.168.2.15
PING 192.168.2.15 (192.168.2.15) 56(84) bytes of data.
64 bytes from 192.168.2.15: icmp_seq=1 ttl=64 time=0.027 ms
64 bytes from 192.168.2.15: icmp_seq=2 ttl=64 time=0.035 ms

but I cant login! either as nemo or root

[stewar02@parkroyal ~]$ ssh nemo@192.168.2.15
nemo@192.168.2.15's password: 
Permission denied, please try again.

I havent changed anything in /etc/ssh on the jolla

I am a bit stumped with what to do next. Any suggestions?

edit retag flag offensive close delete

Comments

Go to settings->developer mode and set a password. Just under remote connection.

Philippe De Swert ( 2014-03-20 15:47:37 +0300 )edit

I did that. Didnt include that in the post as I thought it was obvious :-)

sugnea ( 2014-03-20 16:01:17 +0300 )edit

1 Answer

Sort by » oldest newest most voted
5

answered 2014-03-20 16:51:48 +0300

It seems to me that in your desktop config (generated by NetworkManager), you provided 192.168.2.15 as IP address, which is the one used by the Jolla by default. If so, you must choose an other one on your desktop, let's say 192.168.2.14.

When pinging, you are pinging yourself, and you're trying to connect to your desktop machine, and cannot since nemo is not a valid user on the desktop.

I did the same mistake, so if it's the case, don't worry you're not alone ;)

edit flag offensive delete publish link more

Comments

Well spotted! Indeed that seems to be the issue!

Philippe De Swert ( 2014-03-20 16:54:16 +0300 )edit

Hurrah!

Yes Damian good spot. I could have stared at that all day and not got it!

Thanks Aengus

sugnea ( 2014-03-20 17:04:44 +0300 )edit

Ah, "welcome back to home" connection .. this is good joke .. sometime .. :)

Kaacz ( 2014-03-20 21:36:42 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-03-20 15:16:46 +0300

Seen: 671 times

Last updated: Mar 20 '14