Ask / Submit
1

[solved] ssh login with public key broken [answered]

asked 2014-03-21 00:02:54 +0200

vbregier gravatar image

updated 2014-03-21 08:34:05 +0200

Hi all,

Since uptade 1.0.4.20, I cannot login to my jolla via ssh using my public / private rsa keys. My key is correctly registered in ~/.ssh/authorized_keys, with correct 0600 permissions. But the ssh server refuses it. It worked before the update.

The key is correctly set up on the client, since I can connect on a remote server without password. This is not a network problem, since I can login just fine if I enter the password. But I want to connect without password, with publickey…

I tried to edit /etc/ssh/sshd_config, but I did not manage to make it work.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by gabriel
close date 2014-03-21 10:56:26.868830

Comments

2

I use pub key authentication too but this isn't broken for me at all. Any errors in journalctl?

gabriel ( 2014-03-21 00:10:43 +0200 )edit

SSH via key works for me after update.

Blizzz ( 2014-03-21 01:34:04 +0200 )edit

I have the latest Version (2.0.4.14) and it doesn't work for me. I appended my id_rsa.pub to .ssh/authorized_keys, but I still need to type my password. I need the public key method for automatic mounting of the jolla file system via sshfs.

triessner ( 2016-11-15 14:44:53 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-03-21 08:33:29 +0200

vbregier gravatar image

updated 2014-03-21 08:34:26 +0200

Ok I found out the problem.

Thank you for journalctl command; I was looking for ssh logs in /var/logs/syslog, but there is no such file.

The problem was /home/nemo, which had write permissions for group.

chmod g-w /home/nemo solved the problem.

edit flag offensive delete publish link more

Question tools

Follow
1 follower

Stats

Asked: 2014-03-21 00:02:54 +0200

Seen: 572 times

Last updated: Mar 21 '14