Ask / Submit
13

Why do we get: "NOTICE: Env value ignored ..." during shell login?

asked 2014-03-21 02:22:20 +0200

00prometheus gravatar image

updated 2014-03-29 04:29:40 +0200

When logging in via ssh or fingerterm, I am getting various warnings about: "NOTICE: Env value ignored ...". Right now, I am getting warnings for:

NOTICE: Env value ignored LC_NUMERIC=sv_SE.utf8
NOTICE: Env value ignored LC_MEASUREMENT=sv_SE.utf8
NOTICE: Env value ignored QT_GSTREAMER_CAMERABIN_FLAGS=15
NOTICE: Env value ignored QT_WAYLAND_RESIZE_AFTER_SWAP=1
NOTICE: Env value ignored LC_TIME=sv_SE.utf8

I could of course set those variables again in my login-scripts, but I don't like doing things like that, a bit too much cargo-culting for my taste. Why does this happen, and how do you prevent it from happening?

(The LC_* entries are probably because I have tweaked my locale according to: http://www.jollatides.com/2013/12/16/how-to-tweak-jolla-system-locale/ but they still shouldn't be ignored!)

EDIT: OK, so the accepted answer explains how to get rid of the warning message, however, I still don't understand why this functionality exists? Which environment variables should I white-list and which ones should I black-list? What are my selection criteria?

edit retag flag offensive close delete

Comments

3

+1 - Ditto - I get 2 warnings but only when using SSH, not in fingerterm though.

NOTICE: Env value ignored QT_GSTREAMER_CAMERABIN_FLAGS=15

NOTICE: Env value ignored QT_WAYLAND_RESIZE_AFTER_SWAP=1

Regards,

Edz ( 2014-03-21 02:38:14 +0200 )edit

It's interesting that you don't get it in fingerterm... Have you applied the fix to make fingerterm execute login-scripts and place you in home directory rather than root directory? The fix is here: https://together.jolla.com/question/1537/fingerterm-terminal-defaults-to-as-current-working-directory/

00prometheus ( 2014-03-21 18:00:05 +0200 )edit

No changes or fixes/scripts applied to fingerterm. I'm quite happy with the way it works and I'm no expert with CLI (still learning). Before updating to 1.0.4.2 I was only getting the QT_STREAMER... message, then after the update (full reset) i got the QT_WAYLAND.... message. I'm not too fussed, it doesn't seem to affect anything, but ultimately yes, It'd be nice to not see ERROR:!! :)

Edz ( 2014-03-21 18:14:00 +0200 )edit

Same here. Got two warnings. Very annoying. I would appreciate if someone can give me a hint. Did make already a grep for that string. But didn't find it.

fblm ( 2014-03-24 09:49:22 +0200 )edit

1 Answer

Sort by » oldest newest most voted
7

answered 2014-03-24 16:15:07 +0200

Turski gravatar image

updated 2014-03-24 20:49:04 +0200

00prometheus gravatar image

These notices are printed by /etc/profile.d/developer-profile.sh on line 99:

echo "NOTICE: Env value ignored $ENV_PAIR"

If you really want to mute those notices, comment that line and substitute it with : or true. After that it should look like this on lines 98-101:

        if [ $? -ne 0 ]; then
            # echo "NOTICE: Env value ignored $ENV_PAIR"
            :   
        else

EDIT: Alternatively, you can add the name of the variable to the black-list or the white-list in the same file. Depending on what list you add the variable to, it will either be silently ignored, or silently copied to your shell environment.

edit flag offensive delete publish link more

Comments

3

Thanks for that answer! At least I know where to look now :-) I added the variables I added myself to the white-list, but now I wonder, why don't we want to simply copy all environment variables to the shell session? For example, why should or shouldn't we have "QT_WAYLAND_RESIZE_AFTER_SWAP" set in the shell session?

00prometheus ( 2014-03-24 20:28:04 +0200 )edit

I tried Turski's instructions, I ended up with with even more messages/errors all over the ssh login. There is every chance I did something wrong though! I didn't make a record of what the new errors/warnings were, sorry. Still be nice to see it sorted though - JOLLA! ;)

Edz ( 2014-03-24 21:14:35 +0200 )edit

Did you add the ":" on the line under, to replace the commented-out line? Otherwise you have a syntax error.

00prometheus ( 2014-03-24 21:17:37 +0200 )edit

@00prometheus - yes, I added the ":" ~ copied it to the 'letter' so to speak and commented # the line too.

I'll try again at some point. If it has worked for you, then I have clearly not edited correctly - By the way, what do you use for editing files on your PC? (or perhaps you do it all on the Jolla??).

Edz ( 2014-03-24 23:54:44 +0200 )edit
Login/Signup to Answer

Question tools

Follow
8 followers

Stats

Asked: 2014-03-21 02:22:20 +0200

Seen: 688 times

Last updated: Mar 29 '14