We have moved to a new Sailfish OS Forum. Please start new discussions there.

Can't access Settings - Apps - Email anymore since Ohijärvi update [answered]

asked 2014-03-21 07:15:38 +0300

goldenm gravatar image

updated 2014-03-21 07:25:49 +0300

For some reason I can't access Settings - Apps - Email anymore since Ohijärvi update. When I try to open it, it just disappears and throws me right into 'open apps' - page. I've tried to uninstall the native email app, but reinstalling it didn't solve the problem (didn't remove my google mail accounts while doing it). Also battery remove for a couple of minutes didn't help. What to try next, is anyone else having this? I can access the other Apps' settings from the same page, just something is wrong with Email.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by goldenm
close date 2014-03-22 09:21:09.065331


@goldenm - Have you checked also this related question ?

Kari ( 2014-03-21 09:14:41 +0300 )edit

@@goldenm - Can you collect logs ?

With developer mode enabled and as root, do:

journalctl -af

Try to open that settings page and then pastebin the output or send it in a file to mail-logs at jolla dot com. Thanks

VDVsx ( 2014-03-21 16:25:39 +0300 )edit

Found this warning in log

Mar 21 16:03:45 localhost msyncd[967]: [W] Buteo::ProfileManagerPrivate::parseFile:1096 - Failed to parse profile XML:  "/home/nemo/.cache/msyncd/sync/syncemail.xml" 
Mar 21 16:03:45 localhost msyncd[967]: [W] Buteo::ProfileManagerPrivate::load:152 - Failed to load profile: "syncemail"

setting file syncemail.xml is 0 byte, i deleted it and let the client recreates a new working file

raptors ( 2014-03-21 18:01:04 +0300 )edit

Hi,after today's update I seem to have the following Issue.Clicking on settings-accounts-gmail pushes me out to the open apps page.I tried deleting the syncemail.xml as per the solution mentioned ,but I still cannot create a gmail account.All other accounts such as yahoo,microsoft exchange,facebook are accessible except for gmail.Please advice

Blacksphere ( 2015-04-16 20:07:30 +0300 )edit

@Blacksphere - What do you mean by "pushes me out to the open apps page" ?

VDVsx ( 2015-04-17 08:24:51 +0300 )edit

1 Answer

Sort by » oldest newest most voted

answered 2014-03-21 19:10:55 +0300

goldenm gravatar image

updated 2014-03-22 09:19:59 +0300

Thanks Raptors & VDVsx! Those were the exact lines in my Jolla's log too, so I did the same thing and removed "/home/nemo/.cache/msyncd/sync/syncemail.xml" -file with File Browser --> an instant success! No more chrashing in that settings page and also it seems to have fixed automatic sync errors on google mail accounts that I was using.

edit flag offensive delete publish link more


Happened to me after a crash, and this helped! Thanks!

Macilaci457 ( 2014-03-24 15:40:44 +0300 )edit

Thank you ! This helped me as well.

tvicol ( 2014-03-31 12:25:33 +0300 )edit

Helped me as well! Syncing had to be done manually and couldn't access the settings, now it seems to work. If you use File Browser, remember to go to File Browser -> Pulley menu -> Settings and enable 'Show hidden files". At least I had to do that.

J_W_PEPPER ( 2014-04-01 15:05:10 +0300 )edit

I've had this issue after update.. thanks for this fix.

Maettu ( 2014-04-12 00:27:23 +0300 )edit

Same here, I had the issue after The fix helped. Thank you

cocof2001 ( 2014-04-12 09:47:23 +0300 )edit

Question tools



Asked: 2014-03-21 07:15:38 +0300

Seen: 1,074 times

Last updated: Mar 22 '14