mobile data doesn't connect when enabled [duplicate]

asked 2014-03-23 17:08:53 +0200

kearnage gravatar image

updated 2014-07-12 03:21:01 +0200

simo gravatar image

This is new in 1.0.4.20. When I enable the mobile data it doesn't connect until I open an app that requires the connection. Before the update, the phone would connect straight away after enabling.

Edit: issue still exists in 1.0.5.16

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by kearnage
close date 2014-04-28 21:54:00.101854

Comments

First things first; Go to settings and turn off the Internet connection.

Then go to System below and select Mobile Network.

Under Mobile Internet (or similar wording, it seems to vary) you should now see that the Internet connection is Disabled. Tap on it to enable it.

Go back to settings main screen, you should now be connected to the internet again - At least this is how it works on my Jolla.

Try it and see how you get on :)

You should now have a permanent connection and apps shouldn't ask for connection.

Regards,

Edz ( 2014-03-23 17:18:28 +0200 )edit

That didn't work for me :( I still see the same behaviour

kearnage ( 2014-03-23 17:36:28 +0200 )edit

for me it did not connect even with the browser open

chemist ( 2014-03-23 17:55:13 +0200 )edit

I had this behaviour already with earlier firmware versions. The only app which is forcing the mobile data to connect is mail. The connection is then closed again after a certain time and wouldn´t reconnect before i check my mails, other apps won´t which use mobile data aren´t able to bring back the connection.

Stefan P ( 2014-03-23 19:11:52 +0200 )edit