Ask / Submit
0

email POP3 Problem with sync, sign-in [answered]

asked 2014-03-24 01:23:41 +0300

pmelas gravatar image

Cannot connect to my GMX email provider using POP3, in my account configuration I use SSL, port 995 with password, the reported error is: Problem with sync the debug info shows:

 [Debug] Messaging :  QMailTransport::Socket::Socket SET PROXY host= "" port= 0 
 [Debug] Messaging :  Opening connection -  "pop.gmx.net" : 995  SSL 
 [Debug] Messaging :  POP : connection established 
 [Debug] Messaging :  POP : Secure connection established 
 [Debug] POP :  Connected 
 [Debug] POP :  RECV: +OK POP server ready H migmx104 0Ll8vH-1WzXOe2TXa-00ay7Q 
 [Debug] POP :  SEND: "CAPA" 
 [Debug] POP :  RECV: +OK Capability list follows 
 [Debug] POP :  RECV: TOP 
 [Debug] POP :  RECV: USER 
 [Debug] POP :  RECV: UIDL 
 [Debug] POP :  RECV: SASL PLAIN 
 [Debug] POP :  RECV: IMPLEMENTATION trinity 
 [Debug] POP :  RECV: . 
 [Debug] POP :  SEND: "USER xxxxxxx@gmx.net" 
 [Debug] POP :  RECV: +OK password required for user "xxxxxxx@gmx.net" 
 [Debug] POP :  SEND: "PASS <password hidden>" 
 [Debug] POP :  RECV: -ERR authentication failed 
 [Debug] Messaging :  void SSOSessionManager::credentialsNeedUpdate() Setting credentials need update for the service  "pop3" from account  13  using authentication method  "password" 
 [Warning] Would not determine server/action completing 
 [Debug] identityimpl.cpp 103 updateState Updating state:  NeedsRegistration 
 [Debug] identityimpl.cpp 103 updateState Updating state:  NeedsRegistration 
 [Debug] identityimpl.cpp 103 updateState Updating state:  NeedsRegistration 
 [Debug] identityimpl.cpp 103 updateState Updating state:  NeedsRegistration

Trying to send an email I get Problem with sign-in

 [Debug] SMTP :  newConnection 
 [Debug] SMTP :  Open SMTP connection 
 [Debug] Messaging :  QMailTransport::Socket::Socket SET PROXY host= "" port= 0 
 [Debug] Messaging :  Opening connection -  "mail.gmx.net" : 465  SSL 
 [Debug] Messaging :  SMTP : connection established 
 [Debug] Messaging :  SMTP : Secure connection established 
 [Debug] SMTP :  Connected 
 [Debug] SMTP :  RECV: "220 gmx.com (mrgmx102) Nemesis ESMTP Service ready" 
 [Debug] SMTP :  SEND: EHLO [127.0.0.1] 
 [Debug] SMTP :  RECV: "250-gmx.com Hello [127.0.0.1] [86.159.142.234]" 
 [Debug] SMTP :  RECV: "250-SIZE 69920427" 
 [Debug] SMTP :  RECV: "250 AUTH LOGIN PLAIN" 
 [Debug] account-service.cpp: 167 onChanged 
 [Debug] account-service.cpp: 167 onChanged 
 [Debug] account-service.cpp: 167 onChanged 
 [Debug] Messaging :  Custom Field: "qmf-smtp-capabilities-listed" = "true" 
 [Debug] SMTP :  SEND: AUTH PLAIN Njc0MDM2MEBnbXgubmXXXXXXNDAzNjBAZ214Lm5ldABvYXBSMSQyMTI2 
 [Debug] SMTP :  RECV: "535 Authentication credentials invalid" 
 [Debug] Messaging :  void SSOSessionManager::recreateSsoIdentity() Recreating SSO identity using auth method  "password" 
 [Debug] authsessionimpl.cpp 174 initInterface 
 [Debug] authsessionimpl.cpp 270 process sending to queue 
 [Debug] dbusoperationqueuehandler.cpp 135 execQueuedOperations Executing cached oparation: SIGNATURE: "process(SessionData,QString)" 
 [Debug] dbusoperationqueuehandler.cpp 147 execQueuedOperations 
 [Debug] authsessionimpl.cpp 265 process sending to daemon 
 [Debug] SMTP :  Got SSO response 
 [Debug] SMTP :  SEND: AUTH PLAIN Njc0MDM2MEBnbXgubmxxxxxxNDAzNjBAZ214Lm5ldABvYXBSMSQyMTI2 
 [Debug] SMTP :  RECV: "535 Authentication credentials invalid" 
 [Debug] Messaging :  void SSOSessionManager::credentialsNeedUpdate() Setting credentials need update for the service  "smtp" from account  13  using authentication method  "password" 
 [Debug] SMTP :  Closed connection: "535 Authentication credentials invalid
" 
 [Debug] Messaging :  Action completed 5879810228227 result failure 
 [Debug] identityimpl.cpp 103 updateState Updating state:  NeedsRegistration 
 [Debug] identityimpl.cpp 103 updateState Updating state:  NeedsRegistration 
 [Debug] identityimpl.cpp 103 updateState Updating state:  NeedsRegistration

Thanks

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by VDVsx
close date 2014-03-26 15:03:48.249435

Comments

Are you sure about your POP and SMTP settings for GMX? (I use a gmx.co.uk address and the following settings are working, but I can also see there appears to be different settings for *.net GMX addresses).

Also, these are the settings my Winmail client on my Windows 7 PC uses for GMX.co.uk, but I use the settings on my Jolla to get the mail, without problem.

I have POP3 Server: pop.gmx.com (port 110)(NO SSL) SMTP Server: mail.gmx.com (port 25)(NO SSL)

Outgoing Mail Requires Authentication (use same settings as Incoming Mail)

If you have successfully used your settings before, then ignore this post.

Regards,

Edz ( 2014-03-24 12:38:02 +0300 )edit

gmx.net, gmx.com use different settings. I might have done something wrong with my settings, but the same settings work with thunderbird, i.e. incoming SSL 995 password, outgoing smtp SSL465 password. Sailfish Mail account settings assumes that account incoming and outgoing service settings are the same, but the authentication mechanism is not for this case?

pmelas ( 2014-03-24 14:20:54 +0300 )edit

ah, okay, I found differing information on gmx, I see what you're saying.

Yes, agreed, my incoming and outgoing passwords are different and adding a second account threw up that problem. I think I must have tried around 8 times before it accepted the password. There doesn't seem to be any specific order in which to make it 'stick'!

Edz ( 2014-03-24 15:13:07 +0300 )edit

Errors are clear: RECV: "535 Authentication credentials invalid"

Your login details are not accepted by the server in both situations.

VDVsx ( 2014-03-25 13:08:25 +0300 )edit

Thanks, I managed to fix incoming mails, user login name was wrong ;-( I still get error with outgoing mail tho.

pmelas ( 2014-03-25 22:38:33 +0300 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2014-03-24 12:26:39 +0300

slava gravatar image

I think I saw this happen after I entered wrong password when I was creating a new POP account. Changing the password later didn't help, I had to delete and re-create the account. If this trick works for you too, please let us know and I'll file a bug.

edit flag offensive delete publish link more

Comments

I will try to recreate the account and try again, it might be some thing wrong with my settings, here is the recommended settings from the provider: https://hilfe.gmx.net/mailprogramme/pop3.html

pmelas ( 2014-03-24 14:27:14 +0300 )edit
0

answered 2014-03-26 00:23:06 +0300

pmelas gravatar image

updated 2014-03-26 10:58:10 +0300

gmx.net correct settings Here is my pop3 settings for my gmx.net email account that work for me:

Incoming mail server: 
username: xxxx@gmx.net
Server address:  pop.gmx.net
Secure connection: SSL
Port: 995

Outgoing mail server: 
username: xxxx.gmx.net (same as incoming, user name here used to be an ID)
Server address: mail.gmx.net
Secure connection: TLS
Port: 587

Authentication: password

Thanks for your help

edit flag offensive delete publish link more

Comments

SMTP also complains about wrong authentication: SMTP : RECV: "535 Authentication credentials invalid" and in above logs your are using different settings: "mail.gmx.net" : 465 SSL. so please double check those.

VDVsx ( 2014-03-26 09:11:12 +0300 )edit

@pmelas - So works now ? If so please close the question. Thanks.

VDVsx ( 2014-03-26 12:37:09 +0300 )edit

@VDVsx not sure how to close it, do I have enough karma? I've accepted an answer.

pmelas ( 2014-03-26 14:28:34 +0300 )edit

Done :) Thx!

VDVsx ( 2014-03-26 15:04:11 +0300 )edit

Question tools

Follow
2 followers

Stats

Asked: 2014-03-24 01:23:41 +0300

Seen: 1,858 times

Last updated: Mar 26 '14