We have moved to a new Sailfish OS Forum. Please start new discussions there.
4

GMail two-phase auth still not working

asked 2014-03-28 15:19:48 +0300

Mr. Zdeeck gravatar image

Hello all,

unfortunatelly the Google two-phase authentication is still not working for gMail. Our company has migrated to gMail/gApps as standard communication interface with two-phase auth enabled. Scenario:

1) no account defined except my personal IMAP & Jolla
2) I create Google account
3) enter credentials, enter sent SMS code, approve everything, everything seems fine. then:

a) contacts get synchronized (one time only)
b) calendar gets synchronized (one time only)
c) mails seem to be trying to synchronize but finally fail, since then in notifications the "Account needs to be updated" message is nearly persistent
d) the instant messaging (Hangouts) works (!!), which really strange (my presence is "online" and everything seems to be fine, messages get delivered, etc)
e) and also, when I deleted the gMail account for this test, the whole call history disappeared :-((

Right now I must use the gMail android app to read my job-mail, which is kind of annoying - I've purchased Jolla to be more-or-less without Android :-(

I've got the latest Sailfish (1.0.4.20) version, and my gMail didn't work for past three Sailfish versions.

--Z

edit retag flag offensive close delete

Comments

My personal google account works just fine with the sms-auth, but I don't currently have any paid google apps for business-accounts. Will test this real-soon-now..

tigeli ( 2014-03-29 00:08:01 +0300 )edit

My Google Apps for Business is working. It seems now to work also through regular Google account synchronisation as well as through Microsoft Exchange connector. Before 1.0.4.20 I used the Exchange connector to synchronise my email, calendar and contacts.

Karri Huhtanen ( 2014-03-29 12:09:44 +0300 )edit

Hi Mr. Zdeeck,

Thanks for the report. Do you have developer mode enabled, and if so, are you willing to help me debug this issue?

If so, can you please try the following, and then send me the logs to chris dot adams at jolla dot com -- thanks!

systemctl --user stop msyncd.service

wait for a few seconds

kill -9 `ps -C msyncd -o pid=`

wait for a few seconds

SOCIALD_LOGGING_LEVEL=3 devel-su -p msyncd

then in a different terminal:

dbus-send --session --type=method_call --print-reply --dest=com.meego.msyncd /synchronizer com.meego.msyncd.startSync string:'google.Contacts'

and also

dbus-send --session --type=method_call --print-reply --dest=com.meego.msyncd /synchronizer com.meego.msyncd.startSync string:'google.Calendars'

That should give me enough debugging logs to figure out what is going on, in your particular case.

Thanks!

Chris.

chris.adams ( 2014-04-08 07:24:24 +0300 )edit

Hello Chris,

sorry for the delayed answer, but I was on the way-too-long trip to answer in the wilds of South Asia. Now I'm back and ready to hack&debug! ;-)

To be honest like 3 weeks ago I've realized that Google Contacts are kind-of synchronized and the same works for the Calendar. I cannot search through our company shared contact book (as with N900 and Exchange connector), which is kind of dumb (and gMail native android client is definitely able to do this) - but this is, I guess, only missing feature. Concerning Calendar the situation is also so-so - the events/meetings status (accepted/mayber/declined/unanswered) and details (attendees) is not shown in my calendar, but at least it's somehow working.

I went through your instructions and the logs seem OK. On the other hand GMail (e-mail) synchronization still doesn't work. I would like to send you logs from mail sync, but I just don't know where to look.... :-(((

Please, guys, do the debugging/hacking much easier - why don't we have logs for every component in reasonable verbosity level switched on by default and rotate them after lets say 1M? No dbus sh*t, no services, no cryptic components. Just good ol' plain tail -f /var/log/.... ?

Cheers,

--Z

Mr. Zdeeck ( 2014-05-21 22:29:28 +0300 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2014-04-07 14:58:44 +0300

Larswad gravatar image

updated 2014-04-07 15:28:56 +0300

This is STILL buggy (Ohijärvi), google 2 step SMS authentication has never worked for me. It keeps annoying me that the google account needs updating, even though my SMS password seems to work and I get to the point where I click the "Save" button. Few moments later it still asks me for authentication of google.

The strange thing is that in google applications, like Play it seems to be authenticated fine. But as an account in Jolla terms (probably functionality like messaging, syncing etc.) it just doesn't seems to authenticate itself. Something doesn't get properly persistent, I am sure of it.

My update to Ohijärvi went fine, so its not an upgrade thing. I don't know if its a hint to the problem or not, but somehow I seem to have two google accounts associated with the mail address I use to authenticate myself with. Only one account is the one I use and the other was at some point an account that was created by mistake. Even so, I DO get to choose which account I want to use on the webform that appears after I entered the SMS code.

edit flag offensive delete publish link more
0

answered 2014-03-28 15:30:20 +0300

Tibo gravatar image

updated 2014-03-28 15:31:05 +0300

The two-step authentication with Gmail works for me.

But I don't receive a code via sms, I'm using the Google Authenticator app (https://play.google.com/store/apps/details?id=com.google.android.apps.authenticator2).

Can you try this way?

edit flag offensive delete publish link more

Comments

Still not working. :-( Maybe there's the difference that we have enterprise-level gmail access. Can anybody try?

Mr. Zdeeck ( 2014-03-28 17:06:21 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-03-28 15:19:48 +0300

Seen: 441 times

Last updated: Apr 07 '14