We have moved to a new Sailfish OS Forum. Please start new discussions there.
14

[1.0.7.16/18] [bug] Cover art doesn't work

asked 2014-03-31 11:12:33 +0300

Whippler gravatar image

updated 2014-06-18 10:19:01 +0300

Music added before updating to latest version still has working cover art. Recently added music (flac) with both folder.jpg, and metadata albumart, doesn't get recognized anymore.

Also i tried resetting the tracker, explained here: https://together.jolla.com/question/30984/album-art-in-media-player-randomly-does-not-show/

edit retag flag offensive close delete

Comments

1

flac album and folder.jpg don't work on my Jolla too.

magullo ( 2014-03-31 15:01:15 +0300 )edit
1

same problem with ogg (vorbis) files.

Jef ( 2014-04-10 17:05:03 +0300 )edit
1

Still doesn't work in 1.0.7.16/18

Whippler ( 2014-06-18 10:18:53 +0300 )edit
1

Album art has never shown shown for my .ogg files

stevexley ( 2014-06-19 09:32:31 +0300 )edit
1

Has generally worked for me for .ogg and .mp3 files. I generally use a cover.jpg file placed in each album's directory. I have however not been able to figure out why some directories with the cover.jpg file works and some don't. Not until now that is. I have not checked all of my collection, but there is a strong indication that it works when the cover.jpg file is not typed with a capital C (i.e. Cover.jpg) It certainly does not work with the capital C. Hope this helps. Haven't figured out how to persuade the tracker to revisit the cover.jpg files and generate the wanted abum-artist and -title md5sum files for me.

vaurien ( 2014-07-06 02:31:11 +0300 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2014-10-03 23:19:49 +0300

Feffe gravatar image

I don't know about folder.jpg (didn't know that was supposed to be a feature), but I may have some idea about the flac covers. I also noticed that some of my flac files was mssing cover art, but then I started to reformat and reindex the SD card with my library many times while troubleshooting this issue: https://together.jolla.com/question/50744/media-no-longer-recognising-album-info-after-update-10819

But the old .flac-files still show the artwork just fine, so I compared the metadata from my last working flac-file to the oldest non-working one, and lo and behold:

$ metaflac --list working_file.flac| grep vendor
vendor string: reference libFLAC 1.2.1 20070917

$ metaflac --list not_working_file.flac| grep vendor
vendor string: reference libFLAC 1.3.0 20130526

So I think this is an issue with flac files created with libflac 1.3.0. Could you check your files to confirm?

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-03-31 11:12:33 +0300

Seen: 678 times

Last updated: Oct 03 '14