Ask / Submit
25

[Bug] SMS stuck in 'sending' [released]

Tracked by Jolla (Rejected)

asked 2014-03-31 17:20:12 +0200

Alex gravatar image

updated 2017-08-19 00:04:28 +0200

malibu1106 gravatar image

Sometimes (about 5 times a month) I am experiencing a strange bug with the native messages app:

I am trying to send a sms to my friend and the status shows 'sending' all the time. The intended recipient won't receive the sms even after some hours and after rebooting the device and also the status won't change after both actions.

To solve this bug I have to reboot the device, copy the sms (which is still in 'sending') and give it a second try. This behaviour is happening randomly and I don't know what could cause this.

EDIT : Still present on 2.1.1.24 ( ~40% of time - Operator : Sosh (Orange FR) Frequently sms are received normally but status stays on "sending" for a while)

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by Alex
close date 2019-03-18 13:15:23.436638

Comments

2

I experienced similar bug today with my Jolla (latest firmware). SMS was stuck to "sending.." status so I sent another test SMS to my another phone. Same effect, stucks to "sending".

Booted my Jolla and soon after that the test SMS arrived, also statuses of the SMS's had changed to delivery time, same as boot time.

My carrier network is Sonera, Finland.

Juska ( 2014-04-18 10:04:56 +0200 )edit
1

This bug was present even on the Nokia N9, though there it was shown 20 times more often...

Nenderus ( 2015-04-09 13:34:38 +0200 )edit

Same problem. Every days or 2 days. It's a little bit boring, this and the launching time of message app .. :(

In case you got this bug, you can refresh home, it's faster than reboot ;)

malibu1106 ( 2015-08-05 11:50:54 +0200 )edit

It's probably not the same bug, but in case it helps anyone, I experienced similar SMS-sending-hanading symptoms in 2.0.0.10, and the fix was to run pkcon install commhistory-daemon. More details in my full answer to question: https://together.jolla.com/question/116196/sms-troubles/?sort=votes&page=1#131408

mdengler ( 2016-03-12 06:34:56 +0200 )edit
3

I get this from time to time as well. To me it feels related to receiving same SMS multiple times as in both cases an ack is lost, either from network to Jolla (sending) or from Jolla to network (receiving).

Mohjive ( 2016-10-27 14:53:01 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-03-18 13:13:22 +0200

Alex gravatar image

According to the release notes of Sailfish OS 3.0.2 this issue finally has been fixed:

https://together.jolla.com/question/201102/release-notes-302-oulanka/#201102-messages

edit flag offensive delete publish link more

Question tools

Follow
7 followers

Stats

Asked: 2014-03-31 17:20:12 +0200

Seen: 676 times

Last updated: Mar 18