We have moved to a new Sailfish OS Forum. Please start new discussions there.
10

How can I transfer media to Jolla on Ubuntu 14.04?

asked 2014-04-01 21:54:33 +0200

Harakiri gravatar image

updated 2015-08-16 23:35:48 +0200

rainisto gravatar image

When I enable the USB connection (PC connection mode), nothing happens. I f**king hate this MTP! Please enable USB Storage or give a free hammer to the users.

I installed mtpfs - didn't work. I installed gmtp - couldn't detect anything. Didn't work.

On the other hand, when I connect my Nexus 7, it works immediately via MTP. As well as Samsung Galaxy S2.

edit retag flag offensive close delete

Comments

1

@tuniek look at his profile. He was last seen in February. I think this question should be merged with Why is Jolla/sailfish so hard to connect to linux?

jollailija ( 2015-08-17 14:53:02 +0200 )edit

@ jollailija fact :)

tuniek ( 2015-08-17 14:56:09 +0200 )edit

9 Answers

Sort by » oldest newest most voted
1

answered 2014-04-01 22:44:27 +0200

m_josenhans gravatar image
  1. Connect Jolla device via USB to the computer.
  2. On Jolla device select "PC-Connection"
  3. A new file explorer pops up on Ubuntu.
  4. Go to Sailfish/Phone Memory/Pictures folder
  5. When you try to open the pictures directly in Ubuntu, you will get a message "Could not open image - Failed to open input stream"
  6. Thus copy the pictures from Sailfish/Phone Memory/Pictures folder into another folder on Ubuntu
  7. Open the pictures from copy destination folder (where the pictures copied to)
  8. Have fun!!!
edit flag offensive delete publish link more

Comments

Fails at step 3, as I said. Nothing happens.

Harakiri ( 2014-04-01 23:10:37 +0200 )edit
1

I am using Ubuntu 14.04 64 bit version.

m_josenhans ( 2014-04-02 10:16:24 +0200 )edit

I use 32bits Ubuntu. MTP works but is very unstable. Sometimes I have to reboot the phone before to plug it again in order to have it available.

I don't know who is to blame between sailfish and ubuntu

Tigre-Bleu ( 2014-04-02 11:37:48 +0200 )edit

I have tried with gmtp on Ubuntu 14.04 64-bit. That worked from me in both directions. I have downloaded multiple 0.9 GB Ubuntu iso image files to the Scard and back again. I do not have seen a sign of instability. Could you check the Ubuntu 64-bit version? Note: I have the developer mode not activated.

m_josenhans ( 2014-04-03 10:29:28 +0200 )edit

I just tried using nautilus, never tried gmtp. I mostly use it to transfer music to the phone.

I have no 64 bit ubuntu to test on, sorry

Tigre-Bleu ( 2014-04-03 16:28:57 +0200 )edit
1

answered 2014-04-02 10:48:27 +0200

Slavov Welsinksi gravatar image

On 13.10 I had the same problem as you have now and I was dumbfounded as to why it just worked for other people. Since upgrading to 14.04 64bit beta my phone is recognized as mass storage. Perhaps try upgrading to a newer kernel to see if that fixes it.

When I was stuck on 13.10 I used to copy files over via bluetooth, sd card or SSH.

edit flag offensive delete publish link more

Comments

1

I have the same problem now. It's no longer recognised.

Slavov Welsinksi ( 2014-04-05 22:28:44 +0200 )edit

it works on 14.04 lts 32 bits for me. sometimes i need to plug in twice. but thats it during the last 6 months (had always recent version)

pawel ( 2015-08-16 21:18:33 +0200 )edit
1

answered 2014-04-02 12:20:11 +0200

fblm gravatar image

ssh and corresponding scp is very convenient. With a bit of changes around sshd_config you can even use public_key authorization.

edit flag offensive delete publish link more
1

answered 2015-08-16 18:53:08 +0200

tuniek gravatar image
  1. sudo apt-get install mtpfs
  2. Edit: /etc/fuse.conf uncomment: user_allow_other and mount_max = 1000
  3. restart udev or whole Ubuntu
  4. connect your Jolla handset via USB ... and enjoy

TESTED with Ubuntu 14.04

edit flag offensive delete publish link more

Comments

This also works for me (Ubuntu 12.04)

SKyd3R ( 2015-08-24 10:49:05 +0200 )edit
0

answered 2014-04-01 22:00:20 +0200

thisisme gravatar image

I have developer mode enabled and transfer files through ssh from my computer to Jolla. But sometimes USB mass storage could be handy...

edit flag offensive delete publish link more

Comments

1

How can I access the external SD card via SFTP? If I try to go to /data/media/ I get "remote readdir("/data/media"): Permission denied"...or is it at some other location? There's /mnt/sdcard, but nothing there.

Harakiri ( 2014-04-01 22:11:10 +0200 )edit

It's nowadays under /media/sdcard/...

hzb ( 2014-04-01 22:39:56 +0200 )edit
1

Oh, right...now I can access that. Thanks.

Harakiri ( 2014-04-01 22:50:56 +0200 )edit
0

answered 2014-04-02 13:21:53 +0200

je gravatar image

updated 2014-04-02 13:57:28 +0200

Hi. Just an idea. Please check at your Jolla settings -> USB -> Standard USB Mode. There is an option for "only charging". Change to "always ask". As I use german ui maybe the terms are slightly different. Hope that helps

edit: sorry, did not read that you enabled the connection. But another point: your on ubuntu 14.04 which is beta at the moment. Please check on launchpad if there is a known error with libmtp or gvfsd-mtp.

edit flag offensive delete publish link more
0

answered 2015-08-16 19:24:06 +0200

Get Ubuntu 15.04. For me it's working flawlessy out-of-the-box, every time. I'm using Ubuntu 15.04 64bit and Sailfish OS 1.1.6.27.

edit flag offensive delete publish link more

Comments

Ubuntu is a low-quality distro as is, but non-LTS versions are simply beyond bad, they are raw beta versions thrown out to be tested by users. If a non-LTS version works for you, it only means that you are lucky.

ScumCoder ( 2015-08-16 21:19:02 +0200 )edit

According to my experience Sailfish is the only low-quality distro here.

SuperPhone ( 2015-08-16 21:57:50 +0200 )edit
0

answered 2015-08-16 20:25:17 +0200

gfwp gravatar image

On Debian Jessie MTP works. Just do not forget to EXIT developer mode. Otherwise, strangely the access is not complete.

edit flag offensive delete publish link more
-1

answered 2014-04-01 22:47:26 +0200

stephan gravatar image

Easy. Just enter "mtp:/" in dolphin (or whatever filebrowser you choose). But wait: I'm using Kde. Here's a link to a similar question I asked some time ago: https://together.jolla.com/question/8638/linux-access-phone-storage-via-usb/

edit flag offensive delete publish link more

Comments

1

I'm not sure if that helps, because as I wrote in my post, both Nexus 7 and SGS2 work via MTP. Jolla doesn't. But the problem could be anywhere.

Harakiri ( 2014-04-01 23:10:25 +0200 )edit

well, for me it works with jolla ...

stephan ( 2014-04-02 11:44:25 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-04-01 21:54:33 +0200

Seen: 2,890 times

Last updated: Aug 16 '15