We have moved to a new Sailfish OS Forum. Please start new discussions there.
3

How to send e-mails with web.de smtp? [answered]

asked 2014-04-01 23:00:25 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-04-01 23:00:25 +0200

m_josenhans gravatar image

The web.de E-Mail service requires usage of "StartTLS" as authentication method on port 587 of server smtp.web.de: https://hilfe.web.de/sicherheit/ssl.html#mailprotokolle

Using authentication "StartTLS" seems to fail. Thus sending of messages from Jolla phone does not work web.de.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by VDVsx
close date 2015-04-10 10:17:40.105697

Comments

It works for me. Are you sure you have no typo in username (without @web.de) or password? My settings are (in German):

  • Serveradresse: smtp.web.de
  • Sichere Verbindung TLS
  • Port: 587
  • Authentifizierung Passwort
rrunner64 ( 2014-04-01 23:34:00 +0200 )edit

Works for me, too... With similar settings.

Lutwolf ( 2014-04-02 00:20:24 +0200 )edit

No. Sorry, that does not work. When sending a written E-mail, the message "ANMELDUNG FEHLGESCHLAGEN" occurs, The Postausgang remains filled with the written E-mail.

m_josenhans ( 2014-04-02 00:21:55 +0200 )edit

From what I understand and what rrunner64's configuration suggests as well web.de doesn't support encrypted passwords. In other words the authentication option on the bottom should be set accordingly to password not encrypted password.

What is your setting?

minnist ( 2014-04-02 02:06:46 +0200 )edit

Doesn't work for me,too. I always get 'Synchronisation fehlgeschlagen' I have these Problems from the first firmware until now. Changed all params like encryption,tls,... Any chance/hint to get more information on a lower level - shell? We need a more exact error message here to see where the problem is.

asys3 ( 2014-04-02 07:43:54 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2014-04-02 00:46:00 +0200

leszek gravatar image

I am using the smtp.web.de server aswell with the TLS encryption setting and port 25 (I heard web.de from april on uses tls by default also on port 25). Authentication is set to disabled ('Nicht verwenden' in german).

edit flag offensive delete publish link more

Comments

Port 25 doesn't work either for me.

asys3 ( 2014-04-02 07:37:19 +0200 )edit

Port 25 seems to work for me, however I just called the Web.de support hotline. According to them the service on Port 25 will be disabled on 3. April 2014. (They are disabling unencrypted email access.)
Thus Web.de says we shall not should port 25, but port 587.

m_josenhans ( 2014-04-02 09:54:58 +0200 )edit

It turned out that I was using smtp/imap to send email with one email address and using another email address to sync the phonebook (no E-mail) using a ms exchange account. While I had activated the synchronisation of the exchange account, I could not send any E-Mail from the other account using smtp. When I deactivated the synchronization of the MS Exchange synchronisation I could send E-Mails from the other account. This seems to be a jolla bug.
This problem only occured with port 587, not with port 25.
@asys3: Have you got something similar?

m_josenhans ( 2014-04-09 15:55:33 +0200 )edit

Hmm... changed my web.de password and now nothing works neither imap nor smtp. And yes I updated the password. The whole mail client is not yet production ready.

leszek ( 2014-05-29 19:00:33 +0200 )edit

Try in web.de web interface settings reset the connetions of connected mobile clients.

m_josenhans ( 2014-05-29 19:23:00 +0200 )edit
0

answered 2015-04-10 10:14:09 +0200

m_josenhans gravatar image

It turned out that I was using smtp/imap to send email with one email address and using another email address to sync the phonebook (no E-mail) using a ms exchange account. While I had activated the synchronisation of the exchange account, I could not send any E-Mail from the other account using smtp. This bug had been fixed by jolla.

edit flag offensive delete publish link more

Comments

Here is a follow-up issue: E-Mail reply replies with E-Mail address from wrong E-Mail account

m_josenhans ( 2015-10-10 11:59:56 +0200 )edit

Question tools

Follow
2 followers

Stats

Asked: 2014-04-01 23:00:25 +0200

Seen: 1,777 times

Last updated: Apr 10 '15