Ask / Submit
138

WPA-802.1X (aka WPA enterprise) (eg. eduroam) support [duplicate]

asked 2013-12-27 16:35:01 +0200

nander gravatar image

updated 2015-01-06 04:18:40 +0200

bennypr0fane gravatar image

Hi,

I can't connect to my preffered wireless network, because jolla lacks support for WPA-802.1X (aka WPA enterprise).

It simply states that it can't connect to the network. I think the problem is user-interface related: the buttons simply miss to set it up right. Please add these options to the wireless network menu.

Duplicateof this question: https://together.jolla.com/question/315/wpa-8021x-enterprise-others-gui-wifi-support-needed-workaround/ Please leave your vote there!

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by WhyNotHugo
close date 2014-06-13 12:21:52.216090

Comments

3

Check also workaround.

pnuu ( 2013-12-27 16:42:12 +0200 )edit
6

This is very important feature!

LaruX ( 2013-12-28 22:59:25 +0200 )edit
2

Yes, hopefully this can be addressed in next update!

phoenixjyb ( 2013-12-29 16:25:46 +0200 )edit
1

I hope that they will support outer identity (i.e. anonymous login) then, because the workaround doesn't seem to...

tad ( 2014-01-12 20:21:33 +0200 )edit

This answer should be changed to a comment.

Mohjive ( 2014-01-12 20:58:57 +0200 )edit

5 Answers

Sort by » oldest newest most voted
25

answered 2013-12-27 16:38:29 +0200

llornkcor gravatar image

Sailfish OS does have support for WPA enterprise, but not all authentication methods. PEAP is what you need, I believe, and should be included in some future update.

edit flag offensive delete publish link more

Comments

4

That is exactly the case, PEAP is typically needed (eduroam in particular). There is a workaround (http://talk.maemo.org/showpost.php?p=1399365&postcount=2186) but it would be great to have it included in a future update.

mkk ( 2014-01-02 16:19:18 +0200 )edit

Some more info at http://talk.maemo.org/showthread.php?t=92057

Stuarty ( 2014-01-13 12:56:07 +0200 )edit

The workaround with manually creating the config file for connman worked straight away for me. Connected to company WiFi in TAG.

zlatko ( 2014-01-20 17:37:06 +0200 )edit

This workaround just stopped working for me with this latest update.

flyapen ( 2014-04-11 17:15:18 +0200 )edit
2

Up please? A bit odd it's "in some future update" since december, a core feature like that... :/ More useful than working on bluetooth connection maybe, but if it allowed me to go onto my university internet network, maybe I would be happy.

DaTa ( 2014-05-22 12:30:20 +0200 )edit
12

answered 2014-03-18 20:39:21 +0200

savar gravatar image

Please add support for WPA2 Enterprise. I need eduroam support.

edit flag offensive delete publish link more

Comments

3

I was realy hopeing that this feature was implemented with the latest update.

Stefan P ( 2014-03-18 22:49:44 +0200 )edit
5

answered 2014-03-14 13:55:55 +0200

khul gravatar image

This doesn't seem to work when the home institution requires anonymous identity connection. (Not supported by connman.)

edit flag offensive delete publish link more
3

answered 2014-01-28 19:33:40 +0200

jr gravatar image

ConnMan git contains now example eduroam .config file. See http://git.kernel.org/cgit/network/connman/connman.git/commit/?id=63aeaf6bc9effb08b47de155bb4fdbe2a1f4b4ba for details.

edit flag offensive delete publish link more

Comments

This example configuration in ConnMan git is insecure as it does not verify the RADIUS server certificate against anything. By using this it is possible to make a man-in-the-middle attack against you and your Jolla device.

Karri Huhtanen ( 2014-03-21 14:31:14 +0200 )edit
3

answered 2014-02-05 21:29:48 +0200

DavidH gravatar image

There is a small "hack" to get eduroam working. Try this: [http://talk.maemo.org/showpost.php?p=1399878&postcount=10] It works at my university.

edit flag offensive delete publish link more

Comments

Hm, I followed the indications, but it does not work, it just says "Sorry. Could not connect to selected network. Search again". Not sure how to learn from that

wcr ( 2014-02-26 11:37:05 +0200 )edit
1

Did you download the certificate separately and placed it into the folder " CACertFile=/etc/ssl/certs/ca-bundle.crt" ?

motka ( 2014-03-26 16:41:45 +0200 )edit

There's also a "Roamer" sailfish app for doing the config GUI-style.

Newa ( 2015-10-14 13:10:41 +0200 )edit

Question tools

Follow
37 followers

Stats

Asked: 2013-12-27 16:35:01 +0200

Seen: 6,431 times

Last updated: Jan 06 '15