We have moved to a new Sailfish OS Forum. Please start new discussions there.
35

MMS issues? Hints for debugging and helping us to improve

asked 2014-04-11 13:03:28 +0300

Aard gravatar image

updated 2014-04-24 17:34:03 +0300

Update: We're rolling out a hotfix for MMS today, which should fix several of the major issues reported by you. Thanks for all the help so far! We're still collecting data, so please keep contacting us if you still have issues not fixed or not mentioned in the comments to this post.


With the current update we've published initial MMS support. Unfortunately, MMS is technically a bit of a dinosaur, and several operators have slightly incompatible custom implementations. As a result of this we're expecting issues with many operators outside of Finland -- but still decided to push the current implementation early, and try to fix issues faster than we could on our own with your feedback.

This post contains some notes for technically skilled users with developer mode enabled. We're working on a simple application automating some of those steps, which will be published at a later point to enable less skilled users to help us improving MMS as well.

So, if you have problems with MMS..

  1. Was it possible to send a MMS? Many operators only let you receive MMS once you sent at least one MMS from your phone.
  2. No luck? Check if the MMS settings (Settings->System->Mobile network->MMS access point) are correct for your operator. If they're not correct, please provide the output of the following commands, plus correct settings, if you have them:
    • dbus-send --system --print-reply --dest=org.ofono /ril_0 org.ofono.ConnectionManager.GetContexts for the connection settings
    • dbus-send --system --print-reply --dest=org.ofono /ril_0 org.ofono.SimManager.GetProperties for details about your network
  3. Still no luck? Try to get debug output while sending or receiving MMS. Before sending/receiving (or retrying to receive), as user nemo, do
    • pkill mms-engine
    • mms-engine -vkat and send us the output from the terminal, as well as the contents of /tmp/mms

Info collected should be sent to mms-debug@jolla.com. Please note that this address is designed to easily collect debug information for our engineers, and can't be used as MMS support hotline. If you write us, please do a short post here about which provider and which problem you faced as well, to reduce duplicate submissions as much as possible. We'll try to comment here, and most likely only contact you by mail if we need additional debug output.

edit retag flag offensive close delete

Comments

To care@jolla.com or here?

Morpog ( 2014-04-11 13:52:00 +0300 )edit

I cannot send MMSs with Vodafone IT. I gathered all info from points 2. and 3., which is the email address to report them?

donaggio ( 2014-04-11 13:55:26 +0300 )edit
7

Swisscom will not even let you send MMS when you use an unknown model of phone (e.g. the Jolla). I had the same with the N900 and fmms back then.

The solution is to call their hotline and kindly convince them that your handset is capable of MMS sending and receiving. They will then enable it for your phone. However, when you place your SIM card in another phone and put it back in the Jolla, you'd have to call the hotline again.

Venty ( 2014-04-11 14:05:18 +0300 )edit

Is it working for Swisscom after calling the hotline or are there some issues?

thwint ( 2014-04-11 14:26:31 +0300 )edit

My operator is saunalahti, but the mms settings defaulted to elisa. Manually changed them to saunalahtis mms settings, and i am now able to send mms. I am not, however, able to receive MMS. I only get an sms from the operator with a link to where i can have a look at the mms. But i guess this is an issue with saunalahti/elisa and not with the jolla...

plipp ( 2014-04-11 14:40:51 +0300 )edit

35 Answers

Sort by » oldest newest most voted
0

answered 2014-04-24 23:04:54 +0300

Schturman gravatar image

updated 2017-06-11 15:33:47 +0300

Orange Israel also not work :( Tried to add proxy address and port in the setting, but Jolla not saved them. Output sent to mms-debug@jolla.com

the correct setting should be:
MMS Setting for Orange Israel.
Connection name: Orange MMS
APN: uwap.orange.co.il
username: orange
pass: mobile54
Proxy address: 192.118.11.55
Port: 8080
MMSC: http://192.168.220.15/servlets/mms

UPDATE: I spoke with my provider, probably they send me setting and now jolla allow me to save setting that I inserted manually (see above).
After reboot my phone can send and receive MMS :)


UPDATE (11.06.17):
Here is updated setting for Partner (Orange) and 012 mobile providers in Israel:
MMS Access Point:
--------------------
Connection name: Orange MMS
Access Point name: uwap.orang.co.il
Protocol: IP
Username: orange
Password: orange
Proxy address: 192.118.11.55
Proxy port: 8080
MMS message center:
http://192.168.220.15/servlets/mms
--------------------

Look at the APN, the name changed from "uwap.orange.co.il" to "uwap.orang.co.il" and password changed to "orange". I can send and receive MMS only when I on 3G connection... If I connected via wifi or 4G, I need first switch off wifi and switch 4G to 3G, only after this I can receive mms... Don't know why it not do this action automatically.
Output sent to mms-debug@jolla.com
Thanks.

edit flag offensive delete publish link more
0

answered 2014-04-28 17:17:19 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-04-28 17:17:19 +0300

Kollin gravatar image

Globul/Telenor Bulgaria works with the following settings:

  • Provider: Globul
  • Connection Name: Globul MMS
  • Access Point Name: mms.globul.bg
  • Username: mms
  • Password: [Blank]
  • Proxy Address: 192.168.87.11 NO ZEROS HERE
  • Port: 8004
  • MMS Message Centre Address:http://mmsc1.mms.globul.bg:8002

C:\fakepath\20140428171244.jpg

edit flag offensive delete publish link more
0

answered 2014-05-16 15:41:57 +0300

dsilveira gravatar image

tested version: 1.0.5.19

  • Country: PT

  • Operator: Meo

Receiving MMS with a vcard, from friend on same network, just says downloading, forever!

edit flag offensive delete publish link more
0

answered 2014-06-12 03:31:41 +0300

wilsoncompanyusa gravatar image

have to turn off wlan when receiving or sending with t-mobile in the us.

edit flag offensive delete publish link more
0

answered 2015-09-25 09:44:58 +0300

nick75 gravatar image
  • Provider: Hallon (3 Sweden)
  • Connection Name: Hallon
  • Access Point Name: data.tre.se
  • Username: [Blank]
  • Password: [Blank]
  • Proxy Address: 172.16.53.11 NO ZEROS HERE
  • Port: 8799
  • MMS Message Centre Address:http://mms.tre.se

Observe that Jolla automatically uses the proxy address 172.016.053.011, which does not work unless you first manually remove the zeros.

edit flag offensive delete publish link more

Comments

Took me quite a while and many tries, and searching here on TJC, before I tested to remove the zeroes in the proxy address. Then I finally got MMS sending and receiving to work. Running 1.1.9.28 when running into this issue, as a part of changing to a new provider.

nick75 ( 2015-09-25 09:46:35 +0300 )edit
Login/Signup to Answer

Question tools

Follow
20 followers

Stats

Asked: 2014-04-11 13:03:28 +0300

Seen: 9,512 times

Last updated: Jun 11 '17