Ask / Submit
35

MMS issues? Hints for debugging and helping us to improve

asked 2014-04-11 13:03:28 +0300

Aard gravatar image

updated 2014-04-24 17:34:03 +0300

Update: We're rolling out a hotfix for MMS today, which should fix several of the major issues reported by you. Thanks for all the help so far! We're still collecting data, so please keep contacting us if you still have issues not fixed or not mentioned in the comments to this post.


With the current update we've published initial MMS support. Unfortunately, MMS is technically a bit of a dinosaur, and several operators have slightly incompatible custom implementations. As a result of this we're expecting issues with many operators outside of Finland -- but still decided to push the current implementation early, and try to fix issues faster than we could on our own with your feedback.

This post contains some notes for technically skilled users with developer mode enabled. We're working on a simple application automating some of those steps, which will be published at a later point to enable less skilled users to help us improving MMS as well.

So, if you have problems with MMS..

  1. Was it possible to send a MMS? Many operators only let you receive MMS once you sent at least one MMS from your phone.
  2. No luck? Check if the MMS settings (Settings->System->Mobile network->MMS access point) are correct for your operator. If they're not correct, please provide the output of the following commands, plus correct settings, if you have them:
    • dbus-send --system --print-reply --dest=org.ofono /ril_0 org.ofono.ConnectionManager.GetContexts for the connection settings
    • dbus-send --system --print-reply --dest=org.ofono /ril_0 org.ofono.SimManager.GetProperties for details about your network
  3. Still no luck? Try to get debug output while sending or receiving MMS. Before sending/receiving (or retrying to receive), as user nemo, do
    • pkill mms-engine
    • mms-engine -vkat and send us the output from the terminal, as well as the contents of /tmp/mms

Info collected should be sent to mms-debug@jolla.com. Please note that this address is designed to easily collect debug information for our engineers, and can't be used as MMS support hotline. If you write us, please do a short post here about which provider and which problem you faced as well, to reduce duplicate submissions as much as possible. We'll try to comment here, and most likely only contact you by mail if we need additional debug output.

edit retag flag offensive close delete

Comments

To care@jolla.com or here?

Morpog ( 2014-04-11 13:52:00 +0300 )edit

I cannot send MMSs with Vodafone IT. I gathered all info from points 2. and 3., which is the email address to report them?

donaggio ( 2014-04-11 13:55:26 +0300 )edit
7

Swisscom will not even let you send MMS when you use an unknown model of phone (e.g. the Jolla). I had the same with the N900 and fmms back then.

The solution is to call their hotline and kindly convince them that your handset is capable of MMS sending and receiving. They will then enable it for your phone. However, when you place your SIM card in another phone and put it back in the Jolla, you'd have to call the hotline again.

Venty ( 2014-04-11 14:05:18 +0300 )edit

Is it working for Swisscom after calling the hotline or are there some issues?

thwint ( 2014-04-11 14:26:31 +0300 )edit

My operator is saunalahti, but the mms settings defaulted to elisa. Manually changed them to saunalahtis mms settings, and i am now able to send mms. I am not, however, able to receive MMS. I only get an sms from the operator with a link to where i can have a look at the mms. But i guess this is an issue with saunalahti/elisa and not with the jolla...

plipp ( 2014-04-11 14:40:51 +0300 )edit

35 Answers

Sort by » oldest newest most voted
7

answered 2014-04-12 03:41:40 +0300

Zandi gravatar image

updated 2014-07-07 10:24:18 +0300

jukey gravatar image

For German users of o2 Germany: configure your mms setup like this (for me this works):

Connection name: Internet; Access point name: Internet; Username: not needed; Password: not needed; Proxy address: 82.113.100.5; Proxy port: 8080; Message centre address: http://10.81.0.7:8002

For other operators try the following configs. As I am using o2 I couldn’t proof it, but maybe it works.

Vodafone de: Connection name: event.vodafone.de; Access point name: event.vodafone.de; Username: vodafone; Password: live; Proxy address: 139.007.029.017; Proxy port: 80; Message centre address: http://139.7.24.1/servlets/mms

Eplus: Connection name: mms.eplus.de; Access point name: mms.eplus.de; Username: mms; Password: eplus; Proxy address: 212.023.097.153; Proxy port: 5080; Message centre address: -

Telekom: Connection name: mms; Access point name: internet.t-mobile; Username: t-mobile; Password: tm; Proxy address: 172.28.23.131; Proxy port: 8008; Message centre address: http://mms.t-mobile.de/servlets/mms

Feel free to correct the settings if it’s wrong

edit flag offensive delete publish link more

Comments

these t-mobile settings work for me. Thanks.

njeiseck ( 2014-04-28 15:53:02 +0300 )edit

any simple method to test if these settings work?

Garonenur ( 2014-05-07 17:12:06 +0300 )edit

even though congstar (my provider) uses the t-mobile network sending an mms does not work for me.

Garonenur ( 2014-05-07 17:46:53 +0300 )edit

congstar uses other configs than T-Mobile de

Zandi ( 2014-05-07 17:58:03 +0300 )edit
1

try to send an mms to yourself

Zandi ( 2014-05-07 18:08:22 +0300 )edit
7

answered 2014-04-25 10:59:15 +0300

PJW_2273 gravatar image

updated 2014-04-28 11:42:55 +0300

Provider: Three UK

Works fine with the settings below

Connection Name: MMS

Access Point Name: three.co.uk

Username: [Blank]

Password: [Blank]

Proxy Address: 217.171.129.2

Port: 8799

MMS Message Centre Address:http://mms.um.three.co.uk:10021/mmsc

edit flag offensive delete publish link more

Comments

These settings don't work for me on 3 UK. I've tried sending but not receiving; I get the error "Problem with sending message.”

unruly ( 2014-04-27 14:28:40 +0300 )edit
1

My Bad.

Proxy address should be: 217.171.129.2

I'll update the post - Sorry

PJW_2273 ( 2014-04-28 11:42:36 +0300 )edit

Works now, many thanks.

unruly ( 2014-04-28 21:58:20 +0300 )edit
4

answered 2014-04-11 20:48:08 +0300

k.gramner gravatar image

updated 2014-05-15 22:27:59 +0300

Country: Sweden

Provider: Halebop

Network: Telia


[hotfix] MMS changes for Paarlampi (1.0.5.19) solved the problem.


UPDATE:

Got a reply from Jolla regarding this problem.

We already have a fix for the problem with Vodafone UK which had exactly the same symptoms. Most likely that fix would work for you too. It will be included in the next update.

UPDATE (hotfix):

The hotfix solved the problem.

edit flag offensive delete publish link more

Comments

1

With Telia as Provider I can recieve but not send. Maybe the same problem with halebop?

sidde ( 2014-04-12 12:32:41 +0300 )edit

This seems to be true. I can also recieve MMS but not send them.

k.gramner ( 2014-04-12 14:10:25 +0300 )edit
1

I cannot receive or send mms with Telia. I get error 226 from mmsc when sending and decoding failure when receiving

aloof ( 2014-04-12 23:03:02 +0300 )edit

Vodafone Ireland, same symptoms, Auto detected settings OK, can receive MMS fine but cannot send.

coley ( 2014-04-15 02:27:32 +0300 )edit

sunrise Switzerland, exactly same symptoms.

Maettu ( 2014-04-15 12:44:30 +0300 )edit
3

answered 2014-04-12 12:24:04 +0300

branek gravatar image

Ok, I managed to find solution for MTS Serbia. Maybe it will help others also.

In manual settings I entered 172.017.085.131 as address. That would not work, but when I removed leading zeros address settings (172.17.85.131) all was ok. MMS sending/receiving is working good.

@Aard - this looks like bug in address parsing.

Branko

edit flag offensive delete publish link more

Comments

1

That seemed to do the trick for CBB on Telenors net in Denmark. You're da man @branek! :)

Tanghus ( 2014-04-12 13:04:48 +0300 )edit

@branek Hi, welcome to Together. Tried this solution yesterday with Telenor Serbia but with partial success. First I entered 217.065.192.033 as address. After sending an MMS, the status was always Waiting. Then I removed the leading zeros in the adress settings (217.65.192.33) and after that I was able to send MMS. But I still can't receive MMS (the downloading fails).

Neo ( 2014-04-12 21:55:11 +0300 )edit

0xx is an octal number. Many Linux systems (pretty much all I would guess) behave this way. For example (I'm typing this on my Ubuntu desktop):

$ ping 192.168.2.015
PING 192.168.2.015 (192.168.2.13) 56(84) bytes of data.
...

(the rest depends on whether 192.168.2.13 is up)

It's pinging 192.168.2.13 rather than 192.168.2.15. Because 015 is actually 13.

slava ( 2014-04-12 23:50:33 +0300 )edit

Removing leeding zeroes from address helped also in case of Plus GSM in Poland. Thanks for the tip.

Maurycy ( 2014-04-27 12:48:37 +0300 )edit

After the hotfix sending and receiving MMS works fine with Telenor Serbia.

Neo ( 2014-05-16 19:04:55 +0300 )edit
3

answered 2014-04-14 00:28:03 +0300

Sayang gravatar image

Tele2/Comviq in Sweden works, send and recive.

Namn på anslutning: Tele2 MMS Namn på accesspunkt: Internet.tele2.se

Proxyadress: 130.244.202.30 Port:8080

MMS meddelandecentral: http://mmsc.tele2.se

edit flag offensive delete publish link more

Comments

thanks for this, tried to send an empty sms to tele2 to get the info with sms (as directed by tele2) but was unable to as jolla doesnt allow to send empty sms.

Kiranos ( 2014-04-14 14:15:04 +0300 )edit
1

I did the same. But I sent a message with one (1) blankspace. Received a message 'Your phone doesn't support MMS'... Oooh, yes it does ;)

Sayang ( 2014-04-15 09:48:21 +0300 )edit

These settings didn't work for me. I did get the same answer to my SMS asking for the MMS settings.

Stuarty ( 2014-04-16 17:05:23 +0300 )edit

Don't send an empty sms to 123, it won't work. These settings only work with tele2.

Sayang ( 2014-04-18 11:25:56 +0300 )edit

These settings doesn't work for me either...and I do have tele2

gvictor ( 2014-04-28 18:32:59 +0300 )edit
3

answered 2014-04-21 23:57:41 +0300

ron282 gravatar image

France - Free. I'm able to send MMS when 1) Wifi is disabled, 2) Mobile data is enabled, 3) Roaming is enabled. The most disturbing thing is to enable roaming.

edit flag offensive delete publish link more

Comments

I also experience this problem too. If both Wi-Fi and mobile data are enabled, DNS lookup request for MMSC is handled through Wi-Fi, but MMSC IP address resides in private IP range of telco network so DNS lookup may fail.

peremen ( 2014-04-22 08:40:57 +0300 )edit

enabling roaming did the trick for me too. strange ...

stephan ( 2014-04-25 08:41:30 +0300 )edit
1

Try replacing mms.free.fr in MMS center URL with its IP address (212.27.40.225). That would take DNS out of the picture.

slava ( 2014-04-25 15:10:11 +0300 )edit
1

Very insteresting: after enabling roaming once to send my first mms, I sent two more MMS without roaming enabled. MMS works for me now.

stephan ( 2014-04-25 18:55:24 +0300 )edit
2

Wi-Fi definitely block MMS from receiving. As soon as I disable the Wi-Fi, the message starts downloading and successfully receives it. I had couple messages that sat there for hours before I disabled Wi-Fi. Hope they fix this in May update.

AbyZThomas ( 2014-05-07 20:06:46 +0300 )edit
2

answered 2014-04-11 15:25:36 +0300

slava gravatar image

Another trick: if you can send MMS but not receive it (the operator sends you an SMS instead), try inserting your SIM into a phone which is well known to be MMS-capable (Nokia, Lumia, Android, Apple), send/receve MMS with that phone and then insert the SIM back into Jolla. Sometimes that helps. I believe this trick helped me to get Jolla to work with Saunalahti.

edit flag offensive delete publish link more

Comments

Years ago (around 2009), this used to work with Swisscom too. Today, you get an error message when your handset device is not enabled for MMS. I assume this could also be the case with other providers. In any way it is advised to first check if sending works.

Venty ( 2014-04-11 17:22:08 +0300 )edit
1

with Swisscom, i can not receive/send MMS with Jolla JP-1301, i'm only end user but i was able receive/send before with Nokia N8-00

  • Country: Switzerland
  • Provider: Swisscom
  • Network: Swisscom
  • APN: Swisscom MMS
  • APN: event.swisscom.ch
  • MMSC: http://mms.natel.ch:8079
  • Proxy: 192.168.210.2:8080

Swisscom MMS parameters http://www.swisscom.ch/en/residential/help/loesung/server-settings-mobile.html

redge73 ( 2014-04-15 01:07:36 +0300 )edit
1

I think you're right. Does that mean it's a problem of swisscom?

[nemo@Jolla ~]$ dbus-send --system --print-reply --dest=org.ofono /ril_0 org.ofono.ConnectionManager.GetContexts method return sender=:1.13 -> dest=:1.86 reply_serial=2 array [ struct { object path "/ril_0/context1" array [ dict entry( string "Name" variant string "Swisscom GPRS" ) dict entry( string "Active" variant boolean false ) ..

mabarezu ( 2014-04-19 14:08:04 +0300 )edit
2

answered 2014-04-28 13:55:14 +0300

smartiz gravatar image

Country : France Provider : SFR Network : SFR Femto Ent (it was "F SFR" at my beginning with my Jolla...) APN : mmssfr Proxy : 10.151.0.1 Port : 8080 Address: http://mms1 These settings seem to be correct. Everything worked fine before 1.0.5.19 update. Now I can neither send nor receive any MMS. I've sent a message to mms-debug@jolla.com.

edit flag offensive delete publish link more
1

answered 2014-04-12 15:13:21 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-10-08 01:08:45 +0300

Louis gravatar image

For CBB in Denmark - and probably also Telenor and BiBoB as it's the same network ;)

Connection name: Telenor MMS
Access point name: telenor
Username: *blank*
Password: *blank*
Proxy address: 212.88.64.8
Proxy port: 8080
MMS message centre address: http://mms.telenor.dk

That at least worked for me with a CBB account over Telenors net.

edit flag offensive delete publish link more
1

answered 2014-04-13 19:18:54 +0300

For Portugal users with provider MEO, the working (at least for me) configurations are:

  • Connection name: Meo Mms
  • Access point name: mmsc.tmn.pt
  • Username: tmn
  • Password: tmnnet
  • Proxy address: 10.111.2.16
  • Proxy port: 8080
  • MMS message centre address: http://mmsc/
edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
20 followers

Stats

Asked: 2014-04-11 13:03:28 +0300

Seen: 9,182 times

Last updated: Jun 11 '17