We have moved to a new Sailfish OS Forum. Please start new discussions there.
7

Add comma to the numeric keyboard

asked 2014-04-11 19:56:50 +0300

ppartti gravatar image

updated 2014-04-11 20:37:46 +0300

I mostly pay my bills with banking apps on my Jolla. In Finland we use a comma to seperate euros and cents (e.g. 3,20 €) and it's impossible to add a comma with the numeric keyboard straight to the amount field when making a new payment. My temporary fix for this is to open a new text message (or note), type the amount with the QWERTY keyboard, copy and paste it.

Note: Some countries use a period instead of a comma (e.g. $3.20).

Edit: Here's a screenshot of the numeric keyboard

Edit edit: The bank I use uses this keyboard for the "amount" field, ignore the phone number field.

13972362209329352

edit retag flag offensive close delete

3 Answers

Sort by » oldest newest most voted
2

answered 2014-04-11 20:15:43 +0300

Okw gravatar image

updated 2014-04-11 20:17:49 +0300

I noticed the same issue, and here's what I found out.

I use english as the system language, but finnish as input language. The keyboard that pops up when activating a HTML input field with type="number" is of english flavor with a period. If I change system language to finnish, the popup keyboard has a comma.

It seems like the default numeric input keypad follows the system language, while it obviously should follow the input language.

Btw, your screenshot is slightly inaccurate, since I don't think the phone keypad is even supposed to have a comma. AFAIK no phone number has periods or commas.

edit flag offensive delete publish link more

Comments

I use Finnish input. I haven't tried the numeric keyboard with Finnish system language. Other than that I agree with your comment.

About the screenshot: Danske Bank uses this numeric keyboard in the "amount" field. I thought I'd use the phone numer field for it because it was quick to get to. I've seen (I think British) phone numbers with periods between the numbers (e.g. 447.123.4567) whereas we Finns use spaces (040 123 4567).

ppartti ( 2014-04-11 20:36:06 +0300 )edit
2

answered 2014-04-12 16:30:02 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-04-12 16:30:02 +0300

Tanghus gravatar image

There's an article in JollaTides about how how to tweak the different locale settings. You'd be interested in changing the LC_NUMERIC setting. I've changed mine to da_DK.utf8 and I have a comma in the numeric keyboard.

That being said it would be nice to be able to change this from within settings. You can vote for this very popular question: https://together.jolla.com/question/931/enable-more-refined-locale-settings-that-are-respected-by-system-and-3rd-party-apps/

edit flag offensive delete publish link more

Comments

So your question is actually a duplicate :)

Tanghus ( 2014-04-12 16:31:15 +0300 )edit
1

answered 2014-04-13 08:10:17 +0300

JS gravatar image

I would say this is a duplicate of https://together.jolla.com/question/23911/bug-wrong-delimiter-key-in-numeric-keyboard-swiss/

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-04-11 19:56:50 +0300

Seen: 532 times

Last updated: Apr 13 '14