We have moved to a new Sailfish OS Forum. Please start new discussions there.
6

[1.0.5.16 BUG] GPS stays on

asked 2014-04-12 21:22:45 +0300

Whippler gravatar image

updated 2014-04-12 21:34:53 +0300

So i launched up GPS, here maps to get the gps properly activated and locked on, and then Endomondo pro (android app). After my cycling ride, i uploaded the endomondo data, shut down the apps, and turn off the GPS from settings. After couple hours i look at the phone and the GPS icon is still showing up in the info bar.

So i toggled it on and off couple times, launch maps(settings GPS off).. it starts blinking to find the location, close maps app, and the GPS indicator still keeps blinking.

Killed android service (with KillDroid app), and toggled GPS couple more times, and it still just stays on/searching.

After some testing it seems to occur when android app has been using the GPS I have tested with Endomondo, Google maps, and Navionics marine maps. Maybe it's caused by having google services installed? So anyone here able to reproduce this with an android app that uses GPS, and doesn't have google services installed?

Turning off GPS in settings seems to turn on the GPS indicator for few seconds for some reason, and sometimes it seems to be stuck longer.

edit retag flag offensive close delete

Comments

I have the same problem:

  1. I opened the here maps application.
  2. GPS turns-on its own (!?) 2.1. I don't think it did that before the update. Furthermore, in the application it would still say GPS wasn't switched on.
  3. I close the here maps application
  4. GPS stays on blinking
  5. I manually enable/disable the GPS a few times but the item keeps blinking.
  6. 1+ hour later. The indicator is still blinking and I reboot the device
  7. GPS is off.

I can not reproduce the problem. When I enable GPS now, no indicator is visible on the home screen. Yet, the minimized settings application shows GPS as enabled.

For completeness sake I was using Opera, an Android application, at the same time when. All Android applications had reinstalled themselves. However, how and if that is related I couldn't say but wouldn't assume so.

minnist ( 2014-04-13 16:37:05 +0300 )edit

I could just recreate the behaviour. Started maps and the icon would blink. Enabled the GPS function in the settings. Closed the maps app. Disabled GPS in settings. However, the icon, non blinking & solid, is still visible. I would think the problem is just cosmetic though as I trust what the settings indicate. This time no Android app was running.

minnist ( 2014-04-13 22:53:06 +0300 )edit

I've not got exactly theese issues afaik, but something struggles with android apps and GPS after 1.0.5.16.

I have to"systemctl restart aliendalvik.service" everytime I've used an android app with GPS otherwise the device won't find th location, it just says "searching for GPS" until I kill the app, sometimes it says "location found" and in those cases it directly changes to "searching for GPS"., then it switches between those lines until I kill the app.

JS ( 2014-04-24 22:46:45 +0300 )edit

Happened to me in 1.0.8.19, although the GPS icon disappeared when I disabled Location in Settings and appeared again as soon as I enabled it again. Didn't run Android apps, didn't have any apps open.

Fixed via reboot, but happened again as soon as the browser crashed while trying to open a site that uses geolocation.

TuukkaH ( 2014-08-18 23:38:12 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-04-13 02:00:43 +0300

Slawek gravatar image

I had the same using Sportracker. You must unistall application and install it once again. This should help you.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-04-12 21:22:45 +0300

Seen: 566 times

Last updated: Apr 13 '14