We have moved to a new Sailfish OS Forum. Please start new discussions there.
10

bug: google calendar events off by 12 hours

asked 2014-04-14 04:44:39 +0300

baergaj gravatar image

updated 2014-04-14 05:30:19 +0300

All of my google calendar events are offset by -12 hours. I am using 1.0.5.16, but I was experiencing the same issue on 1.0.4.20.

My timezone is set to automatic on my Jolla: GMT -7:00 (-6:00) Edmonton, Canada. I experience the same issue if I manually set it. This is also the current timezone on my google calendar settings.

If I add a new event on the calendar app, it is saved to google calendar with the correct time, but the event on the calendar app then switches to -12 hours.

Here is the database entry of a newly created event scheduled to start April 13 at 20:00. The DateStart and DateStartLocal look correct.

2294|012ba221-1e6d-488e-8981-004e5f39fc83|Event|Tester2||1397440800|1397419200|America/Edmonton|0| 1397444400|1397422800|America/Edmonton|0|0|||0|255.0|255.0|0||1397439027|1397439027|1397439027|1||||0|0|0||| urn:x-ical:bef40561-d69f-4e7b-953a-a72c4ce28e82|bef40561-d69f-4e7b-953a-a72c4ce28e82|0|0|0|0|0||0|||0

Here is the same database entry a couple of seconds later. The DateStart and DateStartLocal have both shifted by -12 hours.

2294|012ba221-1e6d-488e-8981-004e5f39fc83|Event|Tester2||1397397600|1397376000|America/Edmonton|0| 1397401200|1397379600|America/Edmonton|0|0|||0|255.0|255.0|0||1397439027|1397439029|1397439029|2||||0|0|0||| urn:x-ical:bef40561-d69f-4e7b-953a-a72c4ce28e82|bef40561-d69f-4e7b-953a-a72c4ce28e82|0|0||0|0|0|0|||0

Any workarounds or suggestions for further troubleshooting?

edit retag flag offensive close delete

Comments

Same issue here, except that my events are brought forward 8 hours instead of 12, so a 7pm dinner appointment displays on the Jolla calendar app as though it starts at 11am the same day. My timezone is set to EST (GMT-5: Toronto) on google & Canada, Toronto on Jolla.

I can't easily check the contents of my sqlite db right now, but I can work some examples later when I'm at home if it would help devs debug this..

I'm on 1.0.5.16; don't recall this issue on 1.0.4.20.

shallimus ( 2014-04-24 21:11:36 +0300 )edit

I'm surprised and disappointed that not a single other person has found their way to this question in the last 6 weeks. Surely we can't be the only two people experiencing this odd behaviour? Is it Canada-specific? (OK probably not, but...)

While my Jolla is very cool in many ways, I have already missed one appointment because the calendar functionality is little better than useless. The N9 was so good at this, especially when using thp's excellent Billboard to display next events on the low-power standby screen.

shallimus ( 2014-06-03 16:10:56 +0300 )edit
1

I'm on Rogers. Maybe it's related to the network date/time settings?

baergaj ( 2014-06-10 07:56:29 +0300 )edit

I'm on Fido, so essentially the same as Rogers. I don't see anything wrong with the network date/time, but I'll keep an eye out.

shallimus ( 2014-06-10 19:23:23 +0300 )edit
1

I'm using a paid calDAV service and my appointments created through the web interface are off (on Jolla) by +2 hours. Appointments created on my Jolla, are recorded correctly, and submitted correctly (with SyncEvolution) to the calDAV service. Though +2 hours look familiar (CET Summer time vs. GMT)... Not sure if my mistake, or SyncEvolution's or the calendars' which obviously - at least in one direction - does not honour (or transmit) timezones.

garrosh ( 2014-06-11 12:49:23 +0300 )edit

1 Answer

Sort by » oldest newest most voted
5

answered 2014-10-11 20:23:20 +0300

crevetor gravatar image

Good news everyone ! I was able to fix this bug. It is actually this http://marc.info/?l=kde-core-devel&m=134973661628231&w=2 bug. So it affects all people that have set up their google calendar account to be in a timezone wiht a negative difference to UTC (so people in the americas mostly). I am discussing the best way to get it fixed in a future release. In the meantime if you want a package with the bug fixed you can PM me.

edit flag offensive delete publish link more

Comments

Fix merged. It will be part of update 10.

tigeli ( 2014-10-12 01:16:10 +0300 )edit

I can confirm that this is fixed in update 10! I did have to delete and re-add my google account in order for my calendar entries to update with the correct time.

baergaj ( 2014-12-19 07:01:04 +0300 )edit

i haven't updated to 10 yet, but i am very happy to hear this bug has been resolved. i was having the same issue. i'm in the united states, mountain time zone, on t-mobile (if you were wondering).

linux_user9 ( 2014-12-23 18:06:54 +0300 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-04-14 04:44:39 +0300

Seen: 281 times

Last updated: Oct 11 '14