We have moved to a new Sailfish OS Forum. Please start new discussions there.
4

Calendar Event ending Midnight

asked 2014-04-14 15:45:48 +0200

FloR707 gravatar image

Hi,

I just tried to enter a new event in my calendar that should end at midnight. First I picked the day and set the beginning time, saved, went to the time picker for the end time and pickt 00:00. After accepting the event was moved to the day bevor the day I had picked and the start time was stet to 23:00. Is this a bug or am I doing something wrong?

Thanks

edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted
2

answered 2014-04-14 20:40:41 +0200

phle gravatar image

For my example, I'll use an event starting at 2014-04-14 20:00, and ending at 2014-04-14 24:00
(from eight o'clock in the evening, and lasting four hours (until midnight)).

You will either need to

  • set the end time to 23:59 on the same date as the start time
    (not that pretty)

or

  • set the end time to 00:00 on the date after the start time
    (will give you the desired time)

both versions will only show on the day of the start date (an event ending at 00:00 "the day after" won't be visible on "the day after".

I hope this "work-around" is ok for you.
(It's not a bug, but rather the way clocks work, and sometimes it's easy to forget that
2014-04-14 24:00
is the same as
2014-04-15 00:00.
;-) :-) )

edit flag offensive delete publish link more

Comments

I would totally agree with you but Calendar currently reads the input 2014-04-14 00:00 as 2014-04-13 24:00 and resets the beginning to 2014-04-13 23:00. So Calendar goes a day back versus a day ahead and now thinks you put the start after the end and resets it. So I think that is a bug in the time picker. They should add 24:00 and then convert it to 00:00 the next day.

FloR707 ( 2014-04-14 22:16:44 +0200 )edit

Hm?

Just tried adding an event

Test
start 2014-04-15 00:00
end 2014-04-16 04:26

and got an event lasting from 2014-04-15 00:00 to 2014-04-16 04:26 (as expected).

If you go to Settings → System → Language and time: Time and date, is "Automatic update" enabled (mine is)?

(just read through "Time zone changes to Finland, Helsinki when enabling "Automatic update" while no SIM card is inserted" - do you still have issues with your SIM-card (I saw your answer over at "Sim card connection to phone lost easily") - could that be part of the issue?)


So: I tried recreating what you actually seem to do:

I edited above event to

start 2014-04-15 13:00
end 2014-04-15 00:00 (i.e. same date, but before the start time)

which ended up (even before "saving" it) as an event lasting from 2014-04-14 23:00 to 2014-04-15 00:00.

... or have I misunderstood your start- and end-times?

phle ( 2014-04-15 07:30:38 +0200 )edit
1

No the second attempt was completely right. I redid it yesterday again, just before 23:00. This triggered the bug right away without me entering anything. Presets were start 23:00 end 00:00 but the event ended up being the day before the day I picked. Personally I think they should add 24:00 to the time picker. So if you come from the right you get 00:00 and if you come from the left you get 24:00, which actually is 00:00 the next day.

FloR707 ( 2014-04-15 09:16:53 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-04-14 15:45:48 +0200

Seen: 105 times

Last updated: Apr 14 '14