Not able to select correct phone number if contact has several

asked 2014-04-15 12:43:52 +0300

tajunta gravatar image

My contacts are synced with Exchange, and they have both land line and mobile phone numbers. On the contact card in People app, I can only see the land line number. I can see both phone numbers only when I select Edit and click on the Phone section to open it up.

I think this is also the cause of these two issues. When I select a contact to send SMS to, by writing the name of the contact, it doesn't allow me to select the correct (mobile) phone number. It only allows me to select either the land line number, or Facebook or G+ chat address (if available).

Second issue is that when I send a picture as MMS, and select a contact by writing the name of the contact, it doesn't let me select any phone number to send it to (if contact has several). It automatically tries to send it in the land line phone number.

The only workaround I have come up with is to delete the land line number from the contact to get the mobile number visible on the contact card in "read mode" (ie. not editing). Then I'm able to select the mobile number when sending SMS, and get MMS automatically sent to it.

edit retag flag offensive close delete

Comments

@tajunta: the reason that you cannot see a number in the contact details is because we think it is a variant of another number, and we have decided to show the other one (usually because it is longer). If your numbers are not variants of each other, there must be something wrong with the data that is causing us to compare them incorrectly.

Would it be possible to provide details on the numbers that are causing the problem? You can email me at matthew.vogt@jollamobile.com if you would like to investigate the problem.

MattVogt ( 2014-06-11 07:22:30 +0300 )edit

Thanks! I'll enable the Exchange contacts sync again, and test once more while emailing you the details and examples.

tajunta ( 2014-06-13 11:14:18 +0300 )edit