[Bug?] "Invalid Number" when using "+" not as first sign

asked 2014-04-17 11:17:27 +0300

Robomike gravatar image

updated 2014-04-22 11:23:27 +0300

kaltsi gravatar image

Saving international numbers with "+" is one thing, i. e. "+49" for Germany etc. Second is to use some prefixes to switch network functionalities, i. e. "31#" code for toggling anonymous mode. My network setup is make calls by default anonymous, but I can switch the mode with prefixing "31#" the phone number. A couple of my contacts are saved this way. International style the number looks like: "*31#+49xxxxxxxx...", this IS in fact a valid number in my network, but Jolla tells me "invalid number" and refuses dialing. So, I'm unable to call a lot of my contacts in a regular way. What can I do?

Michael

edit retag flag offensive close delete

Comments

Why not let the user store and dial whatever they like from the addressbook? It is the job of the phone network to reject invalid numbers, not the phone.

00prometheus ( 2014-04-17 16:08:20 +0300 )edit

This is indeed a bug Hope they will fix this

HtheB ( 2014-04-17 16:39:33 +0300 )edit

I agree that it's a bug. But it's not that simple that all dial strings will be sent straight to the network and analysed there. It's the phone's task to recognize special prefixes, SS and USSD codes and emergency numbers. Those must be stripped off / converted into signalling and sent accordingly. In the mentioned example *31# must be converted into "CLIR=no" (Calling Line Identity Restriction), "+" into "Type of Number=International" and "49xxxxx" would be the sent dial string.

Stefanix ( 2014-04-18 12:21:21 +0300 )edit