Ask / Submit
2

mobile data is set to disabled after reboot

asked 2014-04-20 14:08:53 +0300

Ajulma gravatar image

updated 2014-06-13 17:36:03 +0300

zlatko gravatar image

I had this issue since the start but I just let it be like with all the other bugs that Jolla was infested at that time, just sticking to my old android and waiting it out... Like with with plenty of other things it appeared to have gotten fixed through updates, but a reboot messed it up again.

Mobile data icon is permanently stuck on 'disabled' and the shortcut stays greyed out no matter what. I run across the same issue on another discussion board and someone claimed that he/she had needed reset to factory settings to get around it and someone else that simple 20sec switch to airplane mode should do the trick . I haven't tried the first suggestion and the latter doesn't work for me. My connection settings should be the correct ones for my Comviq connection (apn internet.tele2.se and I've pretty much tested all possible combinations, including ones in the relevant threads here and the settings that function on my Android device).

edit retag flag offensive close delete

Comments

1

Personally when I have this issue, a reboot always enable my data back. But before rebooting, what I usually do is to untick the "Select network automatically" option, which forces the Jolla to look for available networks and sometimes brings the data back.

But I hope that airplane mode will really reset the connection in futur releases.

Sthocs ( 2014-04-20 22:49:50 +0300 )edit

Thanks a lot Sthocs! That trick - unticking the box and rebooting, seemed to work at least this time around. I hope that they'll fix it properly so that I won't have to repeat such rituals too often...

Ajulma ( 2014-04-20 23:05:50 +0300 )edit

Oh, actually I meant: before beeing forced to reboot, I try to untick/tick this option, and that sometimes bring back the data without having to reboot.

Sthocs ( 2014-04-21 12:10:23 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-06-13 17:35:41 +0300

zlatko gravatar image

updated 2014-06-14 14:38:07 +0300

I got mobile-data deactivated somehow after SIM card change between my devices(N9). Now it is all greyed out I can't even open settings of the APN. The same card works OK in N9. And my other(same provider) card works OK in Jolla.

EDIT: Here is how I solved it in my case:

I managed to fix my issue:

  1. When I checked /var/lib/ofono/operator_number/grps - I found out AccessPointName was missing.

  2. I stopped ofono with systemctl stop ofono.service

  3. Edited gprs file adding APN

  4. Started ofono: systemctl stop ofono.service

And voila! - all is working now :)

Still have not tried rebooting the phone though...

edit flag offensive delete publish link more

Comments

I did just that. But to no avail. Even worse after restarting ofono all entries concerning [context1] ( APN configuration) get deleted. When restarting the phone i'll get WAP entries in the APN section of the gprs file. That ist a pretty anoying behavior. The previous release didn't suffer from this problem.

Jmf ( 2015-06-10 18:43:05 +0300 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-04-20 14:08:53 +0300

Seen: 728 times

Last updated: Jun 14 '14