Ask / Submit
18

gstream codecs

asked 2014-04-22 09:47:10 +0300

michdeskunk gravatar image

why before the last update I can play mpeg videos and now I have trouble to see them??? there is only my issue??? and which others kind of codecs are supported by sailfish??

edit retag flag offensive close delete

Comments

I have these problems too, any avi I cannot play, MP4 works fine, not sure why, codecs are probably broken somehow...

Bobsikus ( 2014-04-22 10:03:08 +0300 )edit

but before last update this problem didnt exist

michdeskunk ( 2014-04-24 23:14:22 +0300 )edit

3 Answers

Sort by » oldest newest most voted
3

answered 2015-11-19 13:31:29 +0300

DameCENO gravatar image

Get Ultimate codec pack from openrepos.net, will fix many of the codecs problems, but still won't play flv and wmv videos as far as I can tell, avi mp4 3gp even mkv work well with it. Jolla really need to consider fixing the weakness of gstreamer to support all video codecs MeeGo plays without glitch.

edit flag offensive delete publish link more

Comments

4

There is a limit to how much we can support due to patents. If you have a non working video, please share it with me and I will tell you whether the codec is not supported or whether it's a bug and try to fix it if it's a bug.

MSameer ( 2015-11-19 14:38:46 +0300 )edit
1

@MSameer what I don't get is the lack of VP8 & VP9 support. Basically those codecs are shipped by Jolla already as the SailfishOS Browser supports them. But gstreamer is lacking support for it. The patent issue should be solved on that codecs as the whole world is shipping support for it already.

leszek ( 2015-11-19 14:59:00 +0300 )edit

@MSameer finally someone pays attention to my grievances, I am grateful already. I use LLs Vplayer, and it plays avi, mkv, mp4 and 3gp videos well, but my experience with any flv videos as a whole won't play as it returns internal stream error message, @alex says flv videos play well on his device, so am confused. As for wmv videos it returns the error message your Gstreamer installation is missing a plugin. I have all codecs related from openrepos.net and used the pkcon update to update minor files on my device, opus included, had to get a newer version from openrepos, yet the problem persists, it would mean the world to me if you could help fix this issue as I need to watch those CBT Nuggets videos on my device and they are the wmv formats

would gladly share an flv and wmv video with you to any link you want

DameCENO ( 2015-11-19 15:46:01 +0300 )edit
2

@DameCENO I am always there and listen. I apologize if I missed any previous question related to video playback. I am trying to do my best but I am also governed by our legal guys.

MSameer ( 2015-11-19 16:42:11 +0300 )edit
2

answered 2015-11-19 16:40:59 +0300

MSameer gravatar image

One by one:

1) VP8 is not supported by browser. I did my best but support for VP8/webm is still being checked. I cannot do anything from my side :( 2) MP4, AVI anf FLV: You cannot complain that such videos are not working because these are CONTAINER formats. Each video can have a different audio and video codec. It's really a case by case. 3) WMV: I highly doubt that will ever work (Microsoft).

The only thing that can be done NOW is that someone packages the missing GStreamer codecs into an RPM or a set of RPMs on OpenRepos.

edit flag offensive delete publish link more

Comments

Why wasn't Mplayer used with Gstreamer as on MeeGo, this issues were rarely seen on my N9, I would be really grateful for whomsoever would compile those missing codecs in RPMs. As for AVI and MP4 I have no issue playing them since I started using Ultimate codec pack, flv and wmv are the issue along some low audio compression 3GP videos.

DameCENO ( 2015-11-19 17:16:20 +0300 )edit

Hmm... in my Sailfish-Browser I can play vp8 webms. Also html5 test shows vp8 and vp9 support with it. It actually is a workaround I use whenever I try to play webms (most of them use vp8 or vp9 as codecs)

leszek ( 2015-11-19 17:25:29 +0300 )edit
2

answered 2017-11-07 00:15:13 +0300

objectifnul gravatar image

Ultimate Codec support couldn't be installed (SailfishX 2.1.3.5) because "nothing provides libgstaudio-0.10.so"

edit flag offensive delete publish link more

Comments

Try a pkcon refresh

BonoNL ( 2017-11-07 22:36:32 +0300 )edit

Same problem here, did pkcon refresh, still same message.

hagiz ( 2017-11-11 08:43:47 +0300 )edit

Solved via zypper. Pkcon refresh didn't help.

objectifnul ( 2017-11-11 09:39:13 +0300 )edit

@objectifnul

Please let us know how you solved it using zypper.

prshntrnjn ( 2018-01-05 18:18:35 +0300 )edit

GStreamer 0.10 is not used for anything. If the codec collection is only for 0.10 then better not to install it ;-)

MSameer ( 2018-02-19 20:22:52 +0300 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-04-22 09:47:10 +0300

Seen: 1,380 times

Last updated: Nov 07 '17