[hotfix] MMS changes for Paarlampi (1.0.5.19) [released]

asked 2014-04-24 17:27:07 +0300

Aard gravatar image

updated 2015-07-25 21:32:30 +0300

eric gravatar image

We are releasing a hotfix to eliminate some of the MMS issues seen in 1.0.5.16 today. The issues fixed include changes to decoding of some MMS fields, enhancing interoperability with certain providers, better input validation of user provided settings and updates to the built-in provider database.

For additional information about full Paarlampi release content or how to help us with MMS debugging, please visit the following links:

Note: If you installed custom packages replacing core packages (like a custom wpa_supplicant) you'll have to redo that step after installing this hotfix!

More detailed changelog for technically interested:

  • [mms_codec] Fixed decoding of the From field
  • [mms_codec] Fixed decoding of address fields
  • [mms_codec] Replaced Content-Disposition:Inline with Attachment
  • [mms-lib] Changed default User-Agent to "Mozilla/5.0 (Sailfish; Jolla)"
  • [mms-ofono] Remove leaving and trailing spaces from the URLs
  • [mbpi] Cleaned up MMS settings for Orange France
  • [mbpi] MMS settings for Drei (Austria)
  • [mbpi] MMS settings for Etisalat (UAE)
  • [mbpi] Updated MMS settings for MTel (Bulgaria)
  • [mbpi] Remove spaces from URLs
edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by r0kk3rz
close date 2015-07-01 16:21:22.777500

Comments

4

I confirm that MMS are now working in France with Bouygues Télécom / B&You !

ced117 ( 2014-04-24 18:15:17 +0300 )edit
5

For those whom installed the patched wpa_supplicant version - after upgrading to 1.0.5.19 you need to reinstall the patched version as the release version gets pulled in again.

chemist ( 2014-04-24 18:16:55 +0300 )edit
1

Vodafone IT is working for receiving AND sending now! Great job Jolla Team!

donaggio ( 2014-04-24 18:50:32 +0300 )edit

FYI, the download size is about 2MB

c.la ( 2014-04-24 18:55:42 +0300 )edit

Really good work. MMS are working now. Thanks a lot Jolla team!!!

TellienInTouch ( 2014-04-24 19:04:12 +0300 )edit
1

I don't want to get overly excited too soon, but I sent and received quite a few pictures now (A1Austria) and everything's just fine. Very nice. I appreciate a nice hotfix every now and then. :)

ossi1967 ( 2014-04-24 19:39:50 +0300 )edit

MTel(Bulgaria) now works both sending and receiving for images. Tried sending contact card - my N9 doesn't recognise the format and displays the vcard as (plain)text message without proposing to import it. Sending contact card from N9 to Jolla results in nothing received on Jolla, although N9 displays confirmation delivery report.

zlatko ( 2014-04-24 20:25:52 +0300 )edit
4

and don't forget pkcon remove jolla-startupwizard-tutorial, if you don't need it - it comes back too

jolladiho ( 2014-04-24 20:35:33 +0300 )edit

1.0.5.19 updated a lot of packaged for me: http://paste.ubuntu.com/7323868/

coderus ( 2014-04-24 20:36:33 +0300 )edit
2

Do we still need to disable openrepos repositories before attempting to upgrade?

gsalone ( 2014-04-24 20:48:21 +0300 )edit

you dont need to do anything manually since 1.0.4.20 update.

coderus ( 2014-04-24 20:48:55 +0300 )edit

hope so :) if not, prepare to receive my phone for fixing :p

gsalone ( 2014-04-24 21:01:09 +0300 )edit
1

why hope? it was officially announced. read 1.0.4.20 release notes.

coderus ( 2014-04-24 21:01:54 +0300 )edit

Still not working with Vodafone UK

Oh well.

strongm ( 2014-04-24 21:10:37 +0300 )edit
1

Aha! Got it. Problem with the MMS port, which got set wrong. These are the settings that work for me on Vodafone UK with the 1.0.5.19 hotfix:

Connection name: Contract WAP

APN: wap.vodafone.co.uk

Username: wap

Password: wap

MMS message centre: http://mms.vodafone.co.uk/servlets/mms

Proxy address: 212.183.137.12

Proxy port: 8799

strongm ( 2014-04-24 21:19:02 +0300 )edit

And the (rather useless) Tutorial is here again :( But fortunately there's also the Terminal and the bash-history :)

digitus ( 2014-04-24 23:00:55 +0300 )edit

@donaggio could you please share your settings? I can send MMSs but recipients do not receive images, just the text. Grazie!

IZ1IVA ( 2014-04-24 23:28:45 +0300 )edit

I had prefered to get a security update (or have this included) for the plain text e-mail password saved in user space :-(

jgr ( 2014-04-25 00:38:29 +0300 )edit

Now MMS is working using KT, Korea at least for my pending messages. I will try for other operator soon.

peremen ( 2014-04-25 05:11:32 +0300 )edit
2

Telefonica O2 CZ with the 1.0.5.19 hotfix:

MMS works well now! Can receive and send too.

Well done Jolla. :)

cocovina ( 2014-04-25 10:06:38 +0300 )edit
1

Good Job! Now It works perfectly with Orange France. :-)

Morpheus ( 2014-04-25 13:27:42 +0300 )edit

Had to reinstall bash4 and the patched lipstick-qt5. But this time openssh stayed untouched ;) Strange thing that bash wasn't overwritten after the last firmare upgrade.

J4ZZ ( 2014-04-25 14:35:05 +0300 )edit

Sending contact cards between Jolla and N9 should work. It works for me here in Finland.

slava ( 2014-04-25 15:05:52 +0300 )edit

@slava Confirmed - it is working from Jolla => N9. My initial mistake was adding a text ("Test Vcard" in my case) to the message. When I didn't add any text, just sent the vcard - all works perfect. Thank you for pointing that out! May be it is good idea to not allow adding text to message when sending contact card?

zlatko ( 2014-04-25 15:35:58 +0300 )edit

That definitely is an interoperability problem. There's something N9 doesn't like about the way we encode such messages. I'll take a look.

slava ( 2014-04-25 15:58:42 +0300 )edit