We have moved to a new Sailfish OS Forum. Please start new discussions there.
2

[solved] Jolla Phone do not start but display logo

asked 2014-04-28 02:10:31 +0300

quasar gravatar image

updated 2014-06-22 22:17:53 +0300

rzr gravatar image

Hello Jolla Community,

my new Jolla Phone do not start after 1 week of using. I had connect the phone over night with the power connector. On the next day I see only the Jolla Logo. It is not possible to shutdown the device. I removed the akku/battery and put it back again but after the start button was pressed the jolla logo is the only thing what I see.

I had tried the recovery mode. as described at: https://together.jolla.com/question/22079/howto-all-pc-users-recover-or-reset-a-device-that-is-stuck-in-boot-loop/

But if I try point 5 in the telnet menu nothing happens. I had wait 15 minutes.After that I have removes the akku/battery and start with point 1. Here I see some mount commands and after that he stop working, I had wait again for 15 minutes. But it is ever possible to connect to the shell with point 4. I have see with ps command a sleep 86400? Can I do something over the command line?

the following command aborts:

btrfs check --repair /dev/mmcblk0p28

What is possible to bring my phone back to life?

Thanks quasar

edit retag flag offensive close delete

Comments

nobody an answer? Must I send the device back? It will be cool if I can bring the device fast back to life. because I have the next 2 weeks free and time to use the phone. Any idea?nobody an answer? Must I send the device back? It will be cool if I can bring the device fast back to life. because I have the next 2 weeks free and time to use the phone. Any idea?

quasar ( 2014-04-29 00:39:22 +0300 )edit

It is difficult to see what your exact problem is. What are you using to do the recovery process, PC, Mac or Linux? If you say you cannot get to step 5 (telnet start) then the problem probably lies in that you do not have telnet installed correctly. Do you see the "Jolla Recovery tool" screen?

Also what firmware version was your Jolla running.

bockersjv ( 2014-04-29 12:51:24 +0300 )edit
1

@quasar if this is solved, you should post an answer explaining, accept it, and then close this question!

dsilveira ( 2014-06-02 12:40:58 +0300 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2014-04-30 00:56:46 +0300

quasar gravatar image

updated 2014-04-30 00:58:14 +0300

Hello bockersjv,

I use PC with Linux (Ubuntu 12.04 LTS and OpenSuse 12.3) At the moment I try it again with Ubuntu. The last version of my Jolla phone was Sailfish OS 1.0.5.19. Telnet is no problem I see the recovery screen:

Jolla Recovery v0.2.4      
-----------------------------
Welcome to the recovery tool!
The available options are:
1) Reset phone to factory settings
2) Reboot phone
3) Bootloader unlock [Current state: locked]
4) Shell
5) Try btrfs recovery if your device is in bootloop
6) Exit
Type the number of the desired action and press [ENTER]:

now I choose Point 5 (Try btrfs recovery if your device is in bootloop) I see the number 5 what I have pressed. But the phone does nothing, or how I can see what he is doing? I wait 15 minutes... or must I wait longer? After that I reboot the phone (remove battery and Insert battery back) I see only the Jolla logo. Now I reconnect the phone with telnet and try point 1 (Reset phone to factory settings). On the PC with Linux screen I see:

1

Are you really SURE? If you continue, ALL DATA (pictures, videos, messages, accounts and all the personal data) stored in the device memory WILL BE ERASED! [y/N] y[CLEANUP] Starting cleanup!
[CLEANUP] Umounting top volume...
[CLEANUP] Deleting /mnt
[CLEANUP] Cleanup done.
Mounting /dev/mmcblk0p28 on /mnt
sh: unlock: unknown operand
[OK] No lockcode has been set. Proceeding...
sh: unlock: unknown operand
sh: shell: unknown operand
[OK] Factory snapshots found.
Resetting procedure started!
Backing up current root and home subvolumes. If the backup fails, the old data will be deleted to let the recovery process continue.
[Done]
Restoring factory subvolumes...
Create a snapshot of '/mnt/factory-@' in '/mnt/@'

I wait... after 15 minutes nothing happen. Or must I wait longer? Is there a solution for this problem?

Many thanks for everybody here who can bring my Jolla back to life. quasar

edit flag offensive delete publish link more

Comments

Did you found any solution for that? I've go the same issue, and can't factory reset my device.

restless_being ( 2014-06-16 01:43:47 +0300 )edit

Any update on this? I have the same problem..

joakknut ( 2015-01-09 01:36:25 +0300 )edit

Hi, Any news regarding this issue? I encountered a similar one too.

RazoeG ( 2016-03-05 14:14:41 +0300 )edit
0

answered 2014-04-29 12:10:00 +0300

quasar gravatar image

Hello again, how works the recovery process? which command will be used? I use Linux a long time, but btrfs is new for me.. Can someone describe the recovery process or the system reset from Jolla?

Thanks quasar

edit flag offensive delete publish link more

Comments

See the answer to this question

steph ( 2014-04-29 23:44:26 +0300 )edit

I can't remember how long my btrfs took but I would leave the phone up to 30mins for full re-set. If this still fails I would contact Jolla Care directly.

bockersjv ( 2014-04-30 09:32:33 +0300 )edit

Hi steph, i had try this but the recovery do not work for me :-( see my post above. I think it is helpful to know the commands on the shell. and in what sequence they are executed. Have to see what the commands return..

quasar ( 2014-04-30 09:36:04 +0300 )edit

hi bockersjv, thank you. Okay i can try 30 minutes. But have you see anything during the process?

quasar ( 2014-04-30 09:39:31 +0300 )edit

no after 30 minutes the same. I think i will contact Jolla Care directly. Or any other solution?

quasar ( 2014-04-30 12:17:40 +0300 )edit
0

answered 2014-07-14 14:23:21 +0300

sursomfan gravatar image

I have the same problem: stuck on bootup with the Jolla-logo.

I guess there is nothing else to do besides throwing the phone in the garbage can (where it belongs).

edit flag offensive delete publish link more

Comments

how dramatic!

dsilveira ( 2014-07-15 22:55:19 +0300 )edit
0

answered 2014-09-28 18:00:50 +0300

krayne gravatar image

Same problem with my Jolla. How do you solve this issue?

edit flag offensive delete publish link more

Comments

How does this qualify as an answer?

dsilveira ( 2014-09-29 20:07:36 +0300 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2014-04-28 02:10:31 +0300

Seen: 1,856 times

Last updated: Sep 28 '14