We have moved to a new Sailfish OS Forum. Please start new discussions there.

[bug] Roaming: Data connection does not work

asked 2014-04-29 00:29:01 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-05-02 00:18:27 +0300

jgr gravatar image

I am in Italy and cannot get any data connection on any of the 4 providers providing a signal. The same SIM works without problems in the surf stick connected to the computer right now (which is not the intended use for this SIM).

The problem is a wrong APN setting, see https://together.jolla.com/question/4664/roaming-data-connection-does-not-work/ (reported in December and several major updates later still not corrected). This is not a minor problem: When being abroad, the smartphone with mobile data may be the only way available for internet connection -- so when realising the problem, there is no chance to search the internet to find a (the) solution.

edit retag flag offensive close delete


I was experiencing somewhat the same - AT&T SIM with Elisa in Finland was not yielding any data, although once I switched to "stick to 2G" mode I could get data to work in roaming, still no luck in "prefer 3G" mode though

TopStreamsNet ( 2014-04-29 09:53:32 +0300 )edit

@TopStreamsNet: A wrong APN setting should not allow any mobile data connection, no matter what mobile protocol/speed. In my case it is a wrong APN, as I could verify meanwhile.

jgr ( 2014-05-02 00:20:13 +0300 )edit

@jgr: I didn't say I had an APN issue, subject says "roaming: data connection does not work" - I experienced the same - data connection didn't work for me in roaming, but I was able to solve it by switching to 2G

TopStreamsNet ( 2014-05-02 06:56:02 +0300 )edit

@TopStreamsNet Your post didn't mention details so mentioning this just in case: if you had a north american device then it operates on different 3G WCDMA bands, only common bands with european service providers are on 2G.

tkenakka ( 2014-05-09 22:52:36 +0300 )edit

2 Answers

Sort by » oldest newest most voted

answered 2014-05-09 22:56:06 +0300

tkenakka gravatar image

@jgr Have you tried editing your APN settings manually? That works around the issue if device does not have correct settings (APN name, type, username/password if applicable) for the sim/service provider.

edit flag offensive delete publish link more


To edit it manually you have to know the correct settings (and to know, where within Sailfish OS to change the APN settings). To gather these information, you need Internet access ...

Yes, I did find out the correct settings in time and corrected them manually. Only therefore in my post I could pinpoint the cause of the problem.

jgr ( 2014-05-10 00:42:48 +0300 )edit

Good to hear you were able to work around the problem. Since it helped the root issue seens to be the settings resolved by the device. An another workaround would be to request the service provider to send you a configuration message. Many operators offer such a service via sms or internet.

(Agreed, without an internet connection finding the details on how to do that might be difficult).

tkenakka ( 2014-05-10 07:57:25 +0300 )edit

@jgr Btw if you had Italian sim cards for which the Internet (APN) settings were wrong, could you specify which those were? That would help Jolla to identify issues in their initial settings provisioning.

tkenakka ( 2014-05-10 10:30:09 +0300 )edit

"Roaming": I.e. I did not have an Italian SIM.

Provider and required APN settings: It is all linked in my question ("So for O2 germany its "internet"").

jgr ( 2014-05-11 00:05:41 +0300 )edit

answered 2014-09-16 10:05:20 +0300

meldolion gravatar image

I had the same problem beeing in spain vacation. in germany i do have the o2 operator, for data roaming the spanish movistar was the provider to go, but sailfish did not setup any data connection!

edit flag offensive delete publish link more


@meldolion Please check from your service provider is your subscription enabled for data roaming. Some service providers do not allow roaming data unless you explicitly request it. German O2 probably has such cases.

tkenakka ( 2014-09-18 12:28:09 +0300 )edit

thx, for your answer, but that will not be the problem, as it was working with the N9 and same sim card. I will try to change the APN setting manualy as jgr as said, but right now i can't try this until beeing abroad the next time. ;-D

meldolion ( 2014-09-18 14:27:19 +0300 )edit

The Bug is still uncorrected : neither in February 2015 in Pain, nor this week End in Great Britain Data roaming worked...

(I don't try to change manualky the APN in the settings as reported in TJC, as I discover it today...)

Nokia7710 ( 2015-04-27 12:10:07 +0300 )edit

I'm on UK and rights now the data roaming doesn't work! I try many APN like: internet or everywhere with EE and T-Mobile without success with O2 the mobile data is not switchable

i try also with epc.tmobile.com
fast.t-mobile.com no luck

muchasuerte ( 2015-07-05 09:44:41 +0300 )edit

Same here. I use KPN from the Netherlands no problems within the Netherlands. Traveling to France (switch to Orange F) no data connection. Using XA2 version

Maarten ( 2019-05-25 14:58:26 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2014-04-29 00:29:01 +0300

Seen: 3,144 times

Last updated: Sep 16 '14