Ask / Submit
20

Android apps fail to connect to internet after system update.

asked 2013-12-28 00:04:07 +0200

jonnie.samanen gravatar image

updated 2015-06-23 20:22:16 +0200

simo gravatar image

Many android apps fail to connect to internet after the os update today. Even though the connection is fine the app states that there is no internet connection... For eg. Ilta-Sanomat, Yle-Areena, Yandex Store, OP-Mobiili, Youtube and so on. All of these worked perfectly until the update. What to do?

Edit: It actually seems like all of the android apps I've installed have som kind of connection issues.

Edit 2: Unexpectedly it only seems not to be working in wireless at home. When I turn my connection to 3G it works perfectly. Seems a little bit strange.

Edit 3: Reopened, as a user found this bug is back on 1.1.6.27. Three quotes from discussion at JPF:

I can't get some Android apps (FB, Whatsapp) to connect when using WiFi. Only me having this, or has anybode else seen this?

Native apps work, I only have problems with some of the android apps, FB, Whatsapp, FF, even Ookla's Speedtest.

Can confirm that re-installing the Android Support solved it.Does take a couple reboots to really kick in.

edit retag flag offensive close delete

Comments

It doesn't work. There must be something I don't get with the terminal either because I can't even get the folder (nemo@localhost).

But this states that the problem would only occur when using the 3G net. However the apps won't work in WLAN either...

jonnie.samanen ( 2013-12-28 13:02:16 +0200 )edit

For me, Yandex store didn't open (or, started and closed itself immediately) after today's update. Reboot fixed it.

Bale ( 2013-12-28 15:52:50 +0200 )edit
1

I'm not sure if this is the same thing, but I have also had connection problems with Android apps right from the beginning. They have internet access once, then it drops for 20 mins or so, then works fine again, etc. Appears to be DNS related, though, as connecting to an IP address works fine.

martti ( 2014-01-04 22:05:53 +0200 )edit

I've had this problem since the latest update too. Apps that don't check for a connection (Ilmatieteenlaitos for example) work just fine. The funiest one is the official facebook-app, it says it can't download but still it manages to get the first timeline page. No matter what I do, no connection.

McFox ( 2014-01-09 15:56:23 +0200 )edit

... and I don't have a SIM pin code, and I have tried rebooting, restarting the dalvik service etc. too.

McFox ( 2014-01-09 15:58:14 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2014-01-09 16:18:05 +0200

McFox gravatar image

I managed to solve this problem! I uninstalled Android Support from the Jolla Store, rebooted the phone and installed it again. Now all apps I've tested so far work :)

edit flag offensive delete publish link more

Comments

Unfortunately this didn't work for me :( I'm glad to hear your problem is solved, though!

martti ( 2014-01-09 19:36:13 +0200 )edit

Turning off PIN-code prompting and then restaring worked for me with chess time app

olli ( 2014-01-21 09:57:26 +0200 )edit

I had installed Android support before the system update (to 1.0.2.5) - Yandex Store didn't work ("network error"). After the system update Yandex store still didn't work, so I tried this - unfortunately it didn't work for me.

tingo ( 2014-01-24 22:43:17 +0200 )edit

By the way, if I have WiFi on, Android apps can't connect. Maybe it depends on which connection you used while installing Android Support?

McFox ( 2014-02-20 13:22:58 +0200 )edit
1

answered 2014-05-16 16:23:20 +0200

skull77 gravatar image

updated 2014-05-16 16:37:28 +0200

I'm not sure if it is an answer, but it could be. In my case the DNS lookup fails (8.8.8.8:53; google)). At home the port 53 ist free an everything works well. In my company it's blocked, because the firewall resolves the DNS name for me. Normaly the Android Apps shouldn't use the direct way (8.8.8.8:53) to resolve the DNS name. They should ask the firewall and the fw resolves the name. But the android apps ignore this configuration and ask google over 8.8.8.8:53. The other android phones have no problems an ask the fw. The native jolla apps are using the konfiguration an ask the FW for the dns lookup and everything works well. So I think it's an bug at the android vm.

Ok, I found this: https://together.jolla.com/question/2780/sailfish-and-android-apps-using-different-dns/

edit flag offensive delete publish link more
0

answered 2013-12-28 00:28:16 +0200

kimmoli gravatar image

Try the known issue workaround in release notes:

"Reboot the device and enter the PIN code promptly when asked"

https://together.jolla.com/question/3612/release-notes-software-update-2-1025/

edit flag offensive delete publish link more

Comments

This only solves the problem for 3G (I think), but doesn't do the trick for wifi. The problem persists on 1.0.3.8, unfortunately.

martti ( 2014-02-02 13:15:29 +0200 )edit

hum just have the issue on 1.0.4.20 with wifi. I am connected via hotspot. It usually works but not this time: firefox or amazon market place says that there is no internet while I can use the native browser! A reboot is not solving the issue. And I cannot try 3G as I have no sim yet for jolla... Will try at home later today... otherwise I will probably try to uninstall/reinstall the android compatibility layer...

pat_o ( 2014-04-08 17:30:05 +0200 )edit

Yle areena no work anymore and when I try remove it, it's not removed completely, (icon for it remains etc.) and reinstallation not help. (Fault in first place was error 'Media is not available now, try again later' all time.)

ame ( 2014-05-10 14:31:05 +0200 )edit
Login/Signup to Answer

Question tools

Follow
6 followers

Stats

Asked: 2013-12-28 00:04:07 +0200

Seen: 10,416 times

Last updated: Jun 23 '15