E-Mail: SMTP 504 Unrecognized Authentication Type (Support for AUTH LOGIN)

asked 2014-05-03 13:59:06 +0200

Swl gravatar image

updated 2014-05-05 11:23:28 +0200

VDVsx gravatar image

Hi,

Like a couple of others on togethere i'm facing issues with sending mail over SMTP. I did however not find this particular error. However i send my authentication, be it encrypted or not encrypted (always over SSL). I'm getting hit with a:

[7071] maj 03 12:46:32 [Debug] SMTP : newConnection
[7071] maj 03 12:46:32 [Debug] SMTP : Open SMTP connection
[7071] maj 03 12:46:32 [Debug] Messaging : QMailTransport::Socket::Socket SET PROXY host= "" port= 0
[7071] maj 03 12:46:32 [Debug] Messaging : Opening connection - "submit.notes.lotuslive.com" : 465 SSL
[7071] maj 03 12:46:32 [Debug] Messaging : SMTP : connection established
[7071] maj 03 12:46:32 [Debug] Messaging : SMTP : Secure connection established
[7071] maj 03 12:46:32 [Debug] SMTP : Connected
[7071] maj 03 12:46:32 [Debug] SMTP : RECV: "220 usdl3-ln00-ws03.ben.dc5.lotusliveops.com ESMTP Service (Lotus Domino Build V851SAAS_M11_04172014_FP1) ready at Sat, 3 May 2014 10:46:42 +0000"
[7071] maj 03 12:46:32 [Debug] SMTP : SEND: EHLO [127.0.0.1]
[7071] maj 03 12:46:32 [Debug] SMTP : RECV: "250-usdl3-ln00-ws03.ben.dc5.lotusliveops.com Hello [127.0.0.1] ([10.13.34.1]), pleased to meet you"
[7071] maj 03 12:46:32 [Debug] SMTP : RECV: "250-HELP"
[7071] maj 03 12:46:32 [Debug] SMTP : RECV: "250-AUTH LOGIN"
[7071] maj 03 12:46:32 [Debug] SMTP : RECV: "250-DSN"
[7071] maj 03 12:46:32 [Debug] SMTP : RECV: "250-SIZE 102400000"
[7071] maj 03 12:46:32 [Debug] SMTP : RECV: "250 PIPELINING"
[7071] maj 03 12:46:32 [Debug] SMTP : SEND: AUTH PLAIN <removed auth="" string="">
[7071] maj 03 12:46:32 [Debug] SMTP : RECV: "504 Unrecognized authentication type"
[7071] maj 03 12:46:32 [Debug] Messaging : void SSOSessionManager::recreateSsoIdentity() Recreating SSO identity using auth method "password"
[7071] maj 03 12:46:32 [Debug] authsessionimpl.cpp 174 initInterface
[7071] maj 03 12:46:32 [Debug] authsessionimpl.cpp 270 process sending to queue
[7071] maj 03 12:46:32 [Debug] dbusoperationqueuehandler.cpp 135 execQueuedOperations Executing cached oparation: SIGNATURE: "process(SessionData,QString)"
[7071] maj 03 12:46:32 [Debug] dbusoperationqueuehandler.cpp 147 execQueuedOperations
[7071] maj 03 12:46:32 [Debug] authsessionimpl.cpp 265 process sending to daemon
[7071] maj 03 12:46:32 [Debug] SMTP : Got SSO response
[7071] maj 03 12:46:32 [Debug] SMTP : SEND: AUTH PLAIN <removed auth="" string="" the="">
[7071] maj 03 12:46:33 [Debug] SMTP : RECV: "504 Unrecognized authentication type"
[7071] maj 03 12:46:33 [Debug] Messaging : void SSOSessionManager::credentialsNeedUpdate() Setting credentials need update for the service "smtp" from account 17 using authentication method "password"
[7071] maj 03 12:46:33 [Debug] SMTP : Closed connection: "504 Unrecognized authentication type"
[7071] maj 03 12:46:33 [Debug] Messaging : Action completed 5712306503761 result failure
[7071] maj 03 12:46:42 [Debug] IMAP : "9" SEND a006 LOGOUT
[7071] maj 03 12:46:42 [Debug] IMAP : "9" RECV: * BYE logging out
[7071] maj 03 12:46:42 [Debug] IMAP : "9" RECV: a006 OK LOGOUT completed
[7071] maj 03 12:47:04 [Debug] identityimpl.cpp 103 updateState Updating state: NeedsRegistration
</removed></removed>

Using encrypted password instead of plain gives the same 504 from the SMTP server. Using f.ex Apple Mail on OSX works fine, so the server does handle smtp like it should.

update: [nemo@Jolla ~]$ ag-tool update-service 17 email bool:smtp/authentication=1
[nemo@Jolla ~]$ /usr/bin/messageserver5
[5290] maj 04 12:25:57 [Debug] Messaging : Running action TransmitMessagesRequest 20946555502594
[5290] maj 04 12:25:57 [Debug] SMTP : newConnection
[5290] maj 04 12:25:57 [Debug] SMTP : Open SMTP connection
[5290] maj 04 12:25:57 [Debug] Messaging : QMailTransport::Socket::Socket SET PROXY host= "" port= 0
[5290] maj 04 12:25:57 [Debug] Messaging : Opening connection - "submit.notes.lotuslive.com" : 465 SSL
[5290] maj 04 12:25:58 [Debug] Messaging : SMTP : connection established
[5290] maj 04 12:25:58 [Debug] Messaging : SMTP : Secure connection established
[5290] maj 04 12:25:58 [Debug] SMTP : Connected
[5290] maj 04 12:25:58 [Debug] SMTP : RECV: "220 usdl3-ln00-ws02.ben.dc5.lotusliveops.com ESMTP Service (Lotus Domino Build V851SAAS_M11_04172014_FP1) ready at Sun, 4 May 2014 10:26:07 +0000"
[5290] maj 04 12:25:58 [Debug] SMTP : SEND: EHLO [127.0.0.1]
[5290] maj 04 12:25:58 [Debug] SMTP : RECV: "250-usdl3-ln00-ws02.ben.dc5.lotusliveops.com Hello [127.0.0.1] ([10.13.34.1]), pleased to meet you"
[5290] maj 04 12:25:58 [Debug] SMTP : RECV: "250-HELP"
[5290] maj 04 12:25:58 [Debug] SMTP : RECV: "250-AUTH LOGIN"
[5290] maj 04 12:25:58 [Debug] SMTP : RECV: "250-DSN"
[5290] maj 04 12:25:58 [Debug] SMTP : RECV: "250-SIZE 102400000"
[5290] maj 04 12:25:58 [Debug] SMTP : RECV: "250 PIPELINING"
[5290] maj 04 12:25:58 [Debug] SMTP : SEND: MAIL FROM: <>
[5290] maj 04 12:25:58 [Debug] SMTP : SEND: RCPT TO: <
>
[5290] maj 04 12:25:58 [Debug] SMTP : SEND: DATA
[5290] maj 04 12:25:58 [Debug] SMTP : RECV: "530 Authentication required"
[5290] maj 04 12:25:58 [Debug] SMTP : Closed connection: "530 Authentication required "
[5290] maj 04 12:25:58 [Debug] Messaging : Action completed 20946555502594 result failure

edit retag flag offensive close delete

Comments

Your server only supports one authentication methods that is current not enabled in our MW and also marked to be deprecated(SMTP : RECV: "250-AUTH LOGIN"). You can make it work by modifying the account via command line(any modification then in accounts UI will overwrite that).

pkcon install libaccounts-glib-tools
ag-tool list-accounts //check the id of your account
ag-tool update-service ACCOUNT_ID email int:smtp/authentication=1

Restart messageserver5 or reboot the device.

VDVsx ( 2014-05-03 14:13:47 +0200 )edit

Hm.. that turns off "Secure connection" in the UI and getting a SMTP : Closed connection: "Have not received any greeting from SMTP server, probably configuration error" when trying to connect instead.

I have however also contacted IBM Support on that issue, see if they can put us over to a more modern smtp server that accepts these connections.

Swl ( 2014-05-03 14:31:26 +0200 )edit

Ah sorry, wrong command, edited above. Please enable secure connection in the UI before performing last command again.

VDVsx ( 2014-05-03 15:16:49 +0200 )edit

Ah, that gives a "530: Authentication required" instead, and naturally it does turn off authentication in the UI as well. I have like i said written to IBM on the subject as well, since it's their SMTP server, so we can leave this a little bit hanging for now.

Swl ( 2014-05-03 15:33:43 +0200 )edit

Should not, that's login mechanism you should see LOGIN in the logs, like I said above you can't open accounts UI for that account after command line edit since it will auto-correct to the known options.

VDVsx ( 2014-05-03 15:37:14 +0200 )edit