Ask / Submit
2

Browser - Next track on Bandcamp won't start playing if the screen is locked

asked 2014-05-05 13:57:17 +0200

Teme gravatar image

updated 2014-05-05 14:23:52 +0200

I ran into a minor annoyance while using Bandcamp's mobile version over 3G (Jolla's browser is served this web app by default - the "switch to desktop view" option is at the bottom of the page). The links provided are straight to an album for your convenience and I'm in no way affiliated with it.

To reproduce:

  1. Navigate with the browser to: http://tenmillionsounds.bandcamp.com/album/finding-time
  2. Song keeps playing and after set delay the screen is locked. For testing purposes you can fast forward so that there are only 10-20s of the song left and lock the screen manually (problem still occurs).
  3. Observe that the next track does not start playing by itself
  4. Unlock screen - next song starts immediately playing

Expected:

  1. Navigate with the browser to: http://tenmillionsounds.bandcamp.com/album/finding-time
  2. Next track after the other starts through the whole album even if screen has been locked (manually or automatically with set delay)

On IRC a bug in browser's sleep/standby functionality was suspected, although it could be a reasonable default to not let the browser perform any requests in the background after some time period (to conserve battery & bandwidth). The problem is probably encountered on any site which does not stream all of the content at once, but changes to the next item automatically once the previous one has finished (Youtube playlists, Soundcloud etc). I've performed no field testing in other services.

edit retag flag offensive close delete

Comments

Is this over WiFi or 3G?

veskuh ( 2014-05-05 14:09:21 +0200 )edit

3G - have not tested over WiFi. Updated question.

Teme ( 2014-05-05 14:12:01 +0200 )edit

1 Answer

Sort by » oldest newest most voted
3

answered 2014-05-05 14:50:33 +0200

veskuh gravatar image

Thanks for reporting this. I've been testing this now a little bit and on WiFi the changeover to next song most of the time seems to work, but on 3G I'm seeing the same issue.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-05-05 13:57:17 +0200

Seen: 844 times

Last updated: May 05 '14