We have moved to a new Sailfish OS Forum. Please start new discussions there.

SDK: No SailfishOS template available in 'New File or Project'

asked 2014-05-11 19:00:06 +0300

teemupa gravatar image

I'm not able to select the SailfishOS templates in QtCreator when running on Windows 7 with a username that contains scandinavian characters. I've tested this with different username without scandinavian characters and it seems to be working just fine.

Problem: Can't access SailfishOs templates when Windows username contains scandinavian characters.

I know the SDK is still alpha but this is quite annoying since my primary Windows user account has the scandinavian characters (and everyone else who uses Windows in Finnish at least).

And btw the Windows installer uses '/' instead of '\' when defining the path.

edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted

answered 2014-05-11 21:47:10 +0300

kaltsi gravatar image

This is fixed in the next release of the SDK. Meanwhile you can use a workaround by adding a command line parameter to Qt Creator when it's launched. You don't need to reinstall or anything, just add the command line parameter to the Qt Creator icon properties.

See here: https://lists.sailfishos.org/pipermail/devel/2014-April/004024.html

Btw, I'm Finnish and I don't have Scandinavian characters in my name, also I don't use my full name as the windows user id, so that was a bit of a generalisation on your part :-)

What about the / vs \ part? Where do you see that as a problem?

edit flag offensive delete publish link more


Thanks! Just that Windows uses \ not /. No biggy.

teemupa ( 2014-05-11 21:53:27 +0300 )edit

Yes, but where does the installer show / instead of \ ? I can't test it right now, but if you tell me, then I can check it tomorrow.

kaltsi ( 2014-05-11 21:56:22 +0300 )edit

Oh, yes. When defining the workplace where you just type the path instead of browsing. Didn't test it with \ though!

teemupa ( 2014-05-11 22:01:24 +0300 )edit

I believe that if you type the path manually then it will accept both chars and converts them internally as needed. That's a feature :-)

kaltsi ( 2014-05-11 22:06:25 +0300 )edit

Ok, cool. Thanks again for your fast answers.

teemupa ( 2014-05-11 22:11:06 +0300 )edit
Login/Signup to Answer

Question tools

1 follower


Asked: 2014-05-11 19:00:06 +0300

Seen: 148 times

Last updated: May 11 '14