Ask / Submit
0

[solved] Qt Creator connecting to emulator

asked 2014-05-17 19:42:21 +0200

FloR707 gravatar image

updated 2014-05-18 21:13:47 +0200

Hi,

I just installed the new SDK but now I do not get a connection the the emulator anymore. Can anyone tell me what this error message means?

:-1: Error:SailfishOS Emulator: Problem with private key: No such file or directory

Several keys were created in emulator and vmshare.

[edit] Within the options I found under devices "re-generate ssh keys". After doing this I get the error that the emulator rejected the new key. Has anyone figured that out already?

[edit2] Sorry for leaving out these details. I am using a Mac with the latest OS X. The SDK is installed in ~/Programs/SailfishOS as I had it before. My username is a single word with pure ASCI letters.

[edit3] Looks like that was a little to fast. Qt Creator says I am connected but I cannot deploy a program...

ssh: connect to host 10.220.220.1 port 22: No route to host
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
Deploy failed
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [sender=3.1.0]
22:59:09: the prozess "... .config/SailfishAlpha4/mer-sdk-tools/MerSDK/SailfishOS-i486/deploy" wurde mit dem Rückgabewert 1 beendet.
Error while creating/deploying the project Test(Kit: MerSDK-SailfishOS-i486)
during the step 'Rsync'

If I test the connection in the Qt Creator settings it is okay.

edit retag flag offensive close delete

Comments

  • What's your host computer?
  • If Windows, which version?
  • Into which path did you install the SDK?
  • In your host computer do you have a username that has space or non-ascii characters?
kaltsi ( 2014-05-17 22:44:41 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-05-17 23:57:19 +0200

FloR707 gravatar image

Okay I think I solved it. With re-generating the key (or something else) a new folder was created in Programs, SailfishOS. The new folder also had the emulator and vmshare folder but the emulator still looked at the original folder in ~/Programs/Sailfish/... After changing the path in the emulator (Host+S) -> Shared Folders and a restart the connection worked.

edit flag offensive delete publish link more

Comments

Ok.. the correct way to recover from this is to quit qtcreator and remove the ~/.config/SailfishAlpha4 directory and then restart qtcreator. It will recreate the config files with the new paths.

kaltsi ( 2014-05-18 14:01:17 +0200 )edit

I solved it by reinstalling everything again and using ~/Applications/SailfishOS/ as folder. This worked right away.

FloR707 ( 2014-05-18 21:13:35 +0200 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-05-17 19:42:21 +0200

Seen: 1,155 times

Last updated: May 18 '14