Ask / Submit
92

[hotfix] Opt-in hotfix for connectivity in upcoming update 7 [not relevant]

asked 2014-06-09 16:06:07 +0200

Aard gravatar image

updated 2015-07-25 21:31:16 +0200

eric gravatar image

Update: we just released this to subscribers. (12.6., 14:20 EEST)

We've been working for a while on updating connman to a newer version (from 1.15 to 1.23). It will fix connectivity issues in some environments - but comes at a regression risk in some networks where the old one worked fine.

We used all the different networks available to us to identify and fix issues - but there's a lot more interesting network hardware out there, so we decided not to include it in update7, but make it available for community members as opt-in hotfix, which will be published the same week as the update, hoping that the new stack gets the toughest and widest audience for testing.

If you want to test the new connectivity stack please send an email with arbitrary content to connman-hotfix@jolla.com, making sure the From-Address used is the one matching your Jolla account. After processing your email (which may take a while) you should get an update notification and be able to install the hotfix like any regular update.

Please add new issues as answers to this post or for already known issues add a comment to the answer describing your issue. If you want to go back to the old connectivity stack just send an email to connman-hotfix-opt-out@jolla.com, after a while you'll get an update notification which will bring you back to the main update.

edit retag flag offensive reopen delete

The question has been closed for the following reason "question is not relevant or outdated" by chemist
close date 2014-09-21 17:48:02.092477

Comments

This is cool, but wouldn't it be cooler by following/unfollowing here or via store?

harry ( 2014-06-09 16:21:12 +0200 )edit
8

I think this is the appropriate way - if it was too easy to opt-in, inexperienced users might try it and break something.

nodevel ( 2014-06-09 16:24:13 +0200 )edit

would be better if one could hotswap between the versions, so i could test both in places that i dont visit all too often and have baf reception like my summer home in the middle of nowhere.

Whippler ( 2014-06-09 16:27:44 +0200 )edit
11

Does this version support WPA2-PSK/AES (and others) networks or do we need to install the patched wpa_supplicant again?

Alex ( 2014-06-09 16:34:29 +0200 )edit
8

To be clear, this only affects wifi and bluetooth? Not the normal GSM/LTE reception?

BonoNL ( 2014-06-09 16:37:44 +0200 )edit

23 Answers

Sort by » oldest newest most voted
15

answered 2014-06-16 20:43:01 +0200

updated 2014-07-15 18:08:21 +0200

nightmare gravatar image

Jolla definitely has a problem with DHCP renewal ... I just watched the DHCP log at home (2 hours lease time) and while all other devices correctly renewed their IP address, Jolla did not do so ...

The bad thing in addition is, that Jolla keeps using the (not renewed) IP address and is this way a potential threat to the network, as this generates the risk of duplicate IP.

EDIT: I tested the behaviour of Jolla on being active (screen on) or standby (screen off). Therefore I set the DHCP lease to T=600 sec and resetted firewall (DHCP server) and Jolla.

  • with screen on Jolla perfectly renewed it's IP lease after T/2
  • with screen off Jolla did not renew it's IP address at all, so it expired after T - activating the screen did not solve the problem, IP stayed expired, Jolla had to be rebooted

EDIT: see comments below, chances are high, that missing DHCP renewal is a consequence of failing layer 2 connection

Edit Nightmare 15.07.2014: same problem with 1.0.8.19!!

edit flag offensive delete publish link more

Comments

I'm not using DHCP, but RA at home and have the same problems. So there's either two issue here, or the issue is elsewhere and DHCP not renewing is merely a symptom of that..

WhyNotHugo ( 2014-06-18 05:15:26 +0200 )edit
2

@hobarrera Agreed, Jolla really seems to loose layer 2 connection, so potentially not even DHCP broadcast/unicast renewals are getting through. Also in my case IPv6 RA connection dies usually in the very moment also IPv4 dies.

Manankanchu ( 2014-06-18 10:44:59 +0200 )edit

@Manankanchu: I hand't thought about it being layer 2 (or lower?). I'll try disabling power-saving in my router and see if that's related (it's the only layer 2-issue I've had in the past). In my case, I have no IPv4, so I was unaware that both were lost at the same time.

WhyNotHugo ( 2014-06-18 11:44:31 +0200 )edit

Ok, so my router's wifi driver doesn't support disabling power-saving mode, so I can't try that to determine if it's the issue or not. If somebody can run a quick test on this, we might discard that option.

WhyNotHugo ( 2014-06-18 12:09:10 +0200 )edit

Tried to test power saving and wasted lot of time as this horrible Jolla WiFi shows to be connected on SSID1 (standalone Cisco office access point) while in fact it is connected to SSID2 (hotspot WiFi with Cisco WLC controller) where SSID2 is deactivated in Jolla GUI

Manankanchu ( 2014-06-18 15:32:39 +0200 )edit
12

answered 2014-06-13 11:24:52 +0200

sremes gravatar image

It seems that when both wifi and mobile data are enabled, the device is connected to both of them (ifconfig shows two IP addresses, wlan0 and rmnet0). Testing which connection is actually used, I downloaded a file, and it seemed to use mobile data for that (again checking ifconfig for RX/TX bytes line). Tried toggling the wifi, but the phone still prefers to use mobile data instead of wifi. The WLAN here is not encrypted (no WPA).

edit flag offensive delete publish link more

Comments

I also noticed that with both WLAN and MOBILE enabled, there was no way to use WLAN.

magullo ( 2014-06-13 11:50:30 +0200 )edit
1

Found out the same problem, it seems that only the default route to rmnet0 (mobile network) is preserved, but IP address from the WLAN is also retrieved. I know this may be too advanced, but what about having different routing tables for each connection (mobile, WLAN) etc. and then using policy routing, firewall marking for directing the traffic to correct pipe?

Karri Huhtanen ( 2014-06-13 19:52:14 +0200 )edit

It is not advanced, you just need to set different metric to the route based on interface type. This is pretty basic setup. No need to play with firewall or anything complicated. But have no idea how to do it in connman (yet).

miska ( 2014-06-13 23:53:18 +0200 )edit

my phone acts just fine. it uses wlan, mobile data is enabled with good signal strength but no connection established(ifconfig shows only loopback lo and wlan0).

nightmare ( 2014-06-14 00:40:14 +0200 )edit
2

It's a bug in connman that sometimes setting default route to the wifi connection doesn't always work.

llornkcor ( 2014-06-14 11:13:20 +0200 )edit
10

answered 2014-06-17 13:30:47 +0200

cquence gravatar image

With 1.0.7.18 there are still problems when switching between WiFi and Mobile Data. Sometimes the phone decides to not connect to the known WiFi, sometimes the phone flashes both WiFi and Mobile Data network icons without being connected to either of those. Other times I tried to toggle the Flight mode in order to "reset" the connection settings when they got stuck and flight mode was not being enabled at all, I ended up with the Flight mode indicator flashing at the same rate that the Mobile Data icon was flashing along with the exclamation mark in it. (2G on an area with poor reception). In this scenario I was switching on WiFi, WiFi stayed on but did not bother to connect to the known WiFi that existed in the area. Rebooting the phone seems to cure these problems since the known WiFi gets detected immediately and the phone connects.

Also I didn't see any improvement in automatic switching when walking out of my house [WLAN] and a transition into Mobile Data is required. I still have to wake the phone and tap on the screen for it to refresh its state and realize that WLAN is no longer available and it should connect to the Mobile Data network.

Overall I think that there is a lot of work needed in handling the connection switch between WLAN and Mobile Data. I think its the major "broken" thing on the phone for a while. You cannot rely on the phone for data connections, you have many applications open and cannot be sure if you don't get notifications because there aren't any or because the phone simply has dropped the data connection in the background but still thinks [and the apps also] that it has an active data connection.

edit flag offensive delete publish link more
6

answered 2014-06-13 12:32:09 +0200

2Ti gravatar image

I haven't so far had any other problems with the hotfix, other than connecting to my university's eduroam WiFi network. It would be fantastic if the eduroam/enterprise WiFi connection problems could be fixed.

There is a full list of settings for the Sussex eduroam instance here. Please let me know if there are any logs etc. I can provide to help in getting this fixed.

edit flag offensive delete publish link more

Comments

Same experience here. My Jolla fails to connect to most enterprise wifi networks. I always get "Sorry. Could not connect to selected network. Search again", when trying to any network that requires a user name and password log in or certificate.

My home wifi has always been very stable. It acts just like before with the patch. Automatically connects when I get home and switches to mobile when I leave. No problems there. My wifi and mobile is always on. When I am at home it always use wifi.

AbyZThomas ( 2014-06-13 16:41:50 +0200 )edit

Do you use username@sussex.ac.uk as your username (Identity in conf.)? Also you need retrieve ("Thawte Premium Server CA") certificate in a file, place it to for example /etc/ssl -directory and direct CACertFile mentioned in https://together.jolla.com/question/315/wpa-8021x-enteprise-others-wifi-support-needed-workaround/ to that file. That should do it, according to those Sussex instructions. However, beware that Jolla does not really support WPA2 Enterprise properly, wish it did.

Karri Huhtanen ( 2014-06-13 20:00:18 +0200 )edit

I do use that identity. I did not have the certificate file installed before as the connection worked with the default ca-bundle.crt, I installed it now however, but the connection still does not work. The error I get in the wpa_supplicant log is

err='Server used client certificate'

I noticed that Sussex also supports TTLS-MSCHAPv2, TTLS-MSCHAP and TTLS-PAP, tried all of those but the error is always the same. I'm guessing this is the same issue as here?

2Ti ( 2014-06-18 12:55:47 +0200 )edit
6

answered 2014-06-14 10:18:28 +0200

duesselschorsch gravatar image

updated 2014-06-17 09:50:36 +0200

With the hotfix installed, my Jolla loses its IP address after some time when connected to my home WIFI network, while still staying connected to it (maybe when the dhcp lease runs out? I have set it to one hour). If I disable WIFI temporarily and enable it again, it will get an address again. I'll try to opt-out from the hotfix now to see if this is related to the hotfix or to 1.0.7.16

Edit: I opted-out from the hotfix now, back at 1.0.7.16 my Jolla seems to keep its WIFI address again. BTW: my WIFI router is a Mikrotik RB2011UAS-2HnD-IN with RouterOS 6.15

edit flag offensive delete publish link more

Comments

I have the same issue of the device loosing it's IP. I don't think it's related to the DHCP lease expiring because my network does not have DHCP, only RA.

WhyNotHugo ( 2014-06-14 17:29:18 +0200 )edit
2

Same issue here, connected to a Public Hotspot (Cisco WLC controller, 25 units of Cisco 1602 access points) Jolla looses the routing while still having it's IP address configured via DHCP (checked through ifconfig in CLI). The hotspot has a very short DHCP lease (8 minutes) so this happens frequently. Manual WiFi disassociation and reassociation gets me the same IP address like before and routing is okay again.

While in my home WiFi with long lease times Jolla stays connected.

Maybe it's really an issue on DHCP renewal of IP address ?

Manankanchu ( 2014-06-16 12:19:48 +0200 )edit

same Problem here, connectio nestablished but no transfers possible. i don't know if it's connected to DHCP lease time, but could be possible (have the problem over night and a lease time of 12h)

nightmare ( 2014-06-16 16:04:59 +0200 )edit

@nightmare As I mentioned before, the issue is also present on networks that use RA instead of DHCP, so I don't think that's the cause.

WhyNotHugo ( 2014-06-17 04:45:32 +0200 )edit
5

answered 2014-06-14 13:15:14 +0200

Ozymandias gravatar image

So far I have the feeling the hotfix handles wifi/mobile changes better, but today when I woke up Jolla claimed to be connected to my wifi, but the internet didn't work. When I turned off wifi, it started to signal "problem with connection" and didn't stop, no matter what I activated or deactivated, even with both mobile and wifi off it still said "problem with connection" every few seconds. After reboot it seems to work fine again.

edit flag offensive delete publish link more

Comments

The "problem with connection" loop happened to me yesterday in an underground garage where there was no cell signal. Instead of rebooting, I attempted turning the airplane mode on/off and it solved the problem.

incognito ( 2014-06-14 14:00:04 +0200 )edit

Just had the no connection loop again, after doing a reset of my router (maybe just a coincidence, but I noticed it ~30 minutes after that reset) Airplane mode did not help. Reboot did.

Ozymandias ( 2014-06-15 16:54:45 +0200 )edit
1

Woke up again to find that Jolla was "connected" to my Wifi but didn't have working internet. This time no connection error loop, simply de- and reactivating wifi worked.

Oh and I'm running suspend policy on "early", but it was on the charger, so that shouldn't make a difference anyway.

Ozymandias ( 2014-06-17 09:51:11 +0200 )edit
4

answered 2014-06-13 07:59:16 +0200

WhyNotHugo gravatar image

updated 2014-06-13 12:28:05 +0200

This issue (not picking up the advertised default gateway), introduced in 1.0.7.16 seems to have gone (hasn't ocurred again since, but it's always hard to tell with these intermitent issues if it was fixed or I've just been lucky).


No real improvement over connectivity. I used to have lots of disconnections and the device failed to reconnect after that. I've since discovered that the device does reconnect, but has no IP address:

ifconfig | grep inet6
inet6 addr: ::1/128 Scope:Host

You know what I realized about that? The device needs a local-link to subscribe to the RA multicast address. The device seems to NOT have a local-link address, and that's very wrong. This is probably why it's not getting any internet access.

Maybe I can provide new feedback regarding my issue? I'd be more than happy to help.


UPDATE: If I try to do stuff like "check mail", I get the wireless connection dialog, every time. I pick my home network, but the same keeps happening (as noted above, it seems I'm actually connected, but IPless). As a workaround, I've found that disabling wireless and re-enabling it generally picks up an IP.

edit flag offensive delete publish link more
4

answered 2014-06-13 11:17:22 +0200

alci gravatar image

Here is my use case on a 24h cycle:

  • home
    • open Wifi (no security at all, except I'm in the middle of nowhere)
    • no mobile network
  • from home to work
    • alternate from 2G, to 3G, to 2G, to no network, to 3G
  • at work
    • 3G
    • WPA-PSK wifi

What happens is that after a work / home / work commuting, mobile data connextion is lost, I have to reboot. My question is: how could I get some logs from connman / ofono I could activate for one or two days to have more information ?

edit flag offensive delete publish link more

Comments

With the phone in developer mode install the connman-tracing package.

Aaron McCarthy ( 2014-06-16 04:48:51 +0200 )edit
3

answered 2014-06-13 10:21:58 +0200

updated 2014-06-13 10:31:15 +0200

At first: Thank you to let us beta-test some of your changes. I hope, we are able to test more new software / releases in the feature.

Now to the hotfix:

I had troubles from the beginning, to connect my Jolla to my WLAN. It was absolutely unstable and I got errors like "Connection Error" and "Wrong value [...]". So I tested around and changed my WLAN encryption from WPA2/PSK-only to WPA/PSK-only (AES).

After that change, all Problems where gone and my Jolla connected with my WLAN without any (or very few) problems. But I think, that this could not be the final solution for this.

So I installed the hotfix yesterday and I tested my WLAN connection again. I updated the firmware of all my hardware to the latest versions:

  • TP-Link TL-WR1043ND with latest OpenWRT snapshot (11.06.2014)
  • TP-Link TL-WDR4900 with latest OpenWRT snapshot (11.06.2014)
  • TP-Link Powerline WLAN Access-point TP-Link TL-WPA4220 with latest firmware

After the firmware updates, I changed the WLAN encryption from WPA/PSK-only to WPA2/PSK-only again and played around a bit.

At first my Jolla connected without any problems to my WLAN, but after a while the connection problems appeared again. My Jolla lost the connection and I was able to reconnect by selecting my WLAN manually. But that happened quite often and this morning my Jolla completely refused to connect to my WLAN and I had to reboot it to get it working again. So I decided to switch the encryption back again and now it works perfectly.

In my /var/log/wpa_supplicant.log I have a lot of these two messages:

  • wlan0: CTRL-EVENT-SCAN-STARTED
  • rfkill: WLAN unblocked

All of them sometimes 6+ times in a row.

So for me, this hotfix did not solve my connection problems at all. I hope, this could be fixed somehow in the future.

edit flag offensive delete publish link more

Comments

I also have 3 access points and the same issue. How did you change to AES? I don't see sny option to chsnge it.

dash72 ( 2014-06-15 23:06:33 +0200 )edit

You have to do that on AP-side. There doesn't seem to be an (UI-)option on our Jolla to stick the encryption to an specific version / method.

ejjoman ( 2014-06-16 11:28:17 +0200 )edit

I also had all the above-mentioned problems. My solution is, I do not use the mobile data connection at all. Only when it is really necessary. And when i do so, it is necessary to reboot, no other solution. A long time ago i was programming in basic. I supose that in Sailfish OS there is the possibility to programming choises as;" if there is wifi choose wifi and only wifi" if there is "no wifi and only than chose 3G ore 4G"? I suppose that for a developer it can not be so difficult to make a similar programline? I hope that finally, the solution will be available in the next update?

MarcG ( 2014-06-25 23:40:15 +0200 )edit

yes, loaded dd-wrt on all 3 three AP's with completly identical wireless settings (N-only and WPA2 aes encryption). no more issues now

dash72 ( 2014-07-08 18:17:28 +0200 )edit
2

answered 2014-06-13 16:31:12 +0200

I am currently not in the environment where I had problem with the WLAN. At my parents home there are two access points, one FritzBox and one TP-Link AC. There I lost connections regularly.

At my home, with only one WLAN access point, I never had these problems.

But yesterday (with 1.0.7.16) my mobile connection was gone. It was greyed out and there was no way to activate it. It was set to auto discovery and the ComboBox below showed the appropriate provider. I tried to set the mobile provider manually, but it did not find anything. Today I installed hotfix (1.0.7.18). After the restart the mobile network was still not available, but now it was possible to choose the provider manually, what fixed the problem and mobile network is back.

edit flag offensive delete publish link more

Comments

1

Hi, I have the problem with loose of mobile provider, too. Once it is lost only a reboot brings the phone back online. Here is the relevant log from journalctrl pastebin journalctrl

harry ( 2014-06-13 16:51:10 +0200 )edit
1

I also have this issue, sometimes switching between "2G only" and the other options helps. If remeber correctly, this never happened in 2G only mode, but I may be wrong.

schmittlauch ( 2014-06-18 00:25:12 +0200 )edit

If I use "3g preferred" everything works stable. But If I use "4g preferred" the mobile internet is not usable. It stops working after 30seconds and can only be reset by a reboot. My mobile provider has 4g support but I have to pay for it. So it is not enabled with my current data plan. Maybe this causes problems.

harry ( 2014-06-24 11:53:04 +0200 )edit

I now used manual Network selection and prefer 2G for a while. And it works without any problem. Will try and observe it with 3G only mode.

Buschmann ( 2014-07-07 14:04:03 +0200 )edit

Question tools

Follow
33 followers

Stats

Asked: 2014-06-09 16:06:07 +0200

Seen: 9,455 times

Last updated: Sep 21 '14