Ask / Submit
24

[bug] Odd wrapping of displayed lockscreen date

asked 2014-06-10 08:51:37 +0200

norguhtar gravatar image

updated 2014-07-15 06:19:40 +0200

Sailfish OS 1.0.7.16, Saapunki, brought us "_Operator name label dynamically displays date for 1500ms when the lockscreen is shown_", which is nice, but to avoid the "_[BUG] lockscreen date string overlaps with notification_" the date string is wrapped, _and the wrapping ends up in weird places_:

Examples: (in reality, the date string is centered)

Russian - the year info is displayed trailing on its own line:

Вторник, 10 июня 2014
г.

One of these would be better

Вторник, 10 июня 2014 г.

or (better, as "г." just means "year")

Вторник, 10 июня 2014

to avoid accidental overlapping with notifications icons, maybe

Вторник
10 июня 2014

English

Wednesday, 11 June
2014

One of these would be better

Wednesday,
11 June 2014

or (without the comma)

Wednesday
11 June 2014

or (for longer month names)

Wednesday,
11 June
2014

or (without the comma)

Wednesday
11 June
2014


UPD still here in 1.0.8.19

edit retag flag offensive close delete

Comments

Today my lock screen date show as "Tuesday, 10 juin 2014" (english day of week with french month). I'm in France with Language set to English. Maybe we should have a more general question for all date formatting & locale problems in lock screen ? (that's why i've posted here)

eber42 ( 2014-06-10 10:27:55 +0200 )edit

I'm add you info to question

norguhtar ( 2014-06-10 10:39:02 +0200 )edit

I forgot i've had custom settings in /var/lib/environment/nemo/locale.conf (LC_TIME=fr_FR.utf8) so i'm probably with an unsupported configuration and my previous message can be ignored. Edit: dates are correct with French and English locale with no locale.conf customization

eber42 ( 2014-06-10 11:25:57 +0200 )edit

@eber42, I guess that's right; I have customized locale and mixed Finnish-English date...

ssahla ( 2014-06-10 13:43:24 +0200 )edit

It also happens with Italian.

Orologiaio ( 2014-06-11 15:55:27 +0200 )edit

4 Answers

Sort by » oldest newest most voted
4

answered 2014-06-11 21:03:22 +0200

ssahla gravatar image

updated 2014-06-11 21:06:12 +0200

I think the date has to be wrapped because the leftmost part of the screen is reserved for notification icons, and therefore the whole width can't be used, and all dates won't fit on a single line. (If the icons were moved down to make room for the date, that would also require modification to the Events screen to keep the icons in place.)

What could be done is that the date would be wrapped only at certain points, like between weekday and date or between date and year (or whatever is reasonable in each local date format), to avoid dividing for example between "2014" and "r." (original poster's case) or "11" and "kesäkuuta" (screencap below from my mixed English-Finnish date).

image description

(The proper dividing points in this example would be "Wednesday / 11 kesäkuuta / 2014".)

edit flag offensive delete publish link more

Comments

1

I like the option with the wrapping after the weekday, but with the year on the same line of day and month.

Orologiaio ( 2014-06-12 13:39:57 +0200 )edit
2

answered 2015-02-18 10:20:17 +0200

hyper_sonic gravatar image

Still present on 1.1.1.27.

image description

edit flag offensive delete publish link more

Comments

they just need to change format. There should not be space between YEAR and "г", i.e. "2015г." (or, as stated above, there should not be "г" at all)

virgi26 ( 2015-02-18 11:14:24 +0200 )edit

I agree, best way to omit symbol years: "г".

hyper_sonic ( 2015-02-18 15:00:37 +0200 )edit

virgi26, no, it' recommended to put a space: http://www.gramota.ru/spravka/letters/?rub=data

Vuubi ( 2015-02-18 20:57:45 +0200 )edit
1

answered 2014-06-11 12:59:23 +0200

Whippler gravatar image

updated 2014-06-11 13:10:17 +0200

You could just edit it yourself. The lockscreen UI is defined in /usr/share/lipstick-jolla-home-qt5/qml/Lockscreen.qml

Enable Developer mode in terminal: "devel-su" "nano /usr/share/lipstick-jolla-home-qt5/qml/Lockscreen.qml" (you might need to install nano) scroll down to where it says

Label {
   id: dateLabel
   anchors { ...}
   width: parent.width - (Screen.width / 5 * 2)

change the line:

width: parent.width - (Screen.width / 5 * 2)

to width: parent.width /* - (Screen.width / 5 * 2) */ so the date can use the whole width of the screen.

you'll need to reboot for it to update.

you could also fiddle with the date format to have it like 11.6.2014 if you like, but im not going to go into that deep here.

edit flag offensive delete publish link more

Comments

thx. I try it

norguhtar ( 2014-06-11 13:01:06 +0200 )edit
0

answered 2014-06-10 09:36:51 +0200

sa.rasputin gravatar image

indeed. poor russian jolla users. :)

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-06-10 08:51:37 +0200

Seen: 588 times

Last updated: Feb 18 '15