Ask / Submit
28

bug: Information about GPS satellites not put through to dalvik [answered]

asked 2013-12-28 14:03:02 +0200

renegade22 gravatar image

updated 2013-12-28 14:37:19 +0200

hzb gravatar image

There are Apps like KeypadMapper for Openstreetmaps, that not only need accuracy (GPS) but also need information on how many GPS satellites are found by the phone, or they just wont work. I tried with osmand+ and discovered, that the GPS coordinates are put through to the Android devices (uncertainty is very low) but the amount on connected satellites stayed at 0/0. The Information about the satellites should at least be faked, but better should be put through to the android apps.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by ymb
close date 2014-01-24 14:15:00.847621

Comments

I can confirm this

Wizah ( 2013-12-28 14:09:55 +0200 )edit
1

Yep, that seems broken still in 1.0.2.5 Maadajävri. Hope this will be fixed in near future.

hzb ( 2013-12-28 14:37:01 +0200 )edit

Perhaps this isn't really a Dalvik problem? When using Qt, QGeoSatelliteInfoSource::createDefaultSource returns NULL (so no satellite info for you), but QtGeoPositionInfoSource::createDefaultSource returns a valid pointer and position information is eventually available.

hammarland ( 2014-01-03 11:15:31 +0200 )edit

I’m still observing this issue (or a similar one). Does it work for others?

nomeata ( 2014-10-09 13:29:50 +0200 )edit

It got better, sometimes it works, sometimes not. Maybe it’s not related to davlik at all here, and the device just had problems getting a fix.

nomeata ( 2014-10-13 00:36:37 +0200 )edit

1 Answer

Sort by » oldest newest most voted
9

answered 2014-01-07 09:03:55 +0200

Aaron McCarthy gravatar image

Thank you for the bug report, it is a known issue and a fix is in progress.

edit flag offensive delete publish link more

Comments

is there an issue tracker where I could see process on the bug, as this question was closed? I'm trying to get RunKeeper to work.

count ( 2014-08-22 13:06:09 +0200 )edit

Any updates on this? Any ETA for the fix?

anandrkris ( 2014-11-27 06:25:23 +0200 )edit

Question tools

Follow
7 followers

Stats

Asked: 2013-12-28 14:03:02 +0200

Seen: 753 times

Last updated: Jan 07 '14