Ask / Submit
21

Is there a config file to change BT keyboard layout? [answered]

asked 2014-06-11 20:04:38 +0200

ossi1967 gravatar image

We finally got support for bluetooth keyboards. I love it! However, there's no way yet to change the layout. It's always set to english QWERTY.

Now the release notes state this is a known issue, but... Isn't there a way to set the kbd layout from the command line with developer mode enabled? I have this really old Nokia SU-8W foldable keyboard with German layout and I'd just love to use it right away. :)

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by ossi1967
close date 2014-11-30 13:53:58.764809

Comments

I would like to know this as well. I have a foldable perixx keyboard with French layout, and it connects just fine. But I seem to not be able to tell the jolla that this is a French layout...

wcr ( 2014-08-03 22:02:56 +0200 )edit

1 Answer

Sort by » oldest newest most voted
7

answered 2014-11-29 23:45:35 +0200

remjey gravatar image

updated 2016-09-12 01:21:32 +0200

I have a temporary solution to this problem for french keyboards.

The keymap file used by default is /usr/share/qt5/keymaps/boston.qmap. This is the only qmap file in the directory. I found that the qmap format for keyboard layout is specific to Qt for embedded devices like phones. It can be created from kmap files with a tool in the Qt development framework named kmap2qmap.

So I used a kmap file from my Linux distribution (fr-latin9.kmap) and converted it to a qmap keyboard layout with the kmap2qmap utility provided with the Qt development kit. Unfortunately, the layout came out bad with dead keys not working and the euro character missing. After investigation I found that kmap2qmap was broken and the euro key code missing from Qt. I had to fix the tokenizer in the kmap2qmap tool and replace the euro symbol with the euro unicode in the keymap.

To apply this keyboard layout in your Jolla, download fr-latin9.qmap and use it to overwrite /usr/share/qt5/keymaps/boston.qmap. You may have to activate the developer mode to do this. Now reboot the phone and your french BT keyboard works !

Here is the implemented layout:

#  ____ ____ ____ ____ ____ ____ ____ ____ ____ ____ ____ ____ ____ _______
# | Œ «| 1 ·| 2 É| 3 ž| 4 Ž| 5 š| 6 Š| 7 È| 8 ¯| 9 Ç| 0 À| ° ÿ| + Ÿ| <--   |
# | œ »| & '| é ~| " #| ' {| ( [| - || è `| _ \| ç ^| à @| ) ]| = }|       |
#  ========================================================================
# | |<-  | A ä| Z Å| E ¢| R Ç| T Þ| Y Ý| U ü| I ï| O ö| P `| " '| £ ë|   , |
# |  ->| | a â| z å| e €| r ç| t þ| y ý| u û| i î| o ô| p ¶| ^ ~| $ ê| <-' |
#  ===================================================================¬    |
# |       | Q Ä| S Ø| D Ë| F ª| G Æ| H Ð| J Ü| K Ï| L Ö| M º| % Ù| µ ¥|    |
# | MAJ   | q Â| s ø| d Ê| f ±| g æ| h ð| j Û| k Î| l Ô| m ¹| ù ²| * ³|    |
#  ========================================================================
# | ^   | > Š| W <| X >| C ©| V  | B  | N  | ? º| . ×| /  | §  |     ^     |
# | |   | < || w «| x »| c ©| v ®| b ß| n ¬| , ¿| ; ×| : ÷| ! ¡|     |     |
#  ========================================================================
# |      |      |      |                       |       |      |     |      |
# | Ctrl | Con+ | Alt  | Space    Nobreakspace | AltGr | Con- | Con | Ctrl |
#  ¯¯¯¯¯¯ ¯¯¯¯¯¯ ¯¯¯¯¯¯ ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯ ¯¯¯¯¯¯¯ ¯¯¯¯¯¯ ¯¯¯¯¯ ¯¯¯¯¯¯

EDIT: new links:

I’ve seen that Bluetooth keyboard layout changing is supported from the settings now, maybe you should give it a try!

edit flag offensive delete publish link more

Comments

1

For OP, here is de-latin1.qmap, tell me if it's good for you.

remjey ( 2014-11-30 02:49:23 +0200 )edit

@remjey: You're my hero. Works amost perfectly - good enough for me anyway.

The things that don't work come from the fact that the Nokia SU-8W keyboard I use isn't a classic German layout, either. The de-latin layout expects some characters to be where they are on my regular PC keyboard, but Nokia decided they'd look prettier in more exotic places. That's not a big deal, though: Letters, numbers and most punctuation marks work fine. And thanks to you, I finally (!) know what file to explore if I want to dig deeper.

Thank you so much, I'm happy! :)

ossi1967 ( 2014-11-30 13:53:23 +0200 )edit

@ossi1967 I just found that the new keyboard layout deactivates the volume buttons... sorry about that, I'll try to find a workaround.

remjey ( 2014-12-03 14:59:57 +0200 )edit

@remjey: oh ;) I noticed that the volume rocker seems to have stopped working, but I had no idea it was related to this. I would have assumed some Android app fcuked up the system and a re-boot would certainly fix it. Was just too lazy to try. ;)

Doesn't matter that much, though. As long is I know where it comes from and I can fix it by cipying the original file back...

ossi1967 ( 2014-12-03 19:49:56 +0200 )edit
2

Hey there, I updated the french and german keyboard layouts, now the volume buttons are working again.

remjey ( 2014-12-07 19:22:35 +0200 )edit

Question tools

Follow
9 followers

Stats

Asked: 2014-06-11 20:04:38 +0200

Seen: 6,736 times

Last updated: Sep 12 '16