Wiki: How to disable email notification force feedback

asked 2014-06-12 18:48:52 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2017-11-10 08:55:58 +0300

Manatus gravatar image

To make this change you need developer mode enabled. See: https://together.jolla.com/question/32459/howto-access-command-line-with-root-privileges/

Email notifications are handled in

/usr/share/ngfd/events.d/email.ini

Before editing the file, you should make a backup of it to a directory you can easily find (such as /home/nemo/). Do not leave backup of the file in the same directory as email.ini as all files in the folder are active and it would override the changes.

In the email.ini put # character in the beginning of all lines in the email.ini that start with:

ffmemless.effect =
haptic.type =

Save the changes and reboot the phone.

Notes:

  • To disable email notification LED, please see this wiki.
edit retag flag offensive close delete

Comments

1

I have earlier presented my solution to this as an answer in https://together.jolla.com/question/24674/possible-to-disable-vibration-for-emails/. I first tried it your way, but as it seemed to have no effect, I defined a new effect NGF_NONE. But have you got it working this way? Did it start working after deleting the .ini_bak?

ssahla ( 2014-06-12 20:54:59 +0300 )edit

Yep, it seems to be working for several hours now. I'll update this wiki, and may delete it in favor of yours, if it stops working. Or if no-one else gets the same results. :)

Manatus ( 2014-06-12 21:29:21 +0300 )edit

Ok! I don't have the hack applied on my phone now, because it was undone by updating, so maybe I'll try it this time with your instructions and report it it works that way.

By the way, did you try if you can also disable the led notification by editing this file (removing the mce.led_pattern line), or do you have to do it the way described in https://together.jolla.com/question/46454/how-to-disable-email-notification-led/?

ssahla ( 2014-06-12 21:56:55 +0300 )edit

The discrepancies between what is defined in settings, and what is defined in the ambience is something that really needs improving. I have disabled email notification sound in the ambience I use, and don't get any vibrations either, but the whole thing is just so freaking unintuitive...

Tanghus ( 2014-06-12 22:16:04 +0300 )edit

Ok, I edited email.ini the way described in the question, and it really seems to work. Vibration is disabled.

Also, I deleted the lines for mce.led_pattern, and now the led notification is disabled too. So no need to edit 20hybris-led.ini when you can do that also in email.ini.

@Tanghus, setting "no sound" for email in ambience settings doesn’t remove the vibration...

ssahla ( 2014-06-12 22:55:53 +0300 )edit