Ask / Submit
0

File '/repodata/repomd.xml' not found on medium 'https://store-repository.jolla.com/features/latest/xt9/armv7hl/?credentials=store' [answered]

asked 2014-06-13 13:30:56 +0300

nthn gravatar image

updated 2014-06-13 14:19:33 +0300

When adding a new repository using the Warehouse app, which causes a repository refresh, I get the following error: Status: repo-not-available Extra details: File '/repodata/repomd.xml' not found on medium 'https://store-repository.jolla.com/features/latest/xt9/armv7hl/?credentials=store'

I don't know what issues this causes, other than not getting a notification for system updates (in this case I did not receive a notification for the hotfix update even after manually refreshing, and had to update with pkcon update), although I'm not entirely sure if these two issues are related or not.

Does anyone know what would cause this and how to fix it?

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by nthn
close date 2014-06-13 14:11:39.686209

1 Answer

Sort by » oldest newest most voted
2

answered 2014-06-13 13:46:35 +0300

pycage gravatar image

"latest" in the URL looks wrong to me. When I issue "ssu lr" on my device, it shows me "https://store-repository.jolla.com/features/1.0.7.16/xt9/armv7hl/"

Maybe you have to call "ssu re 1.0.7.16" as root manually to fix it. You should not set the SSU release to "latest". Did you happen to enable the developer updates in the Developer Mode settings? This might have caused such a thing.

OTOH, the check for updates is independent from the repositories. The device just looks for a meta "app" on the store server, and compares it to your OS version. If you don't see the update, your Jolla account is not able to see the appropriate meta app, which means the update has not been enabled for you (maybe contacting Jolla Care will help in this case).

edit flag offensive delete publish link more

Comments

Yeah, the 'latest' part looked odd to me too. I don't think I've ever touched the 'developer updates' switch, although it might be the case that I accidentally turned it on and off again without noticing.

The update should be enabled because I don't think I could have updated to the opt-in hotfix update (by using pkcon update) otherwise.

I'll try your suggestion and see if it changes anything.

Btw, 'ssu status' says my device is not registered, is this normal?

nthn ( 2014-06-13 14:06:07 +0300 )edit

The problem is fixed, thank you! Although ssu status still says my device is not registered.

nthn ( 2014-06-13 14:11:13 +0300 )edit

I think you were able to update to the hotfix because you were on SSU release "latest". It's perfectly normal that your device is not registered to ssu, btw.

pycage ( 2014-06-13 14:50:29 +0300 )edit

Alright, thanks, that makes sense.

nthn ( 2014-06-13 15:13:27 +0300 )edit

Question tools

Follow
3 followers

Stats

Asked: 2014-06-13 13:30:56 +0300

Seen: 1,350 times

Last updated: Jun 13 '14