Ask / Submit
167

[1.0.7.16/18] Battery drain and heating up after Update 7 [not relevant]

asked 2014-06-13 22:38:48 +0300

updated 2015-01-29 08:02:22 +0300

simo gravatar image

Since I updated to the latest Firmware I've got massive Battery drain and the Jolla is getting very hot. Lighthouse says a Process called tracker-store is constantly using CPU with around 40-50%. Do anybody know this process or what to do? thanks!

Update: Today I had the same problem without tracker-store. My Jolla got very hot because different processes intensively used the CPU. Looking at Lighthouse told me, that the phone restarted by itself (uptime 10min) in my poket and tracker-store reappeared. Has anyone similar problems?

Update 2: Maybe the problem is linked to the new connman in my case, because after killing tracker-store in my case the phone also got hot in situation with poor wifi signal, where the phone always try to reconnect, I will figure it out with the old connman and report.

Update 3: still on 1.0.7.18, now it's appearing randomly - heating and massive battery drain - no special process but constant 50% CPU-Usage... :(

Update 4: maybe tracker-store is indexing the android apps rainisto (jolla) posted some kind of indexing after updating...

Update 5: got an answer from rainisto tracker-store is indexing your media files (may take up to 24h, if process is killed, will restart after restart)

Update 6: Tracker-store seemed to finish index, last time no need to kill the process - device still gets hot :(

Update 7: maybe related to mitakuuluu. Process doesn't appear in lighthouse but sometimes when CPU-Usage is high restarting mitakuuluu helps - who of you is using mitakuuluu?

Update 8: Developer is working on a fix in the futher mitakuuluu version: https://github.com/CODeRUS/mitakuuluu2/issues/141

Update 9: I observed my device for a couple of days. It's not only related to mitakuuluu gone wild. Battery drain is much higher than with paarlampi. Hunger Meter shows higher power consumption than before without using 4G...

Update 10: Maybe all lf us having problems should participate here: Battery Report for all Stages of Sailfish OS what do you think?

Update 11: 1.0.8.19 seems not to change anything in this case

Update 12: Mitakuuluu has been released in Version 0.8.1.-4, the release note describes different bugfixes and a probably fix for the 100% CPU-Usage-Problem. So let's have a try! I'm figuring it out since yesterday and I observed less battery drain through the night. I'm going to update the post in a few days with a final report, if the problems got fixed or if there other problems ;-)

Update 13: Sometimes I got the problems but under normal conditions no more problems. I have Hunger meter open all the time, in high power consumption phases I close mitakuuluu and reopen.

Final Update: Since massive problems with registration through mitakuuluu and getting banned for using mitakuuluu and Coderus stopping developing further, I switched to Android Whatsapp. Now my problems are gone. Now I have an average power consumption of 300mW, befor it was between 500-600mW. I don't know exactly if it is also related to updating to 1.1.0.39. Tracker-process don't use the CPU as much as before with the latest version.

edit retag flag offensive reopen delete

The question has been closed for the following reason "question is not relevant or outdated" by r0kk3rz
close date 2015-01-21 18:48:41.661528

Comments

noticed that when I use the camera or the internet then the area of the front camera is strongly heated.

sa.rasputin ( 2014-06-14 01:02:50 +0300 )edit
1

i noticed the same problem of sa.rasputin

Francesco ( 2014-06-14 10:15:52 +0300 )edit
1

should like to bring this issue developers.

sa.rasputin ( 2014-06-14 10:31:28 +0300 )edit

Did you allready have a look at lighthouse while device is heated like discribed? Maybe it is also a special process causing the heat with intensiv CPU-Usage...

drummer12 ( 2014-06-14 16:52:28 +0300 )edit
1

Had a not so massive drain yesterday with 1.0.7.16: around 5% in half an hour without usage. Normaly the battery level reduces less than 5% during full night (8 hours without usage but WLAN connected).

Had used the hotspot for some minutes in the morning. Don't know if this was the cause.

Stopped all open apps. Checked top in terminal for CPU consuming processes. Nothing special. Battery drain still happened. Than switched on and off flight mode and it seemed to help.

axaq ( 2014-06-14 17:23:23 +0300 )edit

15 Answers

Sort by » oldest newest most voted
0

answered 2014-08-29 13:23:59 +0300

michdeskunk gravatar image

It happen to me too, but phone being hot in top of the screen when I use browser, map app, stream and others app with internet connection, before 3 last update this don't happening

edit flag offensive delete publish link more
0

answered 2014-06-30 13:36:25 +0300

RobNas gravatar image

II think it has to do mainly with wifi. When I switch wifi off, there's much less battery drainage. I know there was a change in handling of the wifi, because of the many connection problems. I think that's causing processes to be very active (eating a lot of CPU). 3G is better, but also experiencing problems in my case.

edit flag offensive delete publish link more

Comments

No - that do not help on my case - My phone does not last whole working day (7h) of use.... Battery drain is huge and no fix seem not to available. This starts to look End Of Life product.

Jani68 ( 2014-07-08 15:00:15 +0300 )edit
0

answered 2014-06-30 01:06:29 +0300

redge73 gravatar image

updated 2014-06-30 01:07:36 +0300

i did catch the heating issue. discovered while i use cellular data connection 3G/4G start sailfish web browser and open: http://partyfoot.ch or scal.ch wait automatic download slide show and smartphone heating up quickly.

ver. 1.0.7.18 bug code website or sailfish web browser ?

edit flag offensive delete publish link more

Comments

No, I almost never use sailfish browser (dolphin browser from android is superior) and I'm also experiencing the heating problem/battery drain.

RobNas ( 2014-06-30 13:37:27 +0300 )edit
1

answered 2014-06-23 20:09:14 +0300

vicsjo gravatar image

I had same problem and some reboot problems also, even before update 6-7. But got worse after latest update. Some one whit this problem pleas try my solution, it can work for this problem also.

https://together.jolla.com/question/7144/jolla-randomly-shuts-down-10716/#post-id-36965

edit flag offensive delete publish link more
0

answered 2014-06-20 13:55:52 +0300

okourkoulos gravatar image

I have used an App called Crest. There I can see that some android features are working without me having started them. That's usually Skype-raider and org.Mozzila.firefox. Sometimes it's others like skydrive or soundcloud. I changed some settings there in those apps so they won't be always on, or continuously running. Then disconnect from data and/or WiFi. Restart Dalvik and open Crest again. Voila! They are away. You can now reconnect to wherever you want. I often use Dalvik restart when checking in Crest that something is running that I do not want it to. Sometimes it doesn't work and sometimes it comes back whenever I open any Android App. This usually helps me from battery drain, but yesterday there was something else that drained my battery and I couldn't find what it was. If it happens again, I will search more thoroughly.

edit flag offensive delete publish link more
0

answered 2014-06-19 18:18:48 +0300

sa.rasputin gravatar image

I write about my observations. 3G and android application. some applications cause heating of the upper part of the smartphone. what it is and what has caused it is not clear, but probably poor optimization android demon. probably something in the android applications there is still something very devours battery causing heating of the upper part of the smartphone. to test the 4G has not yet succeeded, but 4G should devour charge faster by 15 percent than 3G. before the last update basked smartphone, but the charge did not disappear so quickly. charge dropped in three hours from 100% to 20%. use the Internet and android applications without downloading anything. only social networks and news feeds. not all android application heated smartphone.

the next step is to check the GPS HERE, android GPS Osmand and android app 2GIS using 3G or 4G.

edit flag offensive delete publish link more
0

answered 2014-06-18 18:41:59 +0300

nthn gravatar image

For me I haven't experienced any heat problems lately, but the past days I have seen the battery empty itself very quickly. Just now I watched the battery drop from over 30% to less than 10% in about half an hour. Nothing out of the ordinary seemed to be going on with processes using up a lot of CPU or anything. This has happened on both 1.0.7.16 and 1.0.7.18. I have noticed that the Wi-Fi connection always seems to die after a while - it's still 'connected', but it shows no signal strength (the Wi-Fi symbol is completely transparent) and it's impossible to use any web services at all. Maybe the connection problems in the answers here and the battery problems here are related.

edit flag offensive delete publish link more

Comments

I got Problems with both version, so connman didn't change anything in this topic... in my case.

drummer12 ( 2014-06-18 19:19:22 +0300 )edit
0

answered 2014-06-17 17:47:52 +0300

Por gravatar image

updated 2014-06-17 22:29:40 +0300

I had same issues after the update. Yesterday battery level went from 100% to 4% in 10 hours (without 4G).

I made a backup and restored factory settings. Installed every update. so far battery level has dropped 20% in 6h with same ammount of usage than yesterday.

edit. I installed new update for android-support and battery-level has dropped 4% in last 3h.

edit flag offensive delete publish link more

Comments

1

I'm new user of Jolla phone. I came from good old N8 with round 4 days of akku, sometimes 7 days if i went to offline mode on night and didn't phone much. So I only know the update 1.0.7.xx and I found it embarrassing that the battery dropped a few % all 5-10 mins when wifi is on. I decided to use my umts internet connection to go online and it was "ok" for me, 30% battery drain on one day with some ideling but using the phone. Calls didn't seem to be the issue, but when wifi is switched on or I use terminal to fix wlan in the university it drained 50% of battery yesterday. Today at home I updated the android support and other apps I have from the shop. Now wifi is switched on since 2 hours, I have apps running as I always have and it just drained from 11% to 10%. Maybe the updates fixed something, hopefully this is it, so please share ur experience.

Btw: The tasks rild and tracker store are up and running but dont seem to use as much ram/cpu as u say

NuklearFart ( 2014-06-17 23:22:44 +0300 )edit

Still having issue... keep watching over phone as if it were a sick puppy, waiting to see if it has a temperature. Annoying. Last update seems to be the cause, but is there no solution?

dmelamet ( 2014-06-19 05:04:10 +0300 )edit

So far my problems has gone away.Battery level drops about 40% in 24h with my normal use (without 4G, wifi and 3G on).

Por ( 2014-06-19 15:08:17 +0300 )edit
1

Is there anybody else who was able to fix the issue by doing a complete reset? I would like to avoid delete all my data, apps, settings etc. on the phone to find out nothing changed ;-)

NFec ( 2014-06-19 23:23:16 +0300 )edit

Hej, I have been "off the grid" for more than 36 hours with normal usage. My charge indicator reads now 67%. Pre-conditions: a whole night in flight mode, last 1 hour on charger. The Jolla was fully charged when charger was disconnected. WLAN and mobile data were left on during active hours (during the night, the data connections were off) in 2G only mode. It definitely has something to do with flight mode. Before that it was like 35-40% in the evening when phone was 100% charged in the morning.

LVPVS ( 2014-06-20 14:47:32 +0300 )edit
1

answered 2014-06-17 09:37:33 +0300

JoneK gravatar image

I just voke up and after 8 hours off doing nothing on the phone, the battery was drained. Red light was blinking. It was 75% when I went to sleep.

No wlan on Prefered 3G on

I had trouble turning it on, as even after keeping it on the charger for awhile 1%, it didn't want to start. Another attempt 2% i got it to work, I then started hunger meter/crest/lighthouse and the drain was +200mAh my computer usb power supply normally keeps it around -1000mAh even if something is on.

There was a proses running called "rild" that was using cpu, now I can't be 100% sure it was draining power. But that is the one I saw. After Awhile it settled back to -1000mAh even with HM/Crest/LH on..

edit flag offensive delete publish link more

Comments

Did your device also get hot during drain?

drummer12 ( 2014-06-17 09:55:48 +0300 )edit

just for the record, not all is affected. My jolla works fine after update. I use no mobile internet though.

Macilaci457 ( 2014-06-17 12:23:14 +0300 )edit

yeah I think it's hardly connected to the new feature LTE and changed connection settings or so...

drummer12 ( 2014-06-17 15:23:37 +0300 )edit
1

i have the same Problem. my jolla gets very hot, sometimes i cant even touch the back (its not the accu, its behind camera). the capazity of my accu is very low: only 4 hours with normal usage. and my cellphone restarts several times.

contacts sometimes not working, maybe this is connected to the not working XMPP account

apps always need a third or fourth try to open.

anika ( 2014-06-18 00:04:26 +0300 )edit
7

answered 2014-06-17 08:46:51 +0300

bilgy_no1 gravatar image

updated 2014-06-17 08:48:49 +0300

Since the update I've noticed that the battery life is a little less than before: at the end of the day, the difference is maybe 20-30%.

Not really noticed the phone getting really hot yet.

But I do notice all kind of lag in using the phone. Sometimes the browser takes a really long time to load a page (on good connection), or it will freeze. I've also had the browser crash completely. The camera is also very slow, and zooming in and out in the gallery photos seems to be too much to handle at times. The user interface is also slow at times, not responding well to my input. And sometimes a whole bunch of active apps will suddenly disappear from the task switcher view.

Not sure it's related. Maybe I should start a new thread.

edit flag offensive delete publish link more

Comments

I think there must be some connection with the heating and draining with the browser lag. When the phone is functioning well; no battery drain or heating up also the browser works perfectly - even faster than ever before. And when something starts to cause the heating also the browser gets very laggy.

jaine ( 2014-07-08 14:38:47 +0300 )edit

I have noticed that sailfish-browser seems consistently to take CPU cycles noticeable more than Android Firefox when displaying same web page. For example, my regularly visited newsite hs.fi pages seem to consume cpu like 3..5 % vs < 1 % reported by crest.

I do have adblocking blacklist hosts file in place on Sailfish side and for Android I use Firefox Adblock extension which may or may not to be related.

Overall I do have noticed that sailfish-browser is often the process that consumes most cpu cycles. I do not use mitakuuluu or facebook services.

pata ( 2014-07-30 12:27:27 +0300 )edit

Question tools

Follow
21 followers

Stats

Asked: 2014-06-13 22:38:48 +0300

Seen: 7,447 times

Last updated: Dec 03 '14