Ask / Submit
0

Description of e-mail option in Settings > Accounts

asked 2014-06-14 12:44:55 +0200

NikosAlexandris gravatar image

updated 2014-06-14 13:31:04 +0200

An issue of minor importance: after the previous update (from 1.0.4.20, Ohijärvi to 1.0.5.16, Paarlampi), the description of the e-mail option under Settings > Accounts is: settings_accounts-email_provider. Upgrading to the latest version of SailfishOS 1.0.7.16, Saapunki, didn't fix this. A screenshot shown below. Can I quickly fix that myself?

image description

edit retag flag offensive close delete

Comments

maybe try updating to latest firmware saapunki (1.0.7.16)

drummer12 ( 2014-06-14 12:49:06 +0200 )edit

I already am in Saapunki. Apologies for not including this important bit of info.

NikosAlexandris ( 2014-06-14 13:32:06 +0200 )edit

Are you using patchmanager or openrepos like that? Looks like something got overwritten. I think finally factory reset will fix it, but that would be the last thing I want to do just to fix it ;)

drummer12 ( 2014-06-14 15:12:12 +0200 )edit

I do have apps installed via Warehouse. Not the patchmanager though. And a factory reset should be normally out of question, normally. Ideally, it would be, if I can simply edit the entry in question directly.

NikosAlexandris ( 2014-06-15 07:43:53 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-06-16 04:08:49 +0200

blam gravatar image

It looks like the translations in /usr/share/translations/settings-accounts-* are not available for this option. If you don't care to have a properly translated "Email" option, then you can just edit the "<name>" value in /usr/share/accounts/services/email.service.</name>

edit flag offensive delete publish link more

Comments

I edited the file email.service but it didn't work-out as expected -- even after rebooting. These /usr/share/translations/settings-accounts-* files don't look like regular ascii files. Are they binary? How can I create one for -el(==greek)?

NikosAlexandris ( 2014-06-20 00:05:12 +0200 )edit

Sorry, I referred to the wrong file -- you need to edit the <name> tag in /usr/share/accounts/providers/email.provider rather than services/email.service. </name>

.qm files are generated with the lupdate tool (http://qt-project.org/doc/qt-4.8/qdeclarativei18n.html). However, this won't work well in this case as without the complete sources, you won't be able to generate a complete set of translations.

blam ( 2014-06-20 06:13:29 +0200 )edit

That worked out. Thanks. I think it'll take me time which I currently don't have, to get up and running for a proper translation.

NikosAlexandris ( 2014-06-20 17:25:31 +0200 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-06-14 12:44:55 +0200

Seen: 121 times

Last updated: Jun 16 '14