Ask / Submit
22

[bug] phone disables mobile network

asked 2014-06-14 14:18:56 +0200

hardcodes.de gravatar image

updated 2014-06-14 14:21:26 +0200

4 days after the update to 1.0.6.17 the Jolla phone decided to deactivate (=grey out) the mobile network. There was no way to switch it back on, I got no error messages nor was I asked for a PIN code. The only way to get it back on was a reboot of the device.

So far I stayed with the old connman.

edit retag flag offensive close delete

Comments

did you try to activate flight mode and deactivate it after a couple of minutes? In my case normally it helps. Additional you can try subscribing to the hotfix beta-tester 1.0.7.17 i think, there is a new connman implemented which perhaps fix you're problem

drummer12 ( 2014-06-14 14:29:27 +0200 )edit
2

I had similar experience yesterday - mobile network disabled(greyed out). But in my case reboot was not fixing it. I noticed that AccessPointName was missing in /var/lib/ofono/provider_number/grps . After stopping ofono, manually editing the file adding APN and starting ofono again - mobile network is back.

zlatko ( 2014-06-14 14:34:33 +0200 )edit

@drummer12 I will try the flight mode next time. Yes, I know about the new conn man, but so far the old one worked fine. What has changed?

hardcodes.de ( 2014-06-14 14:40:36 +0200 )edit

I don't know, the developer team said, that they've changed nothing with the last update. In my case if mobile data is greyed i access the mobile data options, there it is possibel to turn on, an error "connection error" appear toggling a few times reactivates the mobile data ;)

I have to correct my post - the newest connman firmware is 1.0.7.18

Edit: I can recommend the hotfix - in my case connection is way more stable - didn't tested switching between wifi and mobile data

drummer12 ( 2014-06-14 15:07:26 +0200 )edit

I have the same problem. It looks like that when I boot my phone, after a while of 'on' time, the mobile connection crashes and deactivates. The option is grey (can't toggle the option) in the settings on top. When I go to internet settings I can set it to on, but upon a next visit its grey again. Flight mode doesn't fix it, nor does wifi on/of. No error messages visible by gui. I checked the network settings with my provider, and they're still correct.

Will-Do ( 2014-06-15 19:06:04 +0200 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2014-06-15 06:31:09 +0200

stevexley gravatar image

I had to disable 4G (set to 'prefer 3G') to get mobile data to work, have you tried that?. My carrier provides 4G but only on specific plans and sailfish didn't seem to fall back gracefully.

edit flag offensive delete publish link more

Comments

Thank you for the tip, I will try it the next time I run into this problem.

hardcodes.de ( 2014-06-15 12:26:44 +0200 )edit

"Prefer 3G" works very fine for mee, too.

nosy ( 2014-07-18 23:18:25 +0200 )edit

@stevexley Before you set the device to "Prefer 3G", was the problem only with mobile data or with device registering to network? To clarify: did your device register to 4G, meaning was there a "4G" on the device homescreen/lockcreen next to signal bars? Were you able to make voice calls?

tkenakka ( 2014-08-14 09:03:15 +0200 )edit
1

answered 2014-07-09 19:52:45 +0200

SaimenSays gravatar image

updated 2014-07-09 19:53:35 +0200

Same problem here for weeks. I thought my provider supports 4G, but after some hotline calls I was informed that they din't. They only support 7,2Mbit, which is only HSDPA, not 4G after all. After disabling 4G in settings menu, the mobile network is not disabled any time. Also it is not greyed out in settings anymore.

@Sailfish developers: Please implement the 3G fallback correctly. Phone needs to connect on lower speed autoomatically, if 4G is not supported by provider!

edit flag offensive delete publish link more

Comments

@SaimenSays Before you set the device to "Prefer 3G", was the problem only with mobile data or with device registering to network? To clarify: did your device register to 4G, meaning was there a "4G" on the device homescreen/lockcreen next to signal bars? Were you able to make voice calls?

tkenakka ( 2014-08-14 09:01:47 +0200 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2014-06-14 14:18:56 +0200

Seen: 917 times

Last updated: Jul 09 '14