Ask / Submit
12

Battery drain caused by poor network coverage

asked 2014-06-21 12:54:28 +0300

carmenfdezb gravatar image

updated 2014-06-21 20:00:10 +0300

Yaniel gravatar image

There is a critical bug on Jolla's firmware: With 2G, 3G, coverage changing constantly, the battery drains quickly, however with my old phone (Nokia N8), this didn't happen.

Edit: improved topic wording

edit retag flag offensive close delete

2 Answers

Sort by » oldest newest most voted
1

answered 2014-06-21 12:55:46 +0300

nthn gravatar image

Probably related: https://together.jolla.com/question/46747/1071618-battery-drain-and-heating-up-after-update7/

edit flag offensive delete publish link more

Comments

3

It happens with all firmwares, not only last version. This bug is related to the coverage, not with running process.

carmenfdezb ( 2014-06-21 13:15:34 +0300 )edit

You're right, my bad.

nthn ( 2014-06-22 03:43:00 +0300 )edit

Don't worry, thank you for trying to help me.

carmenfdezb ( 2014-06-22 11:33:13 +0300 )edit
0

answered 2014-06-23 11:33:33 +0300

vandersmash gravatar image

Having the GSM antenna ribbon cable changed by technical support service center has solved this problem in my case.

Use a decent non-Jolla device for comparison of coverage performance. While on same provider or using same SIM card, try loading an identical web page on both devices with prefer 3G enabled. If the other device does not display erratically behavior and stays stable on 3G while Jolla demonstrates switching between low 3G and slow loading 2G, describe the issue to Jolla tech support.

edit flag offensive delete publish link more

Comments

I've tested with Jolla, Nokia N8 and Nexus 5, using same provider and poor network coverage , and behavior is the same in all of them. I think this issue is not technical.

carmenfdezb ( 2014-06-23 12:45:22 +0300 )edit

I tested this also with Nokia....and it also drains battery fast, plus heats up. I think its not fault in Jolla

nuuni ( 2014-06-23 20:24:19 +0300 )edit

It doesn't happen with my Nokia N8, and other users in same conditions don't have this issue. So, I think there is a bug on Jolla's firmware

carmenfdezb ( 2014-06-25 09:19:47 +0300 )edit

However, when the coverage is good, the battery consumption is correct

carmenfdezb ( 2014-06-25 09:35:03 +0300 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-06-21 12:54:28 +0300

Seen: 566 times

Last updated: Jun 23 '14