We have moved to a new Sailfish OS Forum. Please start new discussions there.

Will you provide a french speaking qwertz keyboard ? [released]

asked 2014-06-24 18:56:06 +0300

lavariya gravatar image

qwertz is used in Germany and Switzerland, but 1/3 of Swiss country speaks french and use the qwertz keyboard. I have to use the french azerty keyboard to get the dictionnary but it would be fine to provide the qwertz keyboard with french dictionnary on a further release.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by nthn
close date 2019-08-12 18:05:01.264148


By the way, your post is somehow a duplicate of this one https://together.jolla.com/question/1189/keyboard-layouts-possible-to-provide-in-jolla-store/

Maximilian1st ( 2014-06-24 19:57:40 +0300 )edit

@lavariya thought by french that is azerty, by smartphone too....

cemoi71 ( 2015-08-05 10:36:21 +0300 )edit

5 Answers

Sort by » oldest newest most voted

answered 2014-06-25 01:36:10 +0300

Jordi gravatar image

updated 2019-08-12 13:31:38 +0300

You will find here the qwertz keyboard with french dictionnary :

https://openrepos.net/content/penguin/french-swiss-keyboard <= Not valid anymore, the new version is here :


edit flag offensive delete publish link more


THIS KEYBOARD IS NOT SUPPORTED ANYMORE No offense to Jordi, just a warning to new users

Maximilian1st ( 2019-08-12 12:49:34 +0300 )edit

Thanks @Maximilian1st for pointing out. I edited my answer with a new link.

Jordi ( 2019-08-12 13:24:17 +0300 )edit

answered 2015-08-04 17:48:28 +0300

Thoric gravatar image

updated 2015-08-04 17:49:17 +0300

As the previous answer is no more valid (the french qwertz keyboard is no more compatible with recent os version) I try the keyboard Qwertz which is using german language. Then I just change the "DE" to "FR" in the file /usr/share/maliit/plugins/com/jolla/layouts/custom-qwertz.conf. Reboot the device! and voilà! Choosing "Qwertz" as keyboard layout give me also access to the french dictionnary.

edit flag offensive delete publish link more



But the German keyboard doesn't seem suitable for French because of some special characters. You'd better to edit the AZERTY layout.

AliN ( 2015-08-05 14:39:01 +0300 )edit

No because in Switzerland we use a keyboard derived from the german one and not from the "AZERTY" french keyboard. In the french speaking part of Switzerland we need a french dictionnary. Then Azerty is useless and the qwertz is the good one. Plus all the accents that I need are provided by these qwertz keyboard. So definitively forget about Azerty for CH-fr keyboard. It looks ugly to us! ;-)

Thoric ( 2015-08-08 14:14:06 +0300 )edit

answered 2015-08-05 14:34:04 +0300

AliN gravatar image

updated 2015-09-27 20:57:44 +0300

Creating a layout isn't so hard, the language code (FR in this case) is enough for the dictionary to work. I can make it for you, as I did for some languages, but you need to enable the developer mode to start using it (i.e. to copy the QML to the file system; I don't know how to package it as RPM).

  1. First of all, download this zip file. Extract it and copy QML and CONF files to your /home (/home/nemo).

  2. From Settings app, enable Developer mode and then enable Remote connection and make a password.

  3. Then open Terminal and copy QML and CONF files to the file system using devel-su cp fr_ch.{conf,qml} /usr/share/maliit/plugins/com/jolla/layouts/. Enter the password you set for remote connection. The password characters will be invisible in Terminal.

  4. Restart maliit-server: systemctl --user restart maliit-server.service

Swiss French

edit flag offensive delete publish link more



For Sailfish 2.0 they change the place so you need

cp fr_qwertz.{qml,conf} /usr/share/maliit/plugins/com/jolla/layouts/

(note the /com/)

Also there's something wrong in the layout. you shouldn't have ç and M has to be next to N, at least with the sample done, I can hack them.

tigerfoot ( 2015-09-27 17:29:32 +0300 )edit

@tigerfoot, thanks for your feedback. That missing /com was my fault and I didn't know about ç. Let me correct it.

AliN ( 2015-09-27 20:39:58 +0300 )edit

answered 2014-06-24 19:56:32 +0300

Maximilian1st gravatar image

They probably will at some place in time but for now you will have to tinker a little bit to change the keyboard to fit your needs. I also use the Swiss keyboard so I know the problem. http://talk.maemo.org/showthread.php?t=91917

edit flag offensive delete publish link more

answered 2015-09-30 23:46:03 +0300

Jordi gravatar image

updated 2015-09-30 23:47:57 +0300

Based on the Dolphin Keyboard with color emoji made by saberaltria, I modified 3 files to have a working Swiss-French keyboard. Here are the instructions:

Install the Dolphin keyboard core, from Openrepos.

Install the Dolphin keyboard English + color emoji, from Openrepos.

Put these 3 files files in the folder /home/nemo/Documents/

And then, with the terminal, copy each of these 3 files in the appropriate folder using the 3 following commands:

cp /home/nemo/Documents/fr+.qml /usr/share/maliit/plugins/com/jolla/layouts/fr+.qml

cp /home/nemo/Documents/fr+.conf /usr/share/maliit/plugins/com/jolla/layouts/fr+.conf

cp /home/nemo/Documents/Xt9Handler.qml /usr/share/maliit/plugins/com/jolla/layouts/Xt9Handler.qml

Start the app Dolphin core and press Restart service.

That's it!

edit flag offensive delete publish link more

Question tools



Asked: 2014-06-24 18:56:06 +0300

Seen: 765 times

Last updated: Aug 12 '19