Ask / Submit
18

No roaming

asked 2014-06-24 23:04:04 +0300

unruly gravatar image

updated 2018-07-11 10:16:49 +0300

jiit gravatar image

Hi,

I'm in the UK and my provider is 3. I spent last weekend in Brussels and, despite having international roaming activated, could not get a phone signal. I tried rebooting the phone, trying in different areas of the city, prefering 3g instead of 4g and manually scanning for networks. Nothing worked, when manually scanning no networks were found. I confirmed with 3 when I got home that international roaming was active. Has anyone had any similar problems or successes?

edit retag flag offensive close delete

Comments

1

can't offer anything other than roaming worked for me from the UK (vodafone) to Italy

steph ( 2014-06-25 14:12:29 +0300 )edit
1

My Jolla roamed fine in Brussels a few weeks ago - but I'm on Vodafone Uk rather than 3

strongm ( 2014-06-25 14:44:52 +0300 )edit
4

Sorry to hear that. Typically operator configures roaming settings to user's sim card and those specify what you can connect to automatically/manually. By the way, if you happen to be there again you may want to try manual network search while having Internet connection disabled from settings. Typically mobile devices disable data connection during manual network scan due to modem restrictions.

tkenakka ( 2014-06-25 16:14:23 +0300 )edit

I've experienced the same problem (with Three UK and roaming to Brussels and Ireland), except I could get a phone signal to make calls, but no data. I also tried lots of combinations of ways to connect, and Three confirmed there was nothing at their end that should have prevented it. There's a thread on JollaTides about the same issue that may be worth tracking: http://www.jollatides.com/forums/discussion/184/roaming

flypig ( 2014-06-27 14:01:41 +0300 )edit
2

Hello, I am a happy user (my happiness is decreasing due to some bad experiences) of a Jolla device. I use in Spain the company http://www.ono.es/ and it works perfectly, voice and data network. Nowadays I am in the Republic of Ireland and my Jolla is not detecting any signal, I tried Prefer 4G, Prefer 3G, Only 2G, combining with and without WiFi signal as the link from the above comment says, but it doesn't work. Last summer with my Nokia N8 I had no problems to work with the same contract that I have nowadays in http://www.ono.es/. I am afraid to become a disappointed user of a Jolla device =(

vicentpavel ( 2014-07-27 21:44:29 +0300 )edit

4 Answers

Sort by » oldest newest most voted
11

answered 2018-02-05 10:47:40 +0300

inta gravatar image

Seems still to be a problem, but maybe not with all countries.

I'm from germany and the last trip to spain everything worked perfectly. Now I visited italy for a few days and after deactivating flight mode at the airport in rome I did not get a mobile network connection. It's not just about data, phone calls do not work either, the mobile network icon in the events view pull down menu is greyed out. Manual search does not work, multiple reboots did not help either.

I thought it is a serious problem with my phone, but back in germany I deactivated the flight mode and everthing was working like before.

I'm using SailfishX and my wife has the same carrier and no problems with her iPhone, so it's not just the carriers fault. Must be some combination of Sailfish and carrier that does not work together.

edit flag offensive delete publish link more

Comments

4

The upcoming 2.1.4 release will make roaming work better. It is still impossible to say if it works with all combinations, though.

jovirkku ( 2018-02-07 11:53:19 +0300 )edit
2

After update, roaming still does not work for me on Sailfish X (Jolla 1 was always fine even if now it seems to loose randomly the network connection and needs to be restarted). My carrier is DNA in Finland and roaming did not work in Germany before the update and in Switzerland after the update (to 2.1.4).

arno784 ( 2018-04-03 12:00:16 +0300 )edit
5

answered 2014-08-14 08:55:50 +0300

tkenakka gravatar image

updated 2014-08-14 11:47:46 +0300

@vicentpavel If you get the "Oops..." error message on manual network selection, I suggest you disable mobile data from settings and try manual scanning again. Typically mobile devices disable data connection during manual network scan due to modem restrictions, however Jolla does not do that currently automatically, which may result in no found networks. To clarify: this workaround should be needed only when using manual network selection.

UPDATE: I happened to test manual network selection using a roaming prepaid card, there was first the "Oops" error message but regardless of that after a minute or two the registration did complete (operator name on lockscreen) and voice/sms were ok. So if this helps at all: in roaming manual network selection I recommend waiting a while after the selection regardless of the "Oops". Miracles do happen, it seems :)

edit flag offensive delete publish link more

Comments

Mobile data was disabled.

unruly ( 2014-08-14 11:24:44 +0300 )edit

For your convenience, update 1.0.8 introduces improvements regarding mobile data functionality (https://together.jolla.com/question/50175/release-notes-software-version-10819-tahkalampi/).

tkenakka ( 2014-09-11 14:34:59 +0300 )edit

This question is about voice calls, not data functionality.

unruly ( 2014-09-11 16:35:05 +0300 )edit

@unruly: Yes, just saying so you can keep an yet in case it helps at all.

@unruly:

@vincentpavel: If you are able to reproduce your problems about network registration, please give a word if you are eager to do some log capturing the next time. It would require enabling developer mode and using terminal via Jolla terminal app (or ssh over USB) according to steps that I could copy you. The steps should not damage your device, but I do have to state as a disclaimer that all such debugging would be done on your own responsibility. I hope you understand :)

tkenakka ( 2014-09-15 12:44:07 +0300 )edit
5

answered 2014-09-09 15:02:19 +0300

stezz gravatar image

Thanks for the report, tracking this internally now. In case you have more logs or scenarios please add this the post.

edit flag offensive delete publish link more

Comments

2

Any progress on this issue?

inta ( 2018-02-05 10:52:48 +0300 )edit
2

@inta - you'll get no response from @stezz, he is no longer with Jolla. Last seen on here Oct 21st 2015.

Edz ( 2018-02-05 11:47:22 +0300 )edit
2

I already thought of that, but hoped Jolla would track the postings of former employees. Nevertheless thanks for the hint.

inta ( 2018-02-06 08:59:33 +0300 )edit
2

answered 2018-07-10 13:04:31 +0300

Robomike gravatar image

To bring this up as an answer: I'm currently on a short trip to US and my XperiaX with SailfishX 2.2.0.29 connects to nothing with my German O2-sim. The device is able to see 6 different network services here in Newnan, GA, but does not connect to none of them. Roaming worked fine before in NL, B, CZ.... but here's no phone call possible.

My old Jolla 1 (took it with me as backup, don't ask me why having trust issues :( ) is still running on 2.1.0.1 and connects flawlessly to the TMobile-network, but due to its technical restrictions there are less services available.

It there's anything I can do or any logs I can collect please tell me. Disappointed as hell.

edit flag offensive delete publish link more

Comments

I had a similar problem when in Spain recently. My carrier is iD but piggy backs on to Three in the UK. According to iD I should have changed the data access point to iD/id (case significant) so can I suggest you compare the two phones? That's Settings -> Mobile Network -> Data Access Point.

Can you let us know if that fixed the issue, or no change as we would all like to know a resolution.

toner_cloud ( 2018-07-10 19:29:14 +0300 )edit
1

I did play around with these settings with no success. I don't think that's a possible solution, because I don't know to which network the phone wants to connect as a prediction. It's not only no mobile data, it's no connection /refused connection at all. I can't make a call. It's now anything else but a phone, because I can neither make phonecalls nor receive/send SMS.

Most networks here seem to be 4G. So my old Jolla 1 can't see them. There's only the T-Mobile left with 3G, the Jolla sees and connects. The Xperia sees it too when I disable 4G, but doesn't connect. 2G is not available. When 4G is activated, the Sony sees up to 8 (!) different services around, in the manual select menu some of them are greyed out (why?), but not always. Trying to select one of the others will throw an error notification a minute later or so.

I didn't test if an emergency call is possible or not. Not wiilling to explain a cop what I'm doing there.

Robomike ( 2018-07-11 04:24:30 +0300 )edit
Login/Signup to Answer

Question tools

Follow
9 followers

Stats

Asked: 2014-06-24 23:04:04 +0300

Seen: 3,837 times

Last updated: Jul 11