Ask / Submit
5

BUG: system_server memory leak [duplicate]

asked 2014-06-25 19:14:19 +0200

Trizt gravatar image

updated 2014-12-11 12:13:15 +0200

simo gravatar image

I have been thinking my Jolla been consuming a lot of CPU power, but today I notices the system_server must be leaking a lot, rebooted the phone around 11 CET as it felt slow. Now around 18 CET the process has taken 41% of the combined RAM/SWAP and a lot of things are pushed out into the swap.

I don't run any more applications than I did before the latest Dalvik update, but my phone has become a lot slower and required to reboot it quite often, as just restarting the Alien Dalvik service will not free memory from swap and the old trick "swapoff -a && swapon -a" don't work as swapon do not work on the Jolla.

SailfishOS 1.0.7.16 Alien Dalvik 0.11.5

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by nthn
close date 2017-05-11 16:45:21.726777

1 Answer

Sort by » oldest newest most voted
2

answered 2014-12-11 12:25:14 +0200

Philippe De Swert gravatar image

For swapon to work you need to tell it the partition which is mmcblk01p24 afaik

so : swapon /dev/mmcblk01p24

For the bug, this has been reported here before : https://together.jolla.com/question/46869/system_server-eating-up-all-memory/

edit flag offensive delete publish link more

Comments

I guess that is a shortcoming of systemd that you have to give the path to the swap partition.

Trizt ( 2015-05-06 08:42:47 +0200 )edit

Question tools

Follow
2 followers

Stats

Asked: 2014-06-25 19:14:19 +0200

Seen: 600 times

Last updated: Dec 11 '14