Ask / Submit
10

always roaming in home network neccessary? (high risk on costs)

asked 2014-07-14 09:42:27 +0300

renegade22 gravatar image

updated 2014-12-25 15:03:05 +0300

My "home" network yesss is a virtual network of the a1 network. So for Internet connection, roaming should be activated.

My Problem: I live near the border, if my phone switches to a provider from germany, it will get really expensive for me and I won't even notice until its to late.

Two ways to solve this Problem is possible:

  • create a list of virtual networks for each provider in the world to determine if you actually are roaming or you are on your home network
  • let the user choose, what network his home network should be (possibly in Settings->System->Mobile network->Select home networks), multiple home networks should be possible
edit retag flag offensive close delete

Comments

2

I have exactly the same problem with my provider BOB which is also a virtual network of A1 Telekom Austria. Sadly nothing changed despite i have already made a feature request in february --> https://together.jolla.com/question/26151/feature-request-differ-between-national-and-international-data-roaming/

Stefan P ( 2014-07-14 09:59:10 +0300 )edit
1

Is there any information on this bug? One could simply make an option to manually select the home network, if otherwise Jolla would be roaming.

renegade22 ( 2014-12-24 14:36:36 +0300 )edit

I'd never come across this problem despite using several SIMs all over Europe, and wondered what feature of these MVNOs caused it. I found this explanation. https://www.xda-developers.com/android-p-national-roaming-toggle/

DaveRo ( 2019-03-29 23:54:11 +0300 )edit

4 Answers

Sort by » oldest newest most voted
2

answered 2019-03-29 09:22:55 +0300

Andrea777 gravatar image

i have a similar problem. My yesss card is virtual provider in the a1 network. So i have to enable roaming. Otherwise it doesn't work. On travelling to Hungary, i always have to disable roaming manually and also enable manually on travelling back to Austria. So my suggestion: please add function "roaming on but only in a defined network" Suggestion: make a checkbox in the sim card options: "sim is virtual provider" , if yes, then a possibility to define the home network for it, e.g. A1 for the yesss card.

edit flag offensive delete publish link more

Comments

Yesss should work automatically without roaming. It's defined in mobile-broadband-provider-info.

Are these settings correct? If not you should make a pull request.

michfu ( 2019-03-29 10:11:51 +0300 )edit
1

First of all, jolla schould get rid of the basic roaming issues, which make the phone unusable.

Raymaen ( 2019-03-30 09:43:54 +0300 )edit

According to https://cellidfinder.com/mcc-mnc yess (mcc 232, mnc 12) is on Orange. [Bob (232, 11) is on A1 Telecom.] What mcc/mnc are in your IMSI?

DaveRo ( 2019-03-30 13:20:47 +0300 )edit

How can i find out the IMSI of the SIM card? I have now installed the App "SIM Scout", and it displays:

GPS Pos., Time Date...

SIM1 Status: roaming Name: vodafone HU Mode: auto Strength: 93 Technology: lte MCC: 216 MNC: 70 LAC: 0 CellID: 0 Changes: 1

I think this is the Info about the Network I am now roaming in and not the data from the SIM card. I surely know that Yesss is currently subprovider in the A1 network, because it works in the mountains and countryside of Austria, where only A1 and no other network is receiveable. Yesss was sold from Orange Austria to A1 in July 2013.

Andrea777 ( 2019-03-30 20:25:17 +0300 )edit

How to get IMSI? Good question. I thought it was written on the SIM - but I looked at several and it was the ICCID (starts 89). So you need an OS that will display it (Symbian doesn't seem to FWIW) or an app.

DaveRo ( 2019-03-30 22:16:01 +0300 )edit
2

answered 2019-03-31 10:50:36 +0300

DaveRo gravatar image

updated 2019-03-31 10:51:46 +0300

It would be interesting to know whether the IMSI has a different MCC/MNC from your home network, as that piece about Android I linked to says, but if true what could you do about it?

Presumably your home network's HLR contains these anamalous IMSIs. If this is a valid situation in GSM, which seems likely since it works and other networks on which you roam can locate your home operator, then the fault does lie with Jolla - its definition of, or test for, roaming is too narrow.

What's the correct test? That 'national roaming' proposal in the Android link seems to assume that the anamalous IMSI will have the 'correct' MCC. Is that true? Without knowing why this happens we don't know. I can see 'country' becoming less important in EU mobile infrastructure. OTOH 'allow in-country roaming' might be useful in other circumstances, where an operator has local access agreements, and might (or might not) solve this problem.

Would an alternative, albeit less user-friendly alternative, be to simply specify in settings the home network's MCC/MNC in the case where it's different to the IMSI? Would that be patchable?

Maybe this problem originates from the sale from Orange to A1. Maybe from an in-country access agreement that's become permanent. Maybe not all Yesss SIMs have this 'feature', You could ask them.

Will make this an answer for techical comments.

(I'm in the UK and sometimes have a UK 3 SIM in one slot and a German Lidl/FONIC SIM roaming on O2 in the other.)

edit flag offensive delete publish link more

Comments

2

Now i am in Austria and can give the information that SIM Scout shows when logged in in the A1 network with yesss SIM card:

Status: roaming Name: yesss! Mode: auto Strength: 58 Technology: lte MCC: 232 NNC: 01 LAC: 0 Cellid: 0 Changes: 1

Date + Time: the right... Lat.+lon: wrong, it shows the values from the place, GPS was on last time.

How can I read out the IMSI number stored on the SIM card with the Sony Xperia XA2?

Andrea777 ( 2019-04-04 17:10:31 +0300 )edit
1

232/01 is A1 Telecom Austria.
Several sites say yesss is 232/12

I'm afraid I've no idea how to read the IMSI from the SIM.

DaveRo ( 2019-04-04 20:06:23 +0300 )edit

Why is it important to know the IMSI number? The answer talks about if the "IMSI has a different MCC/MNC". I can btw confirm the values provided by @Andrea777 (Jolla 1, same problem, same provider)

Sebix ( 2019-04-04 21:18:52 +0300 )edit

@Sebix Because the sda-developers link I posted up-thread suggests that this problem arises because "Some MVNOs do not have the same IMSI as their parent carrier. Android, therefore, identifies the MVNO as a separate network, and the different IMSIs make it seem to Android that the device is roaming even when it isn’t."

Q1 - is this true in this case?
Q2 - is so, what could jolla do about it to solve the problem?
Q3 - if not what causes it?

DaveRo ( 2019-04-04 21:50:30 +0300 )edit

Q1, I don't know, but there are several indicators suggesting it. I found this thread on Reddit: https://www.reddit.com/r/Android/comments/22c82e/roaming_at_home_on_android_why_some_networks_need/

[...]Read the list of "EHPLMN" (Equivalent Home Public Land Mobile Network) from the SIM card and consider them equal to the home network. [...]

Is such a list used by Sailfish?

The other option is to differentiate between national and international roaming, that is helpful for other cases too.

Sebix ( 2019-04-06 13:17:20 +0300 )edit
0

answered 2014-12-25 19:27:32 +0300

DiosDelRayo gravatar image

updated 2014-12-25 20:41:47 +0300

I don't live in Austria and also I don't pay for roaming outside the country at all. But would it not be a solution to allow data roaming in settings and pick the provider manually to stick on that provider? I can select here in France (if I want) also which provider I use for roaming (it's a german contract). I made it sometimes because the 3G coverage is different in a lot of regions and I don't know why but in automatic mode it looks like it stick to the last provider in roaming instead of choose the best signal.

edit flag offensive delete publish link more

Comments

2

not really, if I am in the car and driving into Germany, I would have to switch to automatic search again. If I don't do this, one can not call me. It's more a workaround but sadly no true solution.

renegade22 ( 2014-12-26 11:45:24 +0300 )edit

This can't be the all time solution. What should people do which live near the border (and of course travel along there), where the phone sometimes has higher reception from the home network and in the next minute a network from the neighbour country provides better reception.

Stefan P ( 2014-12-27 01:23:39 +0300 )edit
0

answered 2019-03-29 21:35:20 +0300

Andrea777 gravatar image

In the moment i am in Hungary and try out the suggestions. I did disable "choose network automatically", choosed manually "vodafone HU" and then it was no more possible to switch back (enable again) "choose network automatically". after 5-7 min. it switches back to "choose network automatically" itself.

@michfu: the settings for yesss in the link you sent me and in the file in the phone are the same, no difference.

Yesss writes on their Homepage:

Um mit Ihrer yesss! SIM-Karte mobil im Internet surfen zu können, sind folgende Einstellungen auf Ihrem Smartphone, Handy oder Tablet nötig:

Profilname: WebAPN
APN: webapn.at
Benutzername: (nichts eintragen)
Passwort: (nichts eintragen)

......

Tipp für Android-Benutzer: Eventuell ist es nötig, dass Sie auf Ihrem Gerät auch noch die Einstellung "Data Roaming" aktivieren, um das mobile Internet nutzen zu können.

--> that means: Tip for android-user: maybe it is necessary to enable roaming to use the mobile internet...

the same problem again...

edit flag offensive delete publish link more

Comments

which device and SFOS version?

bomo ( 2019-03-29 23:05:44 +0300 )edit
1

When I shared this issue with Jolla last year, they told me to talk to the provider. Unfortunately I did not have the time or desire to do that, but it is annoying. I am with BOB and this issue persists since forever. It was there when I flashed with 2.0 and now upgraded to 3.0.2.8 still the same.

deloptes ( 2019-03-30 00:14:01 +0300 )edit

@deloptes, which device?

bomo ( 2019-03-30 00:15:27 +0300 )edit

Sony Xperia XA2, Sailfish OS 3.0, Build 3.0.2.8 Oulanka, Device adaption 0.0.7.12.

What is a SFOS version? Where can i find this information?

Andrea777 ( 2019-03-30 10:31:52 +0300 )edit

You already just gave the right information, it's the Build number. SFOS means Sailfish Operating System. You should convert your answer to a comment to your previous answer if it's possible.

Pohli ( 2019-03-30 12:09:03 +0300 )edit
Login/Signup to Answer

Question tools

Follow
6 followers

Stats

Asked: 2014-07-14 09:42:27 +0300

Seen: 592 times

Last updated: Mar 31