We have moved to a new Sailfish OS Forum. Please start new discussions there.
38

[bug] 1.0.8.19, brightness at 100% on waking up [released]

asked 2014-07-14 22:17:47 +0200

Moth gravatar image

updated 2014-12-23 11:31:54 +0200

The screen brightness is shocking high on waking up the phone after standby... or is it a feature? :)

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by Moth
close date 2014-12-23 11:31:33.767095

Comments

3

Its the new "blind the user" feature :P

ApB ( 2014-07-14 22:20:33 +0200 )edit
3

UGH! This is an anti-feature. Bed-time browsing (you're doing it too, admit it!). Screen times-out when reading a longer piece (the indicator led is quire dim now, but that's ok). Double-tap to wake up and continue. FLASH. I sure hope we're not stuck with this for two months!

Fuzzillogic ( 2014-07-14 22:55:29 +0200 )edit
2

As a workaround you could disable auto-brightness and reduce brightness to a handy level. Or wear your sunglasses for bed-time browsing, hehe... 8-/

Moth ( 2014-07-14 23:01:23 +0200 )edit
2

Oh yeah just realised it's quite bright on waking up the phone :S

Mariusmssj ( 2014-07-15 00:29:03 +0200 )edit
2

Actually you can leave auto-brightness on but lower the brightness level, this will also remove the bright "waking up" screen.

sunkan ( 2014-07-15 09:25:24 +0200 )edit

1 Answer

Sort by » oldest newest most voted
8

answered 2014-07-15 12:17:32 +0200

spiiroin gravatar image

There were changes to ambient light sensor enable/disable logic due to lpm display states being in use again. Most likely there is a hiccup that causes used-if-real-als-data-is-not-available -value to be used during display wakeup -> is barely noticeable in normal lightning, but goes through way too bright state in darkness.

An internal bug ticket has been created for this.

edit flag offensive delete publish link more

Comments

I am now using Jolla for the first time in months and I updated to Tahkalampi. I have noticed that the auto brightness is doing weird things (I keep brightness setting at middle), screen darkens for no apparent reason and then when you turn it off and on, it's bright again.

The auto brightness used to be perfect, I really liked it.

hana ( 2014-07-27 01:37:31 +0200 )edit

Ok, I guess the auto brightness levels have been changed in some update. Now I have to put it to maximum brightness so that it will not be too dark indoors. So it's on the limit of being usable for me, I used to be able to keep the setting at middle.

And yes, the high brightness after waking up is annoying now that I have adjusted the setting, and I would also disagree that it's "barely noticeable" in normal lightning.

hana ( 2014-07-27 04:50:55 +0200 )edit
5

Turns out that during unblanking missing sensor data was misinterpreted as sensor not in use: the initial brightness was as if "automatic" was not chosen -> in darkness it is likely that display is initially too bright; in bright conditions too dim. Then, after fresh data is received from the sensor, the display returns to expected brightness level. If both manual and automatic methods yield about the same brightness level -> the glitch is not so visible.

Fix will be included in the next update.

spiiroin ( 2014-07-31 14:02:47 +0200 )edit

Question tools

Follow
6 followers

Stats

Asked: 2014-07-14 22:17:47 +0200

Seen: 553 times

Last updated: Dec 23 '14