Ask / Submit
21

Ability to disable email sync outside of working hours

asked 2014-07-15 23:08:35 +0200

eetu gravatar image

updated 2014-07-18 16:00:18 +0200

jiit gravatar image

I'm loving the ability set the email sync interval separately for different email accounts enabled by Tahkalampi. However, there is a quite obvious option missing from the feature: there doesn't seem to any way to disable the synchronization outside the "busy" hours altogether.

The user related user story:

  • In order to rest properly
  • As an employee
  • I want to use my phone during the weekend/evening without seeing notifications for work-related emails
edit retag flag offensive close delete

Comments

Yes, the options are there for Exchange-based accounts (so I can do the above with my work email), but the options for imap/pop mail are subtly different (most importantly missing "manually" as a sync type)

vitaminj ( 2014-07-16 01:07:34 +0200 )edit

Can't belive that no one else need this feature. Until my NFC Project isn't finished I need to cut off all my connections and sounds (by ambience) every night and enable them in the morning.

Now we've got the IMAP_IDLE option, which is superb so an "manually" as Sync type in Custom would be great. Also some more time values

imunar ( 2015-04-29 09:14:21 +0200 )edit

It would be nice to have this in situations app too!

SaimenSays ( 2016-10-12 12:07:09 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2014-07-16 00:59:42 +0200

juiceme gravatar image

See my solution; https://together.jolla.com/question/16434/cronjob-on-sailfish/#post-id-49662

edit flag offensive delete publish link more
0

answered 2016-10-12 08:19:27 +0200

Niko gravatar image

Just popping up old topic. I'm having JollaC running 2.0.4.13 and I have configured two IMAP accounts with off-peak interval set to "manually". However, the emails still seem to get refreshed automatically during off-peak time.

Anybody else facing this issue still or have I missed something in the configuration?

edit flag offensive delete publish link more

Comments

I didn't encounter that. How are your peak intervals configured? Did you check that (presumably yes, but just in case ;-) )?

naytsyrhc ( 2016-10-12 11:37:59 +0200 )edit

Would not be the first time I have screwed something myself... My configuration in the account is:

Sync emails: Custom

Peak interval: Every 30 minutes

Off-peak interval: Manually

Peak time starts: 08:00

Peak time ends: 21:00

Peak days: (all days checked)

Niko ( 2016-10-12 12:10:33 +0200 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2014-07-15 23:08:35 +0200

Seen: 525 times

Last updated: Oct 12 '16