Ask / Submit
10

Cannot open email server settings after misconfiguring SMTP server [released]

asked 2014-07-29 13:04:53 +0300

Jonni gravatar image

I did a factory reset to my device, upgraded to the latest Sailfish release and after that created a new "general email" account. This was the first account I added to the device after the Jolla account. I had something wrong with my outgoing (SMTP) server settings so I ignored that and created the account anyway. The account creation wizard said something like "you won't be able to send emails, but receiving will work".

When I go to Settings -> Accounts, select the created general email account and from the pulley I choose "Server settings", nothing happens in the ui (only the pulley menu dissapears).

I have developer mode enabled and in the journal I can see the following message:

"heinä 28 17:07:54 Jolla [2674]: [W] unknown:108 - file:///usr/share/accounts/ui/email-settings.qml:108: Error: Cannot assign to non-existent property "hideOutgoing""

I had to delete the account and create it again (with working SMTP settings) to be able to access the "Server settings" of the email account.

Also the only error in the SMTP server settings was that I didn't have the "Allow untrusted certificates" checked in the server settings. The certificate the server uses for STARTLS is signed by StartCom and works fine in the browser and when used in incoming mail (no prompts for allowing an security exception). For some reason doesn't seem to work in STMP. But that's is another issue.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by VDVsx
close date 2014-12-18 17:42:48.948374

Comments

1

Thanks for the report I can reproduce it, you should have been able to see your incoming server settings in this case, but is intentional that outgoing(SMTP) setting won't be available in this case, since you intentionally created an account without SMTP.

VDVsx ( 2014-08-05 14:39:59 +0300 )edit

Any news on this? What is the proper way to add an account with receiving-only functionality? Because when I set up the account, i cannot leave the SMTP server field blank... and when I continue with an unreachable server, I get a message that the account will be used as receiving only. But then I cannot access the server settings of the account, e.g. to change the password!

chrila ( 2014-09-03 16:39:41 +0300 )edit

The accounts details can be found in /home/nemo/.config/libaccounts-glib/accounts.db but having taken a look at fixing it by editing this file, I concluded that perhaps it would be best to delete the account and try again! Seems odd that this sort of thing cannot be edited.

rolandw ( 2014-11-04 17:57:57 +0300 )edit
1

@chrila - That's fixed in update9, you can add something to smtp, ignore the error and later settings for incoming will be accessible.

@rolandw - Setting should be edited via the UI (or in last resource command line tool: ag-tool), if you mess with the database directly you might break the entire account. Are you having the cannot access settings issue ?

VDVsx ( 2014-11-05 09:14:21 +0300 )edit

@VDVsx - Indeed, if I select "Server Settings" from the pull-down menu, nothing happens... This is running Mail 0.0.86 on Sailfish 1.0.8.21. I'll try ag-tool! Is there an ETA for update9?

rolandw ( 2014-11-05 09:35:26 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-12-18 17:42:39 +0300

VDVsx gravatar image

Fixed in 1.1.1.26, Vaarainjärvi, if you still have issues please comment here.

edit flag offensive delete publish link more

Comments

Why is it intentional that you cannot add/change SMTP settings if setting them failed when creating the account? When using wrong SMTP settings on account creation, it is not my intention to disable SMTP, but to correct them later.

I have the issue that for no obvious reason my mail account's SMTP settings won't work in Jolla, so I would have liked to change them after saving the account in order to test which settings will work. Creating a new account each time just to test different settings is pretty tedious.

julini ( 2014-12-21 15:27:19 +0300 )edit

You can go back and change the settings when creating a new account and SMTP settings fail, no need to keep creating new accounts for this case.

VDVsx ( 2015-01-05 11:41:45 +0300 )edit

For some reason the outgoing settings refuse to work. I try the exact ones that work in Thunderbird, but no go. Also if the outgoing server settings fail, they are hidden in the "server settings" pull down menu by default, so trying again is overly complicated requiring editing of /usr/share/accounts/ui/EmailSettingsDisplay.qml. Or deleting the account.

twaapo ( 2015-01-26 00:37:37 +0300 )edit

I have the same issue. I use the same SMTP settings as on my laptop, but the authentication fails, which means I have to either go back and "correct" them, or skip it and have no outgoing capability on that account. It's a work account so I need outgoing, and getting server logs will be an problematic.

I can't see how to debug it if I can't save non-working settings...? It would be nice to be able to go back and add an outgoing server to an existing account.

EDIT: I found a workaround. I created the account with one of my personal SMTP servers so it accepted it, then went back an edited it.

skanky ( 2015-02-08 00:47:49 +0300 )edit

@skanky - Humm, so that SMTP does not work during setup and then later if you edit it works ? i.e you can send emails from that account ?

VDVsx ( 2015-02-09 10:09:30 +0300 )edit

Question tools

Follow
4 followers

Stats

Asked: 2014-07-29 13:04:53 +0300

Seen: 443 times

Last updated: Dec 18 '14