Ask / Submit
4

Thumbnails appear in gallery even after deletion

asked 2014-07-29 15:26:21 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-07-30 11:05:18 +0300

jiit gravatar image

I have deleted some of the photos in my gallery. Even after deleting, their thumbnails still appear in the photos section in the gallery. When I click on the thumbnail, the images don't appear. So, the images are deleted but not the thumbnail. Can anyone please tel me where the thumbnails are being stored in Jolla?

edit retag flag offensive close delete

Comments

3 Answers

Sort by » oldest newest most voted
2

answered 2014-07-29 15:38:05 +0300

Moth gravatar image

updated 2014-07-29 16:05:50 +0300

Your question is very similiar to this one. You'll find the answer there, i'm sure... :)

edit flag offensive delete publish link more

Comments

1

A refresh tracker app i think is needed. At least until jolla fixes the tracker. For the non power/dev-mode users.

ApB ( 2014-07-29 17:00:41 +0300 )edit

@ApB Yes. Or just an option in the settings: "Force reload of media files"

Moth ( 2014-07-29 18:06:37 +0300 )edit

@Moth - Thanks Moth. That post took me very near to the solution. But I am not sure how to refresh the tracker control.

VenomousBane ( 2014-07-29 19:24:05 +0300 )edit

Or is there something like just deleting entire photos in the gallery?

VenomousBane ( 2014-07-29 19:24:33 +0300 )edit

@VenomousBane the command you've to enter in terminal is:

tracker-control -es

This means: reset tracker-db and restart miners to get your collection re-created.

Moth ( 2014-07-29 19:35:26 +0300 )edit
2

answered 2015-03-05 17:48:48 +0300

Dubravko gravatar image

updated 2015-03-05 19:17:50 +0300

Come on, this is absolutely humiliating! Even the cheapest dumbphones are able to properly display gallery content without executing any terminal commands. And the problem still persists after the last update to SailfishOS version 1.1.2.16

edit flag offensive delete publish link more

Comments

there is an option to clear tracker from System->Utilities->clear tracker database

pmelas ( 2015-03-05 18:54:41 +0300 )edit

Thank you, but do you really think users should go through System->Utilities->clear tracker database procedure to perform a task which is executed automatically on other devices? As far as I'm concerned, this is a very obvious bug and I'm surprised that it hasn't been fixed already.

Dubravko ( 2015-03-05 19:30:14 +0300 )edit

TBH I used that utility only once, just to recreate the tracker database, no real need tho. As a normal user, and I have few thousands of pics, few hundred videos, and 1k of songs, I never had such a problem.

pmelas ( 2015-03-05 23:55:07 +0300 )edit

I'm afraid I couldn't find 'clear tracker database' option so i selected 'Refresh media database' and now my Jolla says that I have exactly 0 pics and 0 videos in my gallery. This is precious... Well, back to terminal :-)

Dubravko ( 2015-03-06 14:08:57 +0300 )edit

Executing tracker-control -es did recover lost images and videos, but the problem still persists. It doesn't happen always, but in most cases when I select more than one photo to be deleted at once, thumbnails of deleted images remain until I exit the 'Photos' section. Btw, I don't think that I've ever had more than 100-150 photos in my gallery so it's definitely not happening because of large amount of files.

Dubravko ( 2015-03-06 16:32:44 +0300 )edit
1

answered 2014-07-29 23:06:07 +0300

Moth gravatar image

updated 2014-07-29 23:35:22 +0300

tracker-control -es

One last question: did you enter all these commands with privileged access (root)? If yes, it only works WITHOUT root access (devel-su). It results in the same CLI-output but nothing will change...

Jolla's always exciting, isn't it?

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-07-29 15:26:21 +0300

Seen: 643 times

Last updated: Mar 05 '15