Ask / Submit
3

Why doesn't Jolla work with Saunalahti's internet4 apn?

asked 2014-08-05 22:38:15 +0200

jetro gravatar image

Any website or ssh doesn't work with internet4. However ping works. I have tried it with Nokia E51 and N9 and with them it works. I think that the problem became after updating to Saapunki (1.0.7.16) version. internet.saunalahti apn works with Jolla.

edit retag flag offensive close delete

Comments

I can confirm the problem. It's quite interesting, because some operators have APNs that offer public IP without NAT as standard, and Jolla works with them. Saapunki brought us official 4G support, but that shouldn't make any difference. And with a Saunalahti 3G subscription you can't connect to Elisa's 4G network anyway.

hana ( 2014-08-06 08:34:05 +0200 )edit

I think possible explanation is that saunalahti considers jolla as 4g device now after Saapunki, and public IP:s are not allowed on 4g devices. I can not confirm this on another 4g device on 3g mode. If others works, there might be somthing on software witch makes network see it as a 4g devce even on 3g mode.

E: Nope. this is wrong.

Juha. ( 2014-08-08 22:08:48 +0200 )edit
1

Tried my sim on Lumia 1020 and internet4 was working with it so internet4 should be working on 4g devices also.

jetro ( 2014-08-09 16:30:34 +0200 )edit

1 Answer

Sort by » oldest newest most voted
5

answered 2014-08-13 00:28:37 +0200

tigeli gravatar image

Ok, found the problem. Elisa/Saunalahti is tunneling the internet4-connections and there we will need to reduce the rmnet0 mtu to 1440 to get it working. Will try to get the fix included in the next update.

edit flag offensive delete publish link more

Comments

1

As far as I know everybody is tunneling them. 3GPP has their own tunneling-protocol for that. Might be that GGSN does not do mss-clamping, but nat does.

beeki ( 2014-08-13 01:13:22 +0200 )edit

This should fix it: https://github.com/nemomobile-packages/ofono/pull/242

tigeli ( 2014-08-13 02:28:14 +0200 )edit

As I understand it, this will make 1280 the MTU for all "GPRS" connections. Isn't it better to have a list of the ones that need fixing, or an option to set the MTU in the APN configuration?

sunkan ( 2014-08-13 14:43:15 +0200 )edit
1

@sunkan It's impossible to keep "need fixing" list up to date, but option to set the MTU in the settings could be doable. However from user experience point of view the default value must be low enough which works for everyone as people really do not know what the MTU is or that they would need to set it.

1280 is the minimum MTU value for IPv6. The overhead cause by this is not huge and should guarantee that there are no more MTU issues over Internet apn's.

The best option would be if operators would not be blocking icmp-fragmentation needed-packets eg. :)

tigeli ( 2014-08-13 16:11:07 +0200 )edit
1

I understand that a list might be difficult to maintain. I would like a possibility to configure this manually if it is set lower than 1500 as a default.

Will it be possible to receive 1500 bytes packets with MTU 1280? Otherwise the opposite can happen, lets say a 1480 UDP packet comes in and the phone will drop it, once again no ICMP packet will be sent as the two nodes are not on the same MTU for the link between the phone and the "APN".

sunkan ( 2014-08-13 16:54:59 +0200 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-08-05 22:38:15 +0200

Seen: 685 times

Last updated: Aug 13 '14