Ask / Submit
5

TOH not working

asked 2014-08-08 17:44:45 +0200

jsfdez gravatar image

updated 2014-08-12 10:39:35 +0200

eric gravatar image

Hello,

TOH is not working in my phone. When I attach a TOH nothing happens, when I check tohd.service shows this.

[root@Jolla nemo]# systemctl status tohd.service
tohd.service - The Other Half Daemon (TOHD)
   Loaded: loaded (/lib/systemd/system/tohd.service; enabled)
   Active: active (running) since Fri 2014-08-08 16:36:26 CEST; 2min 41s ago
 Main PID: 741 (tohd)
   CGroup: /system.slice/tohd.service
           └─741 /usr/sbin/tohd

Aug 08 16:36:26 Jolla systemd[1]: Starting The Other Half Daemon (TOHD)...
Aug 08 16:36:26 Jolla systemd[1]: Started The Other Half Daemon (TOHD).
Aug 08 16:37:46 Jolla tohd[741]: timeout; terminating discovery

The timeout is just after attaching a TOH.

Anyone knows how to solve it?

Thank you.

edit retag flag offensive close delete

Comments

Seems to relate to this https://together.jolla.com/question/34208/bug-nfc-toh-tag-not-read/ which claimed to be fixed in update.

This is now 2nd identical issue came up with toholed owners. (Even standard Jolla TOHs will not work properly)

kimmoli ( 2014-08-08 19:50:08 +0200 )edit
1

I have the very same symptoms, and here is very non-scientific work-around of the mechnanics how I get the TOHs regogniced. I'll start putting TOH from top side (usb port side) and with my left hand thumb press and hold the NFC tag firmly onto the body. With right hand prevent the bottom part of TOH engaging, bending the TOH somewhat (be carefull not to break it). Now press the bottom part of TOH onto body with right hand and with a bit luck feel the vibration. It is bit of mystery why this is the only working way for me, surely this is not the way it is meant to work.

sconf ( 2014-08-10 12:11:47 +0200 )edit

I have the same issue. I contacted service and they suggested to send the device in because the NFC is "defect".

qrosh ( 2014-08-29 23:35:01 +0200 )edit

I have a problem with white other half and the first one other half. If a attache them nothing happens. Therefore i opened csd-tool

If no Other half is attached there is standing "Cover is not attached" and unter it "Fail" in red letters

Under TOH status information: Cover state: detached NFC state: not ready TOH Id: (nothing)

Than i attache the other half. Where was standing "Cover is not attached" now stands "Scanning...." and unter it "Fail" in red letters.

After scanning is finnished there is standing "No tag found" and under it "Fail" in red letter.

TOH status information now: Cover state: attached NFC state: ready TOH Id: (nothing)

Please help me

az2111 ( 2014-10-25 23:09:20 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-08-14 21:14:15 +0200

yabush gravatar image

I had the same problem too, and the Service and Support suggests me to send the phone back for repair.

edit flag offensive delete publish link more

Comments

Can you see the NFC tag of your TOH?

for my case, I cannot see the tag, so I am not sure if the NFC tag is defected. I ran the csd tool, it passed the NFC detection test, however no NFC tag is shown.

yabush ( 2014-08-15 05:29:16 +0200 )edit
1

image description

yabush ( 2014-08-15 06:12:38 +0200 )edit

@yabush did you send it in?

qrosh ( 2014-08-30 00:21:04 +0200 )edit

I did the repair in HK and they gave me a new phone...

yabush ( 2014-09-14 17:49:53 +0200 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2014-08-08 17:44:45 +0200

Seen: 571 times

Last updated: Aug 14 '14